aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2008-12-10 07:35:19 +0000
committerMark Linimon <linimon@FreeBSD.org>2008-12-10 07:35:19 +0000
commit55eaa1a131b33ee0607f3095fe4d473e99f180e2 (patch)
tree04ffc9024f647686e9f2653ae171b76c9181626f /lang
parentef9aaac2e2fcdde392a6ace208b9ed6e9751fbeb (diff)
downloadports-55eaa1a131b33ee0607f3095fe4d473e99f180e2.tar.gz
ports-55eaa1a131b33ee0607f3095fe4d473e99f180e2.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/bigloo/Makefile8
-rw-r--r--lang/sdcc-devel/Makefile1
-rw-r--r--lang/sdcc/Makefile4
3 files changed, 12 insertions, 1 deletions
diff --git a/lang/bigloo/Makefile b/lang/bigloo/Makefile
index 39f17cda5dec..f899de23bcc5 100644
--- a/lang/bigloo/Makefile
+++ b/lang/bigloo/Makefile
@@ -63,4 +63,10 @@ post-install:
test: build
@(cd ${WRKSRC}; ${GMAKE} test)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/sdcc-devel/Makefile b/lang/sdcc-devel/Makefile
index b0d38c649e1c..ef8766d9050b 100644
--- a/lang/sdcc-devel/Makefile
+++ b/lang/sdcc-devel/Makefile
@@ -47,6 +47,7 @@ CONFIGURE_ARGS= --datarootdir=${DATADIR} \
.if ${ARCH} == "sparc64"
CFLAGS+= -O0
CXXFLAGS+= -O0
+BROKEN= Does not compile on sparc64
.endif
.if !defined(WITHOUT_MCS51) && !defined(WITHOUT_UCSIM) && ${OSVERSION} < 500019
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index 071475b7939b..64a71d2f1de3 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -42,6 +42,10 @@ CONFIGURE_ARGS= --datarootdir=${DATADIR} \
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
.if !defined(WITHOUT_MCS51) && !defined(WITHOUT_UCSIM) && ${OSVERSION} < 500019
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif