aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-22 15:29:45 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-22 15:29:45 +0000
commitc45ffb80064e36f8f26301ef3645b6655a92f54e (patch)
tree54276cc594c692bdbfa4742da65d8038c4c60002 /lang
parent70dfc01d71acb7daf4a39c6f91efb07e55a3f52a (diff)
downloadports-c45ffb80064e36f8f26301ef3645b6655a92f54e.tar.gz
ports-c45ffb80064e36f8f26301ef3645b6655a92f54e.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index a5790e158259..3ee7170dca81 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -13,6 +13,8 @@ EXTRACT_ONLY= # empty
MAINTAINER= python@FreeBSD.org
COMMENT= "meta-port" for the default version of Python interpreter
+RUN_DEPENDS= python${PYTHON_MAJOR_VER}:lang/python${PYTHON_MAJOR_VER}
+
USES= python:run
NO_ARCH= yes
NO_BUILD= yes
@@ -23,14 +25,6 @@ PLIST_FILES= bin/2to3 \
bin/python \
bin/python-config
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_MAJOR_VER} == 2
-RUN_DEPENDS+= python2:lang/python2
-.elif ${PYTHON_MAJOR_VER} == 3
-RUN_DEPENDS+= python3:lang/python3
-.endif
-
do-install:
${LN} -sf 2to3-${PYTHON_MAJOR_VER} ${STAGEDIR}${PREFIX}/bin/2to3
.for file in idle pydoc python
@@ -71,4 +65,4 @@ upgrade-site-packages:
fi; \
fi; \
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>