aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-03-20 17:53:04 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-03-20 17:53:04 +0000
commit8a0b8a84e924ff1f7abcc4fe5f92144cdb3ccab4 (patch)
tree4059a498be6022580138b0a220950941691af075 /lang
parent29b9299658ff947a0c7f3959cff1d1635080dbbf (diff)
downloadports-8a0b8a84e924ff1f7abcc4fe5f92144cdb3ccab4.tar.gz
ports-8a0b8a84e924ff1f7abcc4fe5f92144cdb3ccab4.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc31/Makefile7
-rw-r--r--lang/gcc32/Makefile6
2 files changed, 9 insertions, 4 deletions
diff --git a/lang/gcc31/Makefile b/lang/gcc31/Makefile
index 868edb3bcdac..8d651ce6b46b 100644
--- a/lang/gcc31/Makefile
+++ b/lang/gcc31/Makefile
@@ -42,8 +42,11 @@ CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
.error You have `USE_GCC' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
-# do not require Gcc 3.1 to compile -- or we have an infinate loop on RELENG_4.
-USE_GCC= 2.7+
+# Do not let USE_GCC be set here. We can't hardcode that gcc31 should require
+# gcc31 in order to build. Setting USE_GCC at all here causes recursion errors
+# when it clobbers the USE_GCC defined by other ports.
+.undef USE_GCC
+
NOMANCOMPRESS= yes # to hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index a916096c2a0f..b491517d50c3 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -31,8 +31,10 @@ USE_REINPLACE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
-# Do not require GCC 3.2 to compile -- or we have an infinite loop on RELENG_4.
-USE_GCC= 2.7+
+# Do not let USE_GCC be set here. We can't hardcode that gcc32 should require
+# gcc32 in order to build. Setting USE_GCC at all here causes recursion errors
+# when it clobbers the USE_GCC defined by other ports.
+.undef USE_GCC
NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>