aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-10-15 19:19:48 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-10-25 05:44:07 +0000
commitff9b39f22cda90fbacb312fc5be3fe7d83b04350 (patch)
treea75c01b713a1f59c1dd43b98dd9228041d2ccb9d /lang
parentbfbb016436156657179339cee196416785b63b8a (diff)
downloadports-ff9b39f22cda90fbacb312fc5be3fe7d83b04350.tar.gz
ports-ff9b39f22cda90fbacb312fc5be3fe7d83b04350.zip
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-wx/Makefile6
-rw-r--r--lang/erlang-wx/files/patch-lib_wx_c__src_gen_wxe__wrapper__7.cpp11
2 files changed, 13 insertions, 4 deletions
diff --git a/lang/erlang-wx/Makefile b/lang/erlang-wx/Makefile
index ef132e9e472d..5c3972371a3b 100644
--- a/lang/erlang-wx/Makefile
+++ b/lang/erlang-wx/Makefile
@@ -1,7 +1,7 @@
PORTNAME= erlang
DISTVERSIONPREFIX= OTP-
DISTVERSION= 24.3.4.6
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= lang parallel
PKGNAMESUFFIX= -wx
@@ -21,9 +21,7 @@ USE_GITHUB= yes
GH_PROJECT= otp
USE_GL= gl glu
USE_PERL5= build
-USE_WX= 3.1+
-
-WX_COMPS= wx
+USE_WX= 3.2+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-threads \
diff --git a/lang/erlang-wx/files/patch-lib_wx_c__src_gen_wxe__wrapper__7.cpp b/lang/erlang-wx/files/patch-lib_wx_c__src_gen_wxe__wrapper__7.cpp
new file mode 100644
index 000000000000..11f2b1475b49
--- /dev/null
+++ b/lang/erlang-wx/files/patch-lib_wx_c__src_gen_wxe__wrapper__7.cpp
@@ -0,0 +1,11 @@
+--- lib/wx/c_src/gen/wxe_wrapper_7.cpp.orig 2022-10-15 17:50:46 UTC
++++ lib/wx/c_src/gen/wxe_wrapper_7.cpp
+@@ -2339,7 +2339,7 @@ void wxToolBar_AddTool_4(WxeApp *app, wxeMemEnv *memen
+ } else Badarg("Options");
+ };
+ if(!This) throw wxe_badarg("This");
+- wxToolBarToolBase * Result = (wxToolBarToolBase*)This->AddTool(toolId,label,*bitmap,shortHelp,kind);
++ wxToolBarToolBase * Result = (wxToolBarToolBase*)This->AddTool(toolId,label,(wxBitmapBundle)*bitmap,shortHelp,kind);
+ wxeReturn rt = wxeReturn(memenv, Ecmd.caller, true);
+ rt.send( rt.make_ref(app->getRef((void *)Result,memenv), "wx"));
+