aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-30 13:30:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-30 13:30:53 +0000
commitcece986586705821cc60b570714c3769bb4a0419 (patch)
treed6b0be03ace45ea849c31a46e53949b8e1fe61eb /lang
parent82898481f2e3650eb6a2350ff6351a15edefa26e (diff)
downloadports-cece986586705821cc60b570714c3769bb4a0419.tar.gz
ports-cece986586705821cc60b570714c3769bb4a0419.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/moscow_ml/Makefile8
-rw-r--r--lang/moscow_ml/files/patch-config::auto_aux::endian.c22
2 files changed, 23 insertions, 7 deletions
diff --git a/lang/moscow_ml/Makefile b/lang/moscow_ml/Makefile
index 0db0aa23fe95..26cc9a07ec60 100644
--- a/lang/moscow_ml/Makefile
+++ b/lang/moscow_ml/Makefile
@@ -27,12 +27,6 @@ USE_PERL5= yes
USE_REINPLACE= yes
MAKE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= "Configure fails on sparc64"
-.endif
-
post-patch:
${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
${REINPLACE_CMD} -e "s,-O2,${CFLAGS} -I${LOCALBASE}/include,"
@@ -51,4 +45,4 @@ post-install:
if [ -f $${file} ]; then \
$(LN) -sf $${file} $(PREFIX)/bin; fi; done
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/moscow_ml/files/patch-config::auto_aux::endian.c b/lang/moscow_ml/files/patch-config::auto_aux::endian.c
new file mode 100644
index 000000000000..6242749ff309
--- /dev/null
+++ b/lang/moscow_ml/files/patch-config::auto_aux::endian.c
@@ -0,0 +1,22 @@
+--- config/auto-aux/endian.c.orig Fri Jan 21 11:07:13 2000
++++ config/auto-aux/endian.c Sat Jan 29 21:40:20 2005
+@@ -1,3 +1,5 @@
++#include <sys/endian.h>
++
+ main()
+ {
+ long n[2];
+@@ -6,9 +8,11 @@
+ n[0] = 0x41424344;
+ n[1] = 0;
+ p = (char *) n;
+- if (strcmp(p, "ABCD") == 0)
++#if BYTE_ORDER == BIG_ENDIAN
+ exit(0);
+- if (strcmp(p, "DCBA") == 0)
++#elif BYTE_ORDER == LITTLE_ENDIAN
+ exit(1);
++#else
+ exit(2);
++#endif
+ }