aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-03-26 05:16:44 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-03-26 05:16:44 +0000
commit989fbabdf9d4ec35e4aea8e8e667c2ecef19e90f (patch)
treef7229687d1ac14f35036636d27ba0e6a42ec297c /lang
parentc7ad79395c28c22b8161a13abfd6d1e20475cc0f (diff)
downloadports-989fbabdf9d4ec35e4aea8e8e667c2ecef19e90f.tar.gz
ports-989fbabdf9d4ec35e4aea8e8e667c2ecef19e90f.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc/Makefile4
-rw-r--r--lang/gcc/files/gcc.sh.in14
-rw-r--r--lang/gcc/pkg-plist1
-rw-r--r--lang/gcc40/Makefile4
-rw-r--r--lang/gcc40/files/gcc.sh.in14
-rw-r--r--lang/gcc40/pkg-plist1
-rw-r--r--lang/gcc41/Makefile4
-rw-r--r--lang/gcc41/files/gcc.sh.in14
-rw-r--r--lang/gcc41/pkg-plist1
-rw-r--r--lang/gcc42/Makefile4
-rw-r--r--lang/gcc42/files/gcc.sh.in14
-rw-r--r--lang/gcc42/pkg-plist1
-rw-r--r--lang/gcc43/Makefile4
-rw-r--r--lang/gcc43/files/gcc.sh.in14
-rw-r--r--lang/gcc43/pkg-plist1
-rw-r--r--lang/gcc44/Makefile4
-rw-r--r--lang/gcc44/files/gcc.sh.in14
-rw-r--r--lang/gcc44/pkg-plist1
-rw-r--r--lang/gcc45/Makefile4
-rw-r--r--lang/gcc45/files/gcc.sh.in14
-rw-r--r--lang/gcc45/pkg-plist1
-rw-r--r--lang/gcc46/Makefile4
-rw-r--r--lang/gcc46/files/gcc.sh.in14
-rw-r--r--lang/gcc46/pkg-plist1
-rw-r--r--lang/gcc47/Makefile4
-rw-r--r--lang/gcc47/files/gcc.sh.in14
-rw-r--r--lang/gcc47/pkg-plist1
-rw-r--r--lang/gcc48/Makefile4
-rw-r--r--lang/gcc48/files/gcc.sh.in14
-rw-r--r--lang/gcc48/pkg-plist1
30 files changed, 190 insertions, 0 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index f8cfb0e9a587..b77324cd4827 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -76,6 +76,9 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -149,6 +152,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc/files/gcc.sh.in b/lang/gcc/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/lang/gcc/pkg-plist b/lang/gcc/pkg-plist
index c354ad32d65c..f79172c39695 100644
--- a/lang/gcc/pkg-plist
+++ b/lang/gcc/pkg-plist
@@ -9,6 +9,7 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+etc/rc.d/gcc%%SUFFIX%%.sh
include/omp.h
info/gcc%%SUFFIX%%/dir
%%FORTRAN%%bin/gfortran%%SUFFIX%%
diff --git a/lang/gcc40/Makefile b/lang/gcc40/Makefile
index 255548c09489..99fad93b31d2 100644
--- a/lang/gcc40/Makefile
+++ b/lang/gcc40/Makefile
@@ -57,6 +57,9 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -90,6 +93,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc40/files/gcc.sh.in b/lang/gcc40/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc40/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/lang/gcc40/pkg-plist b/lang/gcc40/pkg-plist
index af92003847f0..d34fedef390d 100644
--- a/lang/gcc40/pkg-plist
+++ b/lang/gcc40/pkg-plist
@@ -9,5 +9,6 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+etc/rc.d/gcc%%SUFFIX%%.sh
info/gcc%%SUFFIX%%/dir
@comment Insert PLIST.lib here
diff --git a/lang/gcc41/Makefile b/lang/gcc41/Makefile
index 1ec3edfd8487..7159e1454da5 100644
--- a/lang/gcc41/Makefile
+++ b/lang/gcc41/Makefile
@@ -76,6 +76,9 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -146,6 +149,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc41/files/gcc.sh.in b/lang/gcc41/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc41/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/lang/gcc41/pkg-plist b/lang/gcc41/pkg-plist
index 5fdc2d7941d0..867fee686215 100644
--- a/lang/gcc41/pkg-plist
+++ b/lang/gcc41/pkg-plist
@@ -9,6 +9,7 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+etc/rc.d/gcc%%SUFFIX%%.sh
info/gcc%%SUFFIX%%/dir
%%FORTRAN%%bin/gfortran%%SUFFIX%%
%%FORTRAN%%bin/%%GNU_HOST%%-gfortran%%SUFFIX%%
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index f8cfb0e9a587..b77324cd4827 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -76,6 +76,9 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -149,6 +152,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc42/files/gcc.sh.in b/lang/gcc42/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc42/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/lang/gcc42/pkg-plist b/lang/gcc42/pkg-plist
index c354ad32d65c..f79172c39695 100644
--- a/lang/gcc42/pkg-plist
+++ b/lang/gcc42/pkg-plist
@@ -9,6 +9,7 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+etc/rc.d/gcc%%SUFFIX%%.sh
include/omp.h
info/gcc%%SUFFIX%%/dir
%%FORTRAN%%bin/gfortran%%SUFFIX%%
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index f8cfb0e9a587..b77324cd4827 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -76,6 +76,9 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -149,6 +152,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc43/files/gcc.sh.in b/lang/gcc43/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc43/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/lang/gcc43/pkg-plist b/lang/gcc43/pkg-plist
index c354ad32d65c..f79172c39695 100644
--- a/lang/gcc43/pkg-plist
+++ b/lang/gcc43/pkg-plist
@@ -9,6 +9,7 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+etc/rc.d/gcc%%SUFFIX%%.sh
include/omp.h
info/gcc%%SUFFIX%%/dir
%%FORTRAN%%bin/gfortran%%SUFFIX%%
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index f8cfb0e9a587..b77324cd4827 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -76,6 +76,9 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -149,6 +152,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc44/files/gcc.sh.in b/lang/gcc44/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc44/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/lang/gcc44/pkg-plist b/lang/gcc44/pkg-plist
index c354ad32d65c..f79172c39695 100644
--- a/lang/gcc44/pkg-plist
+++ b/lang/gcc44/pkg-plist
@@ -9,6 +9,7 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+etc/rc.d/gcc%%SUFFIX%%.sh
include/omp.h
info/gcc%%SUFFIX%%/dir
%%FORTRAN%%bin/gfortran%%SUFFIX%%
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index f8cfb0e9a587..b77324cd4827 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -76,6 +76,9 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -149,6 +152,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc45/files/gcc.sh.in b/lang/gcc45/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc45/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/lang/gcc45/pkg-plist b/lang/gcc45/pkg-plist
index c354ad32d65c..f79172c39695 100644
--- a/lang/gcc45/pkg-plist
+++ b/lang/gcc45/pkg-plist
@@ -9,6 +9,7 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+etc/rc.d/gcc%%SUFFIX%%.sh
include/omp.h
info/gcc%%SUFFIX%%/dir
%%FORTRAN%%bin/gfortran%%SUFFIX%%
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index f8cfb0e9a587..b77324cd4827 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -76,6 +76,9 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -149,6 +152,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc46/files/gcc.sh.in b/lang/gcc46/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc46/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/lang/gcc46/pkg-plist b/lang/gcc46/pkg-plist
index c354ad32d65c..f79172c39695 100644
--- a/lang/gcc46/pkg-plist
+++ b/lang/gcc46/pkg-plist
@@ -9,6 +9,7 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+etc/rc.d/gcc%%SUFFIX%%.sh
include/omp.h
info/gcc%%SUFFIX%%/dir
%%FORTRAN%%bin/gfortran%%SUFFIX%%
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index f8cfb0e9a587..b77324cd4827 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -76,6 +76,9 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -149,6 +152,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc47/files/gcc.sh.in b/lang/gcc47/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc47/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/lang/gcc47/pkg-plist b/lang/gcc47/pkg-plist
index c354ad32d65c..f79172c39695 100644
--- a/lang/gcc47/pkg-plist
+++ b/lang/gcc47/pkg-plist
@@ -9,6 +9,7 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+etc/rc.d/gcc%%SUFFIX%%.sh
include/omp.h
info/gcc%%SUFFIX%%/dir
%%FORTRAN%%bin/gfortran%%SUFFIX%%
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index f8cfb0e9a587..b77324cd4827 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -76,6 +76,9 @@ MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${TARGLIB}
+SUB_LIST= TARGLIB="${TARGLIB}"
+SUB_FILES= gcc.sh
+RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -149,6 +152,7 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc48/files/gcc.sh.in b/lang/gcc48/files/gcc.sh.in
new file mode 100644
index 000000000000..987e9531e371
--- /dev/null
+++ b/lang/gcc48/files/gcc.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ ldconfig -m %%TARGLIB%%
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: ${0##*/} { start | stop }" >&2
+ exit 64
+ ;;
+esac
+exit 0
diff --git a/lang/gcc48/pkg-plist b/lang/gcc48/pkg-plist
index c354ad32d65c..f79172c39695 100644
--- a/lang/gcc48/pkg-plist
+++ b/lang/gcc48/pkg-plist
@@ -9,6 +9,7 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+etc/rc.d/gcc%%SUFFIX%%.sh
include/omp.h
info/gcc%%SUFFIX%%/dir
%%FORTRAN%%bin/gfortran%%SUFFIX%%