aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-05-07 05:39:33 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-05-07 05:39:33 +0000
commitcd74272ff95255310bd3f925c38cdab2a247a3d9 (patch)
tree0b5ca35235dc7dbe5e8bbe5d22515ed277851b68 /lang
parent99e9b5792b737d752368cba6e1b676d525a333f9 (diff)
downloadports-cd74272ff95255310bd3f925c38cdab2a247a3d9.tar.gz
ports-cd74272ff95255310bd3f925c38cdab2a247a3d9.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python-devel/Makefile25
-rw-r--r--lang/python/Makefile23
-rw-r--r--lang/python23/Makefile23
-rw-r--r--lang/python24/Makefile23
-rw-r--r--lang/python25/Makefile25
-rw-r--r--lang/python26/Makefile25
-rw-r--r--lang/python27/Makefile25
-rw-r--r--lang/python30/Makefile25
-rw-r--r--lang/python31/Makefile25
-rw-r--r--lang/python32/Makefile25
10 files changed, 127 insertions, 117 deletions
diff --git a/lang/python-devel/Makefile b/lang/python-devel/Makefile
index d88b5e0bcd2a..9123c5f9471f 100644
--- a/lang/python-devel/Makefile
+++ b/lang/python-devel/Makefile
@@ -36,27 +36,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -64,8 +67,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else
@@ -166,7 +167,7 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
-
+
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.4 ${WRKDIR}/idle2.4 \
${PREFIX}/bin
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 5bee1a4457bc..149b35f9877d 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -38,27 +38,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -66,8 +69,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 5bee1a4457bc..149b35f9877d 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -38,27 +38,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -66,8 +69,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 5bee1a4457bc..149b35f9877d 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -38,27 +38,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -66,8 +69,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else
diff --git a/lang/python25/Makefile b/lang/python25/Makefile
index d88b5e0bcd2a..9123c5f9471f 100644
--- a/lang/python25/Makefile
+++ b/lang/python25/Makefile
@@ -36,27 +36,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -64,8 +67,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else
@@ -166,7 +167,7 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
-
+
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.4 ${WRKDIR}/idle2.4 \
${PREFIX}/bin
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index d88b5e0bcd2a..9123c5f9471f 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -36,27 +36,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -64,8 +67,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else
@@ -166,7 +167,7 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
-
+
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.4 ${WRKDIR}/idle2.4 \
${PREFIX}/bin
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index d88b5e0bcd2a..9123c5f9471f 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -36,27 +36,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -64,8 +67,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else
@@ -166,7 +167,7 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
-
+
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.4 ${WRKDIR}/idle2.4 \
${PREFIX}/bin
diff --git a/lang/python30/Makefile b/lang/python30/Makefile
index d88b5e0bcd2a..9123c5f9471f 100644
--- a/lang/python30/Makefile
+++ b/lang/python30/Makefile
@@ -36,27 +36,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -64,8 +67,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else
@@ -166,7 +167,7 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
-
+
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.4 ${WRKDIR}/idle2.4 \
${PREFIX}/bin
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index d88b5e0bcd2a..9123c5f9471f 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -36,27 +36,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -64,8 +67,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else
@@ -166,7 +167,7 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
-
+
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.4 ${WRKDIR}/idle2.4 \
${PREFIX}/bin
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index d88b5e0bcd2a..9123c5f9471f 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -36,27 +36,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -64,8 +67,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else
@@ -166,7 +167,7 @@ post-install:
${INSTALL_PROGRAM} \
${SHARED_WRKSRC}/${PYTHON_VERSION:S/thon/thon-shared/} \
${PREFIX}/bin
-
+
@# additional files installing by ports
${INSTALL_SCRIPT} ${WRKDIR}/pydoc2.4 ${WRKDIR}/idle2.4 \
${PREFIX}/bin