aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-11 20:09:42 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-10-01 02:20:03 +0000
commit070200f93538ba29ed33a884d7ad28e4f801b843 (patch)
tree47bf97a24cc1e4cdcab55cf4883c20cc72edbd1f /lang
parent3f6bad55641032cde86017118b289fff4a2aa0f5 (diff)
downloadports-070200f93538ba29ed33a884d7ad28e4f801b843.tar.gz
ports-070200f93538ba29ed33a884d7ad28e4f801b843.zip
devel/intel-graphics-compiler: add llvm12 (beta) flavor
Diffstat (limited to 'lang')
-rw-r--r--lang/intel-compute-runtime/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index 47168dd162bf..ebd3ab1e73e2 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -2,6 +2,7 @@ PORTNAME= compute-runtime
DISTVERSION= 21.37.20939
CATEGORIES= lang
PKGNAMEPREFIX= intel-
+PKGNAMESUFFIX= -${FLAVOR}
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= aa5a39a2db79.patch:-p1 # https://github.com/intel/compute-runtime/pull/361
@@ -15,9 +16,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= Only Intel GPUs on x86 are supported
-LIB_DEPENDS= libigc.so:devel/intel-graphics-compiler \
+LIB_DEPENDS= libigc.so:devel/intel-graphics-compiler@${FLAVOR} \
libigdgmm.so:multimedia/gmmlib
+FLAVORS= ${12 11:L:S/^/llvm/}
+
+CONFLICTS_INSTALL= ${PORTNAME}-*
+
USES= cmake compiler:c++17-lang localbase:ldflags pkgconfig
USE_GITHUB= yes
USE_LDCONFIG= yes