aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /lang
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/compaq-cc/Makefile4
-rw-r--r--lang/freetxl/Makefile9
-rw-r--r--lang/icc/Makefile8
-rw-r--r--lang/icc7/Makefile6
-rw-r--r--lang/ifc/Makefile7
-rw-r--r--lang/ifc7/Makefile6
-rw-r--r--lang/linux-j/Makefile2
-rw-r--r--lang/visualworks/Makefile2
8 files changed, 23 insertions, 21 deletions
diff --git a/lang/compaq-cc/Makefile b/lang/compaq-cc/Makefile
index e767565034b4..c3067af81f74 100644
--- a/lang/compaq-cc/Makefile
+++ b/lang/compaq-cc/Makefile
@@ -40,9 +40,7 @@ EXTRACT_AFTER_ARGS= |${CPIO} -idum
EXTRACT_ONLY=
NO_WRKSUBDIR= yes
NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
-NO_MTREE= yes
-USE_LINUX?= yes
+USE_LINUX= yes
.include <bsd.port.pre.mk>
diff --git a/lang/freetxl/Makefile b/lang/freetxl/Makefile
index f7e5a843154d..9fa645c87cc9 100644
--- a/lang/freetxl/Makefile
+++ b/lang/freetxl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freetxl
PORTVERSION= 10.3
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.sasknow.com/pub/txl/
DISTNAME= txl${PORTVERSION}.linux
@@ -14,15 +15,17 @@ DISTNAME= txl${PORTVERSION}.linux
MAINTAINER= ryan@sasknow.com
COMMENT= The TXL Programming Language (transformation by example)
-USE_LINUX?= yes
-STRIP=
-NO_BUILD= yes
+USE_LINUX= yes
MAN1= txl.1 txlc.1 txldb.1 txlp.1
PORTDOCS= 00README.txt COPYRIGHT.txt Documents.html Examples.html \
FILES.txt Learning.html Support.html
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/txl \
+ ${WRKSRC}/bin/txldb
+
do-install:
${INSTALL_PROGRAM} \
${WRKSRC}/bin/txl \
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 623f73484a05..f4bde4aef709 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -18,7 +18,7 @@ PATCHLEVEL= ${PORTVERSION:C/(.+p)(.+)$/pe\2/}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
.if ${PORTVERSION} != ${PATCHLEVEL}
DISTFILES+= ${DISTNAME}_${PATCHLEVEL}${EXTRACT_SUFX}
-PATCH_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
+PATCH_DEPENDS= ${LINUX_BASE_PORT}
.endif
EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
@@ -30,9 +30,8 @@ NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
CONFLICTS= linux_devtools*
-USE_LINUX?= yes
+USE_LINUX= yes
USE_REINPLACE= yes
-NO_FILTER_SHLIBS= yes
COMPILERDIR= intel_cc_80
PLIST_SUB= COMPILERDIR=${COMPILERDIR}
@@ -219,7 +218,8 @@ do-build:
@${CC} ${CFLAGS} -o \
${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld \
${FILESDIR}/ld.c
- @${STRIP_CMD} ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
+# We can't use STRIP_CMD, since we need the FreeBSD one, not the Linux one.
+ @/usr/bin/strip ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
@${CHMOD} 755 ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
# Make ICC happy with regards to crtbegin.o, crtend.o and libgcc.a which it
# expects to find in GXX_ROOT.
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index 2b53d3fc3c7b..1aab74063658 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -25,10 +25,9 @@ NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
CONFLICTS= linux_devtools* ifc*
-USE_LINUX?= yes
+USE_LINUX= yes
USE_REINPLACE= yes
NO_WRKSUBDIR= yes
-NO_FILTER_SHLIBS= yes
COMPILERDIR= compiler70
PLIST_SUB= COMPILERDIR=${COMPILERDIR}
@@ -160,7 +159,8 @@ do-build:
@${CC} ${CFLAGS} -o \
${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld \
${FILESDIR}/ld.c
- @${STRIP_CMD} ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
+# We can't use STRIP_CMD, since we need the FreeBSD one, not the Linux one.
+ @/usr/bin/strip ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
@${CHMOD} 755 ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
do-install:
diff --git a/lang/ifc/Makefile b/lang/ifc/Makefile
index 4287cd8a7603..9865fd6d544c 100644
--- a/lang/ifc/Makefile
+++ b/lang/ifc/Makefile
@@ -18,7 +18,7 @@ PATCHLEVEL= ${PORTVERSION:C/(.+p)(.+)$/pe\2/}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
.if ${PORTVERSION} != ${PATCHLEVEL}
DISTFILES+= ${DISTNAME}_${PATCHLEVEL}${EXTRACT_SUFX}
-PATCH_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
+PATCH_DEPENDS= ${LINUX_BASE_PORT}
.endif
EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
@@ -30,7 +30,7 @@ NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
CONFLICTS= linux_devtools*
-USE_LINUX?= yes
+USE_LINUX= yes
USE_REINPLACE= yes
NO_FILTER_SHLIBS= yes
@@ -191,7 +191,8 @@ do-build:
@${CC} ${CFLAGS} -o \
${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld \
${FILESDIR}/ld.c
- @${STRIP_CMD} ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
+# We can't use STRIP_CMD, since we need the FreeBSD one, not the Linux one.
+ @/usr/bin/strip ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
@${CHMOD} 755 ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
do-install:
diff --git a/lang/ifc7/Makefile b/lang/ifc7/Makefile
index d5cb8fd02ad6..06eed2750ba0 100644
--- a/lang/ifc7/Makefile
+++ b/lang/ifc7/Makefile
@@ -24,10 +24,9 @@ NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
-USE_LINUX?= yes
+USE_LINUX= yes
USE_REINPLACE= yes
NO_WRKSUBDIR= yes
-NO_FILTER_SHLIBS= yes
COMPILERDIR= compiler70
PLIST_SUB= COMPILERDIR=${COMPILERDIR}
@@ -158,7 +157,8 @@ do-build:
@${CC} ${CFLAGS} -o \
${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld \
${FILESDIR}/ld.c
- @${STRIP_CMD} ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
+# We can't use STRIP_CMD, since we need the FreeBSD one, not the Linux one.
+ @/usr/bin/strip ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
@${CHMOD} 755 ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
do-install:
diff --git a/lang/linux-j/Makefile b/lang/linux-j/Makefile
index f041750145ff..8d2fcbf86667 100644
--- a/lang/linux-j/Makefile
+++ b/lang/linux-j/Makefile
@@ -17,7 +17,7 @@ COMMENT= A general purpose programming language
RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
-USE_LINUX?= yes
+USE_LINUX= yes
USE_JAVA= yes
JAVA_VERSION= 1.3+
diff --git a/lang/visualworks/Makefile b/lang/visualworks/Makefile
index 22f46ff08290..74d71e8f1aa7 100644
--- a/lang/visualworks/Makefile
+++ b/lang/visualworks/Makefile
@@ -18,7 +18,7 @@ EXTRACT_ONLY=
MAINTAINER= chris@chrisburkert.de
COMMENT= A high performance Smalltalk environment
-USE_LINUX?= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
PLIST_FILES= bin/visual