aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-12-12 17:25:50 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-12-12 17:25:50 +0000
commit2919df34f8a097ffab6c5bd556dbf7e0e79d5360 (patch)
treef9e7fffa16dca375e98baaf3303dda5648fcdc12 /lang
parentf3c616b5542b95a93a0c0c33ba17ad1016b65376 (diff)
downloadports-2919df34f8a097ffab6c5bd556dbf7e0e79d5360.tar.gz
ports-2919df34f8a097ffab6c5bd556dbf7e0e79d5360.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc32/Makefile27
-rw-r--r--lang/gcc32/files/extrapatch-libjava__configure16
-rw-r--r--lang/gcc32/files/patch-ub32
-rw-r--r--lang/gcc32/pkg-plist9
-rw-r--r--lang/gcc32/pkg-plist.libgcj9
5 files changed, 4 insertions, 89 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index f5d61f74d3b5..b36705ac16f6 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -17,7 +17,6 @@ DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
gcc-testsuite-${PORTVERSION}${EXTRACT_SUFX} \
gcc-g++-${PORTVERSION}${EXTRACT_SUFX} \
gcc-g77-${PORTVERSION}${EXTRACT_SUFX} \
- gcc-java-${PORTVERSION}${EXTRACT_SUFX} \
gcc-objc-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER?= ports@FreeBSD.org
@@ -36,17 +35,9 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 502101
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-gcc__config__freebsd-spec.h \
- ${FILESDIR}/extrapatch-libjava__configure
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-gcc__config__freebsd-spec.h
.endif
-.if ${ARCH} == "sparc64" || ${ARCH} == "ia64" || ${ARCH} == "amd64"
-# libgcj is built on all platforms except sparc64 and ia64 and amd64
-WITHOUT_LIBJAVA=yes
-.endif
-.if ${ARCH} == "ia64"
-BROKEN= gcj does not build.
-.endif
.if ${ARCH} == "amd64"
BROKEN= linker: unrecognised emulation mode: elf_x86_64
.endif
@@ -87,14 +78,9 @@ CONFIGURE_ARGS+= --enable-threads
# ?is this an ObjC only thing?
CONFIGURE_ARGS+= --enable-threads=posix
.endif
-.if defined(WITHOUT_LIBJAVA)
-CONFIGURE_ARGS+= --disable-libgcj
-.endif
ALL_TARGET= bootstrap
-MAN1= cpp32.1 g++32.1 g77-32.1 gcc32.1 gcov32.1 \
- gcj32.1 gcjh32.1 gij.1 rmic.1 rmiregistry.1 \
- jcf-dump32.1 jv-scan32.1 jv-convert.1
+MAN1= cpp32.1 g++32.1 g77-32.1 gcc32.1 gcov32.1
MAN7= fsf-funding.7 gfdl.7 gpl.7
pre-configure:
@@ -123,7 +109,7 @@ post-install:
do \
${STRIP_CMD} $$prog ; \
done )
-.for file in gcc g++ cpp g++filt gcov ${CONFIGURE_TARGET}-gcc ${CONFIGURE_TARGET}-g++ gcj gcjh jv-scan jcf-dump jar grepjar
+.for file in gcc g++ cpp g++filt gcov ${CONFIGURE_TARGET}-gcc ${CONFIGURE_TARGET}-g++
${MV} -f ${PREFIX}/bin/${file} ${PREFIX}/bin/${file}32
( ${TEST} ! -e ${PREFIX}/man/man1/${file}.1 \
|| ${MV} -f ${PREFIX}/man/man1/${file}.1 \
@@ -142,11 +128,9 @@ post-install:
${MV} -f ${PREFIX}/lib/${file}.* ${TARGLIB}
.endfor
-${MV} -f ${PREFIX}/lib/ieee ${TARGLIB}
- # Java
- -${MV} -f ${PREFIX}/lib/libgcj.* ${TARGLIB}
${RM} -f ${PREFIX}/lib/libiberty.a
${RM} -f ${TARGLIB}/*.la
-.for info in cpp cppinternals g77 gcc gcj
+.for info in cpp cppinternals g77 gcc
install-info ${PREFIX}/info/${info}.info ${PREFIX}/info/dir
.endfor
# I am sick and tired of the anonyance that man pages can only be generated if
@@ -169,8 +153,5 @@ post-install:
${ECHO_CMD} "x!" >> ${WRKDIR}/ex.script
${CP} -p ${TMPPLIST} ${TMPPLIST}.pre-gcc-lib
cd ${WRKDIR} ; ex < ex.script
-.if !defined(WITHOUT_LIBJAVA)
- ${CAT} ${MASTERDIR}/pkg-plist.libgcj >> ${TMPPLIST}
-.endif
.include <bsd.port.post.mk>
diff --git a/lang/gcc32/files/extrapatch-libjava__configure b/lang/gcc32/files/extrapatch-libjava__configure
deleted file mode 100644
index d4f8f909e7bc..000000000000
--- a/lang/gcc32/files/extrapatch-libjava__configure
+++ /dev/null
@@ -1,16 +0,0 @@
---- libjava/configure.orig Sun Nov 7 17:50:53 2004
-+++ libjava/configure Sun Nov 7 17:51:38 2004
-@@ -3221,13 +3221,6 @@
- # support for weak references to pthread_* functions ala gthr.h API.
- THREADSPEC='%{!pthread: %eUnder this configuration, the user must provide -pthread when linking.}'
- ;;
-- *-*-freebsd*)
-- # FreeBSD 5 implements a model much closer to other modern UNIX
-- # which support threads. However, it still does not support
-- # -lpthread.
-- THREADLDFLAGS=-pthread
-- THREADSPEC=-lc_r
-- ;;
- *)
- THREADLIBS=-lpthread
- THREADSPEC=-lpthread
diff --git a/lang/gcc32/files/patch-ub b/lang/gcc32/files/patch-ub
deleted file mode 100644
index 920e228f5edb..000000000000
--- a/lang/gcc32/files/patch-ub
+++ /dev/null
@@ -1,32 +0,0 @@
---- gcc/java/gjavah.c.orig Wed Feb 5 20:39:02 2003
-+++ gcc/java/gjavah.c Wed Feb 5 20:43:53 2003
-@@ -750,10 +750,14 @@
- jfloat fnum = JPOOL_FLOAT (jcf, current_field_value);
- fputs ("const jfloat ", out);
- print_field_name (out, jcf, name_index, 0);
-+#ifdef __alpha__
-+ fputs (";\n", out);
-+#else
- if (! java_float_finite (fnum))
- fputs (";\n", out);
- else
- fprintf (out, " = %.10g;\n", fnum);
-+#endif
- }
- break;
- case CONSTANT_Double:
-@@ -761,10 +765,14 @@
- jdouble dnum = JPOOL_DOUBLE (jcf, current_field_value);
- fputs ("const jdouble ", out);
- print_field_name (out, jcf, name_index, 0);
-+#ifdef __alpha__
-+ fputs (";\n", out);
-+#else
- if (! java_double_finite (dnum))
- fputs (";\n", out);
- else
- fprintf (out, " = %.17g;\n", dnum);
-+#endif
- }
- break;
- default:
diff --git a/lang/gcc32/pkg-plist b/lang/gcc32/pkg-plist
index 12d32171d412..84928e6c478a 100644
--- a/lang/gcc32/pkg-plist
+++ b/lang/gcc32/pkg-plist
@@ -8,12 +8,6 @@ bin/gcov32
bin/%%GNU_HOST%%-gcc32
bin/%%GNU_HOST%%-g++32
bin/gccbug-%%PORTVERSION%%
-bin/gcj32
-bin/gcjh32
-bin/jv-scan32
-bin/jcf-dump32
-bin/jar32
-bin/grepjar32
@comment Insert PLIST.gcc-lib here
@comment -=[ begin PLIST.gcc-lib ]=-
@comment -=[ end PLIST.gcc-lib ]=-
@@ -22,16 +16,13 @@ bin/grepjar32
@unexec install-info --delete %D/info/g77.info %D/info/dir
@unexec install-info --delete %D/info/gcc.info %D/info/dir
@unexec install-info --delete %D/info/gccint.info %D/info/dir
-@unexec install-info --delete %D/info/gcj.info %D/info/dir
info/cpp.info
info/cppinternals.info
info/g77.info
info/gcc.info
info/gccint.info
-info/gcj.info
@exec install-info %D/info/cpp.info %D/info/dir
@exec install-info %D/info/cppinternals.info %D/info/dir
@exec install-info %D/info/g77.info %D/info/dir
@exec install-info %D/info/gcc.info %D/info/dir
@exec install-info %D/info/gccint.info %D/info/dir
-@exec install-info %D/info/gcj.info %D/info/dir
diff --git a/lang/gcc32/pkg-plist.libgcj b/lang/gcc32/pkg-plist.libgcj
deleted file mode 100644
index 54fc8573bd31..000000000000
--- a/lang/gcc32/pkg-plist.libgcj
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/addr2name.awk
-bin/gij
-bin/jv-convert
-bin/rmic
-bin/rmiregistry
-lib/security/classpath.security
-lib/security/libgcj.security
-share/java/libgcj-3.2.3.jar
-@dirrm lib/security