aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-10-10 02:32:50 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-10-10 02:32:50 +0000
commit5e7fc97192475bf9f2382b7b079d0e7b511739dd (patch)
tree9ba473f5b0111a21862297a62b26f85cd54f3bdd /lang
parentf6509b9465bf20443342fa8dcd8d45b742fbaac8 (diff)
downloadports-5e7fc97192475bf9f2382b7b079d0e7b511739dd.tar.gz
ports-5e7fc97192475bf9f2382b7b079d0e7b511739dd.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gforth/Makefile4
-rw-r--r--lang/gforth/files/patch-configure17
2 files changed, 15 insertions, 6 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index dacbfed03c73..0c146a3a1c81 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -59,13 +59,13 @@ BROKEN= Does not compile
.endif
.endif
-.if ${ARCH} == i386
+.if ${ARCH} == i386 || ${ARCH} == "powerpc"
WORDSIZE=32
.else
WORDSIZE=64
.endif
-.if ${ARCH} == sparc64
+.if ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BYTEORDER=b
.else
BYTEORDER=l
diff --git a/lang/gforth/files/patch-configure b/lang/gforth/files/patch-configure
index 0bad37060869..dfe8191ccbbe 100644
--- a/lang/gforth/files/patch-configure
+++ b/lang/gforth/files/patch-configure
@@ -1,6 +1,16 @@
---- configure.orig Sat Oct 21 02:49:22 2006
-+++ configure Sat Oct 21 02:49:27 2006
-@@ -8079,8 +8079,8 @@
+--- configure.orig 2003-08-25 10:03:42.000000000 +0200
++++ configure 2010-10-09 20:40:43.000000000 +0200
+@@ -3584,9 +3584,6 @@
+ else
+ LIBOBJS="$LIBOBJS ../arch/power/_sync_cache_range.$ac_objext"
+ fi
+-
+- #long long is broken on (at least) gcc-2.95.* for PPC
+- test x$ac_cv_sizeof_long_long = x && ac_cv_sizeof_long_long=0
+ ;;
+ *)
+ { echo "$as_me:$LINENO: WARNING: Using a generic machine description" >&5
+@@ -8079,8 +8076,8 @@
if (x) {
label1:
asm("$i");
@@ -9,4 +19,3 @@
+ label2:
return (&&label2)-(&&label1);
}
-