aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-10-29 11:26:34 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-10-29 11:26:34 +0000
commit95e90fe8b854166f144d0c8004077434d4d201cf (patch)
tree6532bea5f5e91d4b50a2bd4ce2ee728e2d0f8dc6 /lang
parent6661d5ac1132f3c64a8b502b3b4e1e6ba611e98d (diff)
downloadports-95e90fe8b854166f144d0c8004077434d4d201cf.tar.gz
ports-95e90fe8b854166f144d0c8004077434d4d201cf.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/nawk/distinfo2
-rw-r--r--lang/nawk/files/patch-aa18
-rw-r--r--lang/nawk/files/patch-ba2
3 files changed, 15 insertions, 7 deletions
diff --git a/lang/nawk/distinfo b/lang/nawk/distinfo
index 77eb0d97ea56..73112418209b 100644
--- a/lang/nawk/distinfo
+++ b/lang/nawk/distinfo
@@ -1 +1 @@
-MD5 (awk.tar.gz) = 65f0afae31a1ed77dd21de5a15be570d
+MD5 (awk.tar.gz) = 1e2ef4bce7e538c8bf513ac21120bb26
diff --git a/lang/nawk/files/patch-aa b/lang/nawk/files/patch-aa
index 8ba84e6c94b8..90a6473df217 100644
--- a/lang/nawk/files/patch-aa
+++ b/lang/nawk/files/patch-aa
@@ -1,18 +1,26 @@
---- makefile.orig Tue Jan 1 06:50:28 2002
-+++ makefile Mon Feb 18 01:45:54 2002
-@@ -25,3 +25,3 @@
+--- makefile.orig Sat Jun 29 03:30:04 2002
++++ makefile Tue Oct 29 22:22:31 2002
+@@ -22,15 +22,15 @@
+ # THIS SOFTWARE.
+ # ****************************************************************/
+
-CFLAGS = -g
-CFLAGS = -O2
-CFLAGS =
+#CFLAGS = -g
+#CFLAGS = -O2
+CFLAGS ?= -O
-@@ -29,4 +29,4 @@
+
+-CC = gcc -Wall -g -Wwrite-strings
-CC = gcc -Wall -g
-CC = /opt/SUNWspro/bin/cc
-CC = /opt/pure/purify/purify cc
-CC = cc
++CC ?= cc
++CC := ${CC} -Wall -g -Wwrite-strings
+#CC = gcc -Wall -g
+#CC = /opt/SUNWspro/bin/cc
+#CC = /opt/pure/purify/purify cc
-+CC ?= cc
+
+ YACC = bison -y
+ YACC = yacc
diff --git a/lang/nawk/files/patch-ba b/lang/nawk/files/patch-ba
index 8c2df0c544cf..b5281c377b16 100644
--- a/lang/nawk/files/patch-ba
+++ b/lang/nawk/files/patch-ba
@@ -32,7 +32,7 @@
+}
+#endif
+
- fa *makedfa(char *s, int anchor) /* returns dfa for reg expr s */
+ fa *makedfa(const char *s, int anchor) /* returns dfa for reg expr s */
{
int i, use, nuse;
@@ -287,6 +308,9 @@