aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-12-08 08:38:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-12-08 08:38:06 +0000
commita167e294e9d7dbee3a77070305ac4ae8c6b96c08 (patch)
treee62b862dca96c4a6aa1d921da367030d8532c5c8 /lang
parenta138150d5d41fe2fca7f3f30273226c672fe9abd (diff)
downloadports-a167e294e9d7dbee3a77070305ac4ae8c6b96c08.tar.gz
ports-a167e294e9d7dbee3a77070305ac4ae8c6b96c08.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/munger/Makefile31
-rw-r--r--lang/munger/distinfo2
-rw-r--r--lang/munger/pkg-descr16
-rw-r--r--lang/munger/pkg-plist24
5 files changed, 74 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 20f02ad21541..a1ea8d70ca7f 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -140,6 +140,7 @@
SUBDIR += mono
SUBDIR += moscow_ml
SUBDIR += mozart
+ SUBDIR += munger
SUBDIR += nawk
SUBDIR += nhc98
SUBDIR += nickle
diff --git a/lang/munger/Makefile b/lang/munger/Makefile
new file mode 100644
index 000000000000..d574294d354c
--- /dev/null
+++ b/lang/munger/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: munger
+# Date created: Thu, 03 Jul 2003 20:05:06 EDT
+# Whom: James Bailie <jimmy@jamesbailie.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= munger
+PORTVERSION= 4.38
+CATEGORIES= lang
+MASTER_SITES= http://jamesbailie.com/
+
+MAINTAINER= jimmy@jamesbailie.com
+COMMENT= Static LISP interpreter with text processing abilities
+
+LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
+
+.if defined(WITH_SQL)
+LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite
+.endif
+
+.if defined(WITH_FCGI)
+LIB_DEPENDS+= fcgi.0:${PORTSDIR}/www/fcgi
+.endif
+
+MAN1= munger.1 httpf.1 xml2munger.1
+MANCOMPRESSED= yes
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+.include <bsd.port.mk>
diff --git a/lang/munger/distinfo b/lang/munger/distinfo
new file mode 100644
index 000000000000..f6b695ed7c07
--- /dev/null
+++ b/lang/munger/distinfo
@@ -0,0 +1,2 @@
+MD5 (munger-4.38.tar.gz) = f32dd47fc5f622125842d0f80224b02f
+SIZE (munger-4.38.tar.gz) = 168540
diff --git a/lang/munger/pkg-descr b/lang/munger/pkg-descr
new file mode 100644
index 000000000000..fd02bc829e42
--- /dev/null
+++ b/lang/munger/pkg-descr
@@ -0,0 +1,16 @@
+Munger is a simple, statically-scoped, interpreted lisp that has
+line-editor-like access to multiple text buffers. Lines can be inserted,
+removed, overwritten, retrieved in whole or in part, with or without tabs
+expanded, searched for matches on regular expressions, read from and written
+to files, and piped to and from, or filtered through external processes.
+
+Using regular expressions to search through or transform strings is easy in
+Munger. Basic facilities for doing line-oriented I/O and cursor-addressing
+are provided. Munger also has interfaces to the FastCGI devkit
+(http://www.fastcgi.com), and the SQLite library (http://www.sqlite.org).
+
+WWW: http://jamesbailie.com/munger.html
+
+--
+James Bailie <jimmy@jamesbailie.com>
+http://jamesbailie.com
diff --git a/lang/munger/pkg-plist b/lang/munger/pkg-plist
new file mode 100644
index 000000000000..a5806cb3eb22
--- /dev/null
+++ b/lang/munger/pkg-plist
@@ -0,0 +1,24 @@
+bin/munger
+bin/httpf
+bin/xml2munger
+share/munger-%%VERSION%%/mbox2munger.munger
+share/munger-%%VERSION%%/mime2munger.munger
+share/munger-%%VERSION%%/google.munger
+share/munger-%%VERSION%%/google.template
+share/munger-%%VERSION%%/ed.munger
+share/munger-%%VERSION%%/xml2lisp.munger
+share/munger-%%VERSION%%/xml2lisp2.munger
+share/munger-%%VERSION%%/xmlquery.munger
+share/munger-%%VERSION%%/filter.munger
+share/munger-%%VERSION%%/tags.munger
+share/munger-%%VERSION%%/fcgi.munger
+share/munger-%%VERSION%%/client.fcgi
+share/munger-%%VERSION%%/err.munger
+share/munger-%%VERSION%%/options.munger
+share/munger-%%VERSION%%/fmt.munger
+share/munger-%%VERSION%%/cat.munger
+share/munger-%%VERSION%%/grep.munger
+share/munger-%%VERSION%%/library.munger
+share/munger-%%VERSION%%/transform.munger
+share/munger-%%VERSION%%/view.munger
+@dirrm share/munger-%%VERSION%%