aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-05-29 21:16:54 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-05-29 21:16:54 +0000
commitd9141c0fa1187a427566c637d2bde948cbf7b4eb (patch)
tree77883023f4a38067cc79c50fb859fe78151bd62f /lang
parent5b36cf09a5a99a4a19eb283d477a920363c7da15 (diff)
downloadports-d9141c0fa1187a427566c637d2bde948cbf7b4eb.tar.gz
ports-d9141c0fa1187a427566c637d2bde948cbf7b4eb.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby-devel/Makefile4
-rw-r--r--lang/ruby/Makefile4
-rw-r--r--lang/ruby16/Makefile4
-rw-r--r--lang/ruby18/Makefile4
4 files changed, 16 insertions, 0 deletions
diff --git a/lang/ruby-devel/Makefile b/lang/ruby-devel/Makefile
index 9750862c02ce..b63cca701637 100644
--- a/lang/ruby-devel/Makefile
+++ b/lang/ruby-devel/Makefile
@@ -32,6 +32,10 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby${_RUBY_SUFFIX}.1
MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
+.if !defined(WITH_LIBC_R)
+CONFIGURE_ARGS+= --with_libc_r=no
+.endif
+
.include <bsd.port.pre.mk>
.if !empty(RUBY_SUFFIX)
diff --git a/lang/ruby/Makefile b/lang/ruby/Makefile
index 1f8a1ddd12aa..320e62366c30 100644
--- a/lang/ruby/Makefile
+++ b/lang/ruby/Makefile
@@ -30,6 +30,10 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby${_RUBY_SUFFIX}.1
MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
+.if !defined(WITH_LIBC_R)
+CONFIGURE_ARGS+= --with_libc_r=no
+.endif
+
.include <bsd.port.pre.mk>
.if !empty(RUBY_SUFFIX)
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 1f8a1ddd12aa..320e62366c30 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -30,6 +30,10 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby${_RUBY_SUFFIX}.1
MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
+.if !defined(WITH_LIBC_R)
+CONFIGURE_ARGS+= --with_libc_r=no
+.endif
+
.include <bsd.port.pre.mk>
.if !empty(RUBY_SUFFIX)
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 9750862c02ce..b63cca701637 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -32,6 +32,10 @@ CONFIGURE_ARGS= --enable-shared
MAN1= ruby${_RUBY_SUFFIX}.1
MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
+.if !defined(WITH_LIBC_R)
+CONFIGURE_ARGS+= --with_libc_r=no
+.endif
+
.include <bsd.port.pre.mk>
.if !empty(RUBY_SUFFIX)