aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-03-22 08:59:52 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-03-22 08:59:52 +0000
commitdce05b6781beaf86496c1f247853bc5a213984ed (patch)
tree1959c048c393510177a5e4e5f6034e6f7535e660 /lang
parentbe1494f3f15647722790c4ae8d07994eb403f3c6 (diff)
downloadports-dce05b6781beaf86496c1f247853bc5a213984ed.tar.gz
ports-dce05b6781beaf86496c1f247853bc5a213984ed.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/python/Makefile2
-rw-r--r--lang/python23/Makefile2
-rw-r--r--lang/python24/Makefile2
-rw-r--r--lang/stackless_python/Makefile10
4 files changed, 12 insertions, 4 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 38af9f6aa5a9..3fd4cb0ff30a 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -121,7 +121,7 @@ pre-patch:
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
-post-configure:
+post-configure: ${STACKLESS_POST_CONFIGURE}
@# prepare a subdir for shared build
.for subdir in Modules Parser Python Objects
${MKDIR} ${SHARED_WRKSRC}/${subdir}
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index 38af9f6aa5a9..3fd4cb0ff30a 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -121,7 +121,7 @@ pre-patch:
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
-post-configure:
+post-configure: ${STACKLESS_POST_CONFIGURE}
@# prepare a subdir for shared build
.for subdir in Modules Parser Python Objects
${MKDIR} ${SHARED_WRKSRC}/${subdir}
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 38af9f6aa5a9..3fd4cb0ff30a 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -121,7 +121,7 @@ pre-patch:
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
-post-configure:
+post-configure: ${STACKLESS_POST_CONFIGURE}
@# prepare a subdir for shared build
.for subdir in Modules Parser Python Objects
${MKDIR} ${SHARED_WRKSRC}/${subdir}
diff --git a/lang/stackless_python/Makefile b/lang/stackless_python/Makefile
index 3fa0a9bbebab..2ee0fbad3e12 100644
--- a/lang/stackless_python/Makefile
+++ b/lang/stackless_python/Makefile
@@ -24,7 +24,8 @@ COMMENT= Python implementation that does not use the C stack
CONFLICTS= python-2.3.*
ONLY_FOR_ARCHS= i386 powerpc
CVSDATE= 040225
-MASTERDIR= ${.CURDIR}/../../lang/python
+MASTERDIR= ${.CURDIR}/../python
+STACKLESS_POST_CONFIGURE= stackless-post-configure
DESCR= ${.CURDIR}/pkg-descr
MD5_FILE= ${.CURDIR}/distinfo
@@ -44,4 +45,11 @@ post-patch:
.endfor
@${CAT} ${MASTERDIR}/pkg-plist >>${PLIST}
+stackless-post-configure:
+ ${MKDIR} -p ${SHARED_WRKSRC}/Stackless
+ ${LN} -sf ${WRKSRC}/Stackless/slp_transfer.c \
+ ${SHARED_WRKSRC}/Stackless/slp_transfer.c
+ ${LN} -sf ${WRKSRC}/Stackless/*.h ${SHARED_WRKSRC}/Stackless/
+
+
.include "${MASTERDIR}/Makefile"