aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-05-31 11:24:06 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-05-31 11:24:06 +0000
commitf1e287ac3c751132a0a19c609fec7f7ce8637e04 (patch)
tree0917d267321b6fa94d23c1c16483825b238739d8 /lang
parent4630de4ed75f93975262733d9e15ae015d81b6ef (diff)
downloadports-f1e287ac3c751132a0a19c609fec7f7ce8637e04.tar.gz
ports-f1e287ac3c751132a0a19c609fec7f7ce8637e04.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/spl/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/lang/spl/Makefile b/lang/spl/Makefile
index 48c49206ae26..5f532df2002a 100644
--- a/lang/spl/Makefile
+++ b/lang/spl/Makefile
@@ -14,8 +14,6 @@ MASTER_SITES= http://shakespearelang.sourceforge.net/download/
MAINTAINER= perky@FreeBSD.org
COMMENT= The Shakespeare programming language
-BROKEN= Installs during build phase
-
USE_BISON= yes
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -24,13 +22,13 @@ ALL_EXAMPLES= Makefile fibonacci.spl fibonacci2.spl guess.spl hello.spl \
primes.spl reverse.spl shakesbeer.spl
post-patch:
- @for f in ${WRKSRC}/Makefile ${WRKSRC}/examples/Makefile; do \
- ${REINPLACE_CMD} -i "" -e 's,= gcc,?= gcc,' -e 's,^CCFLAGS.*,CFLAGS += -Wall,' \
- -e 's,CCFLAGS,CFLAGS,g' -e 's,^SPLPATH =.*,SPLPATH =${PREFIX},g' \
- -e 's, spl/, ${PREFIX}/,g' $$f; \
- done
+.for f in . examples
+ ${REINPLACE_CMD} -e 's,= gcc,?= gcc,' -e 's,^CCFLAGS.*,CFLAGS += -Wall,' \
+ -e 's,CCFLAGS,CFLAGS,g' ${WRKSRC}/${f}/Makefile
+.endfor
-post-install:
+do-install:
+ ${TAR} -C ${WRKSRC}/spl -cf - . | ${TAR} -C ${PREFIX} -xf -
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${INSTALL_DATA} ${ALL_EXAMPLES} ${EXAMPLESDIR}