aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-09-14 13:32:06 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-09-14 13:32:06 +0000
commit4fe6852b8fc27fae11fdc1a2e6a04519dff79d2d (patch)
tree3c0e8bfe673a5c1e30efc1a8f7c2fa62a73243fc /lang
parentaa0a6b33abb64a760dac34854c5336e9dd14e0c3 (diff)
downloadports-4fe6852b8fc27fae11fdc1a2e6a04519dff79d2d.tar.gz
ports-4fe6852b8fc27fae11fdc1a2e6a04519dff79d2d.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc295/Makefile4
-rw-r--r--lang/gcc31/Makefile4
-rw-r--r--lang/perl5.6/Makefile4
-rw-r--r--lang/perl5/Makefile4
4 files changed, 16 insertions, 0 deletions
diff --git a/lang/gcc295/Makefile b/lang/gcc295/Makefile
index b6f8482a3a80..afc8c93d76ab 100644
--- a/lang/gcc295/Makefile
+++ b/lang/gcc295/Makefile
@@ -21,6 +21,10 @@ USE_BZIP2= yes
LATEST_LINK= gcc295
+.ifdef USE_GCC
+.error You have `USE_GCC' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
GCC_REV= ${DISTNAME:S/gcc-//g:S/.test3//g}
diff --git a/lang/gcc31/Makefile b/lang/gcc31/Makefile
index 0b92fb1c433e..630eac1230de 100644
--- a/lang/gcc31/Makefile
+++ b/lang/gcc31/Makefile
@@ -79,6 +79,10 @@ MAN1= cpp31.1 g++31.1 g77-31.1 gcc31.1 gcov31.1 \
jcf-dump31.1 jv-scan31.1 jv-convert.1
MAN7= fsf-funding.7 gfdl.7 gpl.7
+.ifdef USE_GCC
+.error You have `USE_GCC' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
pre-fetch:
@${ECHO} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} ${PORTOBJFORMAT} target ${CONFIGURE_TARGET}"
diff --git a/lang/perl5.6/Makefile b/lang/perl5.6/Makefile
index 943341d19ed3..d88341c43852 100644
--- a/lang/perl5.6/Makefile
+++ b/lang/perl5.6/Makefile
@@ -50,6 +50,10 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
INCLUDEDIR= /usr/include
+.ifdef USE_PERL5
+.error You have `USE_PERL5' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
MAN1= a2p.1 c2ph.1 dprofpp.1 find2perl.1 h2ph.1 h2xs.1 perl.1 \
diff --git a/lang/perl5/Makefile b/lang/perl5/Makefile
index 943341d19ed3..d88341c43852 100644
--- a/lang/perl5/Makefile
+++ b/lang/perl5/Makefile
@@ -50,6 +50,10 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
INCLUDEDIR= /usr/include
+.ifdef USE_PERL5
+.error You have `USE_PERL5' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+.endif
+
.include <bsd.port.pre.mk>
MAN1= a2p.1 c2ph.1 dprofpp.1 find2perl.1 h2ph.1 h2xs.1 perl.1 \