aboutsummaryrefslogtreecommitdiff
path: root/mail/akpop3d/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-10-01 09:38:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-10-01 09:38:30 +0000
commit67ff26d3ebfc1eabfe585b0ed08a3c9881756931 (patch)
treefc775187982de2e54c0f04be2181b452e8815e3c /mail/akpop3d/Makefile
parentb8796f0d82a8c2bb4d9aea85ac3524a3578cea7f (diff)
downloadports-67ff26d3ebfc1eabfe585b0ed08a3c9881756931.tar.gz
ports-67ff26d3ebfc1eabfe585b0ed08a3c9881756931.zip
Notes
Diffstat (limited to 'mail/akpop3d/Makefile')
-rw-r--r--mail/akpop3d/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/mail/akpop3d/Makefile b/mail/akpop3d/Makefile
index 95c9fef7426c..e0b9d66b7b17 100644
--- a/mail/akpop3d/Makefile
+++ b/mail/akpop3d/Makefile
@@ -9,17 +9,20 @@ MASTER_SITES= http://www.synflood.at/akpop3d/
MAINTAINER= ports@FreeBSD.org
COMMENT= POP3 daemon aimed to be small and secure
-PLIST_FILES= bin/akpop3d man/man8/akpop3d.8.gz
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= tar:bzip2
+USES= tar:bzip2
GNU_CONFIGURE= yes
-.if defined(WITH_SSL)
-USES+= ssl
-CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-CPPFLAGS+= -I${OPENSSLBASE}/include
-LDFLAGS+= -L${OPENSSLBASE}/lib -lssl -lcrypto
-.endif
+PLIST_FILES= bin/akpop3d man/man8/akpop3d.8.gz
+
+OPTIONS_DEFINE= SSL
+
+SSL_USES= ssl
+SSL_CONFIGURE_WITH= openssl=${OPENSSLBASE}
+SSL_CPPFLAGS= -I${OPENSSLBASE}/include
+SSL_LDFLAGS= -L${OPENSSLBASE}/lib
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/akpop3d ${STAGEDIR}${PREFIX}/bin