aboutsummaryrefslogtreecommitdiff
path: root/mail/alpine/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2017-01-11 22:15:48 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2017-01-11 22:15:48 +0000
commit5de0576005d2dde45d5f8943d7d7c3c7da48bd53 (patch)
tree76a4187075504353ecb0f242d92acab88c7720aa /mail/alpine/Makefile
parent6ea3691c992d57259799cd163590ab19cfa93984 (diff)
downloadports-5de0576005d2dde45d5f8943d7d7c3c7da48bd53.tar.gz
ports-5de0576005d2dde45d5f8943d7d7c3c7da48bd53.zip
Notes
Diffstat (limited to 'mail/alpine/Makefile')
-rw-r--r--mail/alpine/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/mail/alpine/Makefile b/mail/alpine/Makefile
index 63d32c038ce4..2190d97fd39a 100644
--- a/mail/alpine/Makefile
+++ b/mail/alpine/Makefile
@@ -35,6 +35,12 @@ MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
+THREADS_CONFIGURE_WITH= pthread
+MOUSE_CONFIGURE_ENABLE= mouse
+NLS_CONFIGURE_ENABLE= nls
+IPV6_CONFIGURE_WITH= ipv6
+SSL_USES= ssl
+
.if !defined(PICO_ALPINE_SLAVE)
PORTDOCSbase= LICENSE NOTICE README
@@ -60,15 +66,12 @@ MAKE_ARGS+= CC="${CC}" CXX="${CXX}" GCCCFLAGS="${CFLAGS}"
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
-USE_OPENSSL= yes
-
CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLDIR} \
--with-ssl-include-dir=${OPENSSLINC} \
--with-ssl-lib-dir=${OPENSSLLIB} \
--with-ssl-certs-dir=${OPENSSLDIR}/certs
.else
CONFIGURE_ARGS+= --without-ssl
-USE_OPENSSL= no
.endif
.include <bsd.port.pre.mk>
@@ -77,11 +80,6 @@ USE_OPENSSL= no
BROKEN= Does not build with openssl-devel
.endif
-THREADS_CONFIGURE_WITH= pthread
-MOUSE_CONFIGURE_ENABLE= mouse
-NLS_CONFIGURE_ENABLE= nls
-IPV6_CONFIGURE_WITH= ipv6
-
.if ! ${PORT_OPTIONS:MNOSPELL}
.if ! ${PORT_OPTIONS:MISPELL}
CONFIGURE_ARGS+=--with-interactive-spellcheck=${LOCALBASE}/bin/aspell