aboutsummaryrefslogtreecommitdiff
path: root/mail/alpine
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-05-30 20:43:05 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-05-30 20:43:05 +0000
commit5af61e0cddc23ddf508f752386dc55c4aa0f3ae4 (patch)
tree901bc0faf724640a50e83bc6318e3f6710577909 /mail/alpine
parent2675af52ac69dc42f656da7a0e890cb5c0a63d1c (diff)
downloadports-5af61e0cddc23ddf508f752386dc55c4aa0f3ae4.tar.gz
ports-5af61e0cddc23ddf508f752386dc55c4aa0f3ae4.zip
Notes
Diffstat (limited to 'mail/alpine')
-rw-r--r--mail/alpine/Makefile2
-rw-r--r--mail/alpine/files/patch-newuser381
2 files changed, 382 insertions, 1 deletions
diff --git a/mail/alpine/Makefile b/mail/alpine/Makefile
index 824b9b4c51f6..410634a49cfc 100644
--- a/mail/alpine/Makefile
+++ b/mail/alpine/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= alpine
PORTVERSION= 2.00
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= mail news ipv6
MASTER_SITES= ftp://ftp.cac.washington.edu/alpine/ \
http://dougbarton.us/Downloads/alpine-${PORTVERSION}/
diff --git a/mail/alpine/files/patch-newuser b/mail/alpine/files/patch-newuser
new file mode 100644
index 000000000000..ebfc59d4eada
--- /dev/null
+++ b/mail/alpine/files/patch-newuser
@@ -0,0 +1,381 @@
+diff -ur /home/dougb-f/alpine-2.00/alpine/Makefile.am ./alpine/Makefile.am
+--- /home/dougb-f/alpine-2.00/alpine/Makefile.am 2008-06-03 08:54:15.000000000 -0700
++++ ./alpine/Makefile.am 2011-05-22 14:43:01.000000000 -0700
+@@ -19,7 +19,7 @@
+ alpine_SOURCES = addrbook.c adrbkcmd.c after.c alpine.c arg.c busy.c colorconf.c \
+ confscroll.c context.c dispfilt.c flagmaint.c folder.c help.c imap.c \
+ init.c kblock.c keymenu.c ldapconf.c listsel.c mailcmd.c mailindx.c \
+- mailpart.c mailview.c newuser.c pattern.c pipe.c print.c radio.c remote.c reply.c \
++ mailpart.c mailview.c pattern.c pipe.c print.c radio.c remote.c reply.c \
+ roleconf.c send.c setup.c signal.c status.c takeaddr.c titlebar.c smime.c
+
+ alpine_LDADD = $(LDADD) $(INTLLIBS)
+diff -ur /home/dougb-f/alpine-2.00/alpine/Makefile.in ./alpine/Makefile.in
+--- /home/dougb-f/alpine-2.00/alpine/Makefile.in 2008-06-03 08:54:15.000000000 -0700
++++ ./alpine/Makefile.in 2011-05-22 14:43:14.000000000 -0700
+@@ -68,7 +68,7 @@
+ help.$(OBJEXT) imap.$(OBJEXT) init.$(OBJEXT) kblock.$(OBJEXT) \
+ keymenu.$(OBJEXT) ldapconf.$(OBJEXT) listsel.$(OBJEXT) \
+ mailcmd.$(OBJEXT) mailindx.$(OBJEXT) mailpart.$(OBJEXT) \
+- mailview.$(OBJEXT) newuser.$(OBJEXT) pattern.$(OBJEXT) \
++ mailview.$(OBJEXT) pattern.$(OBJEXT) \
+ pipe.$(OBJEXT) print.$(OBJEXT) radio.$(OBJEXT) \
+ remote.$(OBJEXT) reply.$(OBJEXT) roleconf.$(OBJEXT) \
+ send.$(OBJEXT) setup.$(OBJEXT) signal.$(OBJEXT) \
+@@ -271,7 +271,7 @@
+ alpine_SOURCES = addrbook.c adrbkcmd.c after.c alpine.c arg.c busy.c colorconf.c \
+ confscroll.c context.c dispfilt.c flagmaint.c folder.c help.c imap.c \
+ init.c kblock.c keymenu.c ldapconf.c listsel.c mailcmd.c mailindx.c \
+- mailpart.c mailview.c newuser.c pattern.c pipe.c print.c radio.c remote.c reply.c \
++ mailpart.c mailview.c pattern.c pipe.c print.c radio.c remote.c reply.c \
+ roleconf.c send.c setup.c signal.c status.c takeaddr.c titlebar.c smime.c
+
+ alpine_LDADD = $(LDADD) $(INTLLIBS)
+@@ -388,7 +388,6 @@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mailindx.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mailpart.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mailview.Po@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/newuser.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pattern.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pipe.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/print.Po@am__quote@
+diff -ur /home/dougb-f/alpine-2.00/alpine/alpine.c ./alpine/alpine.c
+--- /home/dougb-f/alpine-2.00/alpine/alpine.c 2008-06-03 15:31:05.000000000 -0700
++++ ./alpine/alpine.c 2011-05-22 14:42:15.000000000 -0700
+@@ -49,7 +49,6 @@
+ #include "init.h"
+ #include "remote.h"
+ #include "pattern.h"
+-#include "newuser.h"
+ #include "setup.h"
+ #include "adrbkcmd.h"
+ #include "signal.h"
+@@ -762,7 +761,6 @@
+ pine_state->mangled_header = 1;
+ show_main_screen(pine_state, 0, FirstMenu, &main_keymenu, 0,
+ (Pos *) NULL);
+- new_user_or_version(pine_state);
+ ClearScreen();
+ }
+
+diff -ur /home/dougb-f/alpine-2.00/alpine/mailview.c ./alpine/mailview.c
+--- /home/dougb-f/alpine-2.00/alpine/mailview.c 2008-08-01 17:32:26.000000000 -0700
++++ ./alpine/mailview.c 2011-05-22 14:42:15.000000000 -0700
+@@ -177,7 +177,6 @@
+ int url_local_nntp(char *);
+ int url_local_news(char *);
+ int url_local_file(char *);
+-int url_local_phone_home(char *);
+ static int print_to_printer(SCROLL_S *);
+ int search_text(int, long, int, char **, Pos *, int *);
+ void update_scroll_titlebar(long, int);
+@@ -1697,7 +1696,6 @@
+ {"news:", 5, url_local_news},
+ {"x-alpine-gripe:", 15, gripe_gripe_to},
+ {"x-alpine-help:", 14, url_local_helper},
+- {"x-alpine-phone-home:", 20, url_local_phone_home},
+ {"x-alpine-config:", 16, url_local_config},
+ {"x-alpine-cert:", 14, url_local_certdetails},
+ {"#", 1, url_local_fragment},
+@@ -2252,14 +2250,6 @@
+ }
+
+
+-int
+-url_local_phone_home(char *url)
+-{
+- phone_home(url + strlen("x-alpine-phone-home:"));
+- return(2);
+-}
+-
+-
+ /*
+ * Format editorial comment referencing screen offering
+ * List-* header supplied commands
+diff -ur /home/dougb-f/alpine-2.00/alpine/makefile.wnt ./alpine/makefile.wnt
+--- /home/dougb-f/alpine-2.00/alpine/makefile.wnt 2007-10-24 14:58:00.000000000 -0700
++++ ./alpine/makefile.wnt 2011-05-22 14:42:15.000000000 -0700
+@@ -44,13 +44,13 @@
+ addrbook.h adrbkcmd.h after.h alpine.h arg.h busy.h colorconf.h confscroll.h \
+ conftype.h context.h dispfilt.h flagmaint.h folder.h headers.h help.h imap.h \
+ init.h kblock.h keymenu.h ldapconf.h listsel.h mailcmd.h mailindx.h mailpart.h \
+- mailview.h newuser.h pattern.h pipe.h print.h radio.h remote.h reply.h roleconf.h \
++ mailview.h pattern.h pipe.h print.h radio.h remote.h reply.h roleconf.h \
+ send.h setup.h signal.h status.h takeaddr.h talk.h titlebar.h
+
+ OFILES= addrbook.obj adrbkcmd.obj after.obj alpine.obj arg.obj busy.obj colorconf.obj \
+ confscroll.obj context.obj dispfilt.obj flagmaint.obj folder.obj help.obj \
+ imap.obj init.obj kblock.obj keymenu.obj ldapconf.obj listsel.obj mailcmd.obj \
+- mailindx.obj mailpart.obj mailview.obj newuser.obj pattern.obj pipe.obj \
++ mailindx.obj mailpart.obj mailview.obj pattern.obj pipe.obj \
+ print.obj radio.obj remote.obj reply.obj roleconf.obj \
+ send.obj setup.obj signal.obj status.obj takeaddr.obj titlebar.obj
+
+diff -ur /home/dougb-f/alpine-2.00/alpine/send.c ./alpine/send.c
+--- /home/dougb-f/alpine-2.00/alpine/send.c 2008-06-30 15:03:35.000000000 -0700
++++ ./alpine/send.c 2011-05-22 14:42:15.000000000 -0700
+@@ -70,8 +70,6 @@
+ PARAMETER *parameter;
+ } BODY_PARTICULARS_S;
+
+-#define PHONE_HOME_VERSION "-count"
+-#define PHONE_HOME_HOST "docserver.cac.washington.edu"
+
+ /*
+ * macro to bind pico's headerentry pointer to PINEFIELD "extdata" hook
+@@ -5462,63 +5460,6 @@
+
+
+ /*----------------------------------------------------------------------
+- Generate and send a message back to the pine development team
+-
+-Args: none
+-
+-Returns: none
+-----*/
+-void
+-phone_home(char *addr)
+-{
+- char tmp[MAX_ADDRESS];
+- ENVELOPE *outgoing;
+- BODY *body;
+-
+- outgoing = mail_newenvelope();
+- if(!addr || !strindex(addr, '@')){
+- snprintf(addr = tmp, sizeof(tmp), "alpine%s@%s", PHONE_HOME_VERSION, PHONE_HOME_HOST);
+- tmp[sizeof(tmp)-1] = '\0';
+- }
+-
+- rfc822_parse_adrlist(&outgoing->to, addr, ps_global->maildomain);
+-
+- outgoing->message_id = generate_message_id();
+- outgoing->subject = cpystr("Document Request");
+- outgoing->from = phone_home_from();
+-
+- body = mail_newbody();
+- body->type = TYPETEXT;
+-
+- if((body->contents.text.data = (void *)so_get(PicoText,NULL,EDIT_ACCESS)) != NULL){
+- so_puts((STORE_S *)body->contents.text.data, "Document request: ");
+- so_puts((STORE_S *)body->contents.text.data, "Alpine-");
+- so_puts((STORE_S *)body->contents.text.data, ALPINE_VERSION);
+- if(ps_global->first_time_user)
+- so_puts((STORE_S *)body->contents.text.data, " for New Users");
+-
+- if(ps_global->VAR_INBOX_PATH && ps_global->VAR_INBOX_PATH[0] == '{')
+- so_puts((STORE_S *)body->contents.text.data, " and IMAP");
+-
+- if(ps_global->VAR_NNTP_SERVER && ps_global->VAR_NNTP_SERVER[0]
+- && ps_global->VAR_NNTP_SERVER[0][0])
+- so_puts((STORE_S *)body->contents.text.data, " and NNTP");
+-
+- (void)pine_simple_send(outgoing, &body, NULL,NULL,NULL,NULL, SS_NULLRP);
+-
+- q_status_message(SM_ORDER, 1, 3, "Thanks for being counted!");
+- }
+- else
+- q_status_message(SM_ORDER | SM_DING, 3, 4,
+- "Problem creating space for message text.");
+-
+- mail_free_envelope(&outgoing);
+- pine_free_body(&body);
+-
+-}
+-
+-
+-/*----------------------------------------------------------------------
+ Set up fields for passing to pico. Assumes first text part is
+ intended to be passed along for editing, and is in the form of
+ of a storage object brought into existence sometime before pico_send().
+diff -ur /home/dougb-f/alpine-2.00/alpine/send.h ./alpine/send.h
+--- /home/dougb-f/alpine-2.00/alpine/send.h 2007-08-16 15:25:10.000000000 -0700
++++ ./alpine/send.h 2011-05-22 14:42:15.000000000 -0700
+@@ -41,7 +41,6 @@
+ void pine_send(ENVELOPE *, BODY **, char *, ACTION_S *, char *, REPLY_S *,
+ REDRAFT_POS_S *, char *, PINEFIELD *, int);
+ int upload_msg_to_pico(char *, size_t, long *);
+-void phone_home(char *);
+ void create_message_body(BODY **, PATMT *, int);
+ char *pine_send_status(int, char *, char *, size_t, int *);
+ int confirm_daemon_send(void);
+diff -ur /home/dougb-f/alpine-2.00/pith/filter.c ./pith/filter.c
+--- /home/dougb-f/alpine-2.00/pith/filter.c 2008-08-21 16:50:47.000000000 -0700
++++ ./pith/filter.c 2011-05-22 14:42:15.000000000 -0700
+@@ -7510,8 +7510,6 @@
+ HD(f)->bitbucket = 0;
+ else if(!strucmp(s, "running"))
+ HD(f)->bitbucket = 0;
+- else if(!strucmp(s, "phone_home") && ps_global->phone_home)
+- HD(f)->bitbucket = 0;
+ #ifdef _WINDOWS
+ else if(!strucmp(s, "os_windows"))
+ HD(f)->bitbucket = 0;
+diff -ur /home/dougb-f/alpine-2.00/pith/pine.hlp ./pith/pine.hlp
+--- /home/dougb-f/alpine-2.00/pith/pine.hlp 2008-08-22 17:07:05.000000000 -0700
++++ ./pith/pine.hlp 2011-05-22 14:42:15.000000000 -0700
+@@ -1204,21 +1204,7 @@
+ We hope you will explore Alpine's many capabilities. From the MAIN MENU,
+ select Setup/Config to see many of the options available to you. Also note
+ that all screens have context-sensitive help text available.<P>
+-<!--chtml if pinemode="phone_home"-->
+-SPECIAL REQUEST:
+-This software is made available world-wide as a public service of the
+-University of Washington in Seattle. In order to justify continuing
+-development, it is helpful to have an idea of how many people are using
+-Alpine. Are you willing to be counted as an Alpine user? Pressing
+-<A HREF="X-Alpine-Phone-Home:">Return</A>
+-will send an anonymous (meaning, your real email address will not be revealed)
+-message to the Alpine development team at the University of Washington for
+-purposes of tallying.
+-<P>
+-<!--To Exit this screen and continue your Alpine session press "E".-->
+-<!--chtml else-->
+ To Exit this screen and continue your Alpine session press "Return".
+-<!--chtml endif-->
+ </BODY>
+ </HTML>
+ ===== new_alpine_user_greeting ======
+@@ -1238,21 +1224,7 @@
+ The Release Notes may be viewed by pressing
+ &quot;R&quot; now or while in the MAIN MENU.
+ <P>
+-<!--chtml if pinemode="phone_home"-->
+-SPECIAL REQUEST:
+-This software is made available world-wide as a public service of the
+-University of Washington in Seattle. In order to justify continuing
+-development, it is helpful to have an idea of how many people are using
+-Alpine. Are you willing to be counted as an Alpine user? Pressing
+-<A HREF="X-Alpine-Phone-Home:">Return</A>
+-will send an anonymous (meaning, your real email address will not be revealed)
+-message to the Alpine development team at the University of Washington for
+-purposes of tallying.
+-<P>
+-<!--To Exit this screen and continue your Alpine session press "E".-->
+-<!--chtml else-->
+ To Exit this screen and continue your Alpine session press "Return".
+-<!--chtml endif-->
+ </BODY>
+ </HTML>
+ ===== new_version_greeting ======
+@@ -1269,21 +1241,7 @@
+ documented in the Release Notes, which may be viewed by pressing
+ &quot;R&quot; now or while in the MAIN MENU.
+ <P>
+-<!--chtml if pinemode="phone_home"-->
+-SPECIAL REQUEST:
+-This software is made available world-wide as a public service of the
+-University of Washington in Seattle. In order to justify continuing
+-development, it is helpful to have an idea of how many people are using
+-Alpine. Are you willing to be counted as an Alpine user? Pressing
+-<A HREF="X-Alpine-Phone-Home:">Return</A>
+-will send an anonymous (meaning, your real email address will not be revealed)
+-message to the Alpine development team at the University of Washington for
+-purposes of tallying.
+-
+-<!--To Exit this screen and continue your Alpine session press "E".-->
+-<!--chtml else-->
+ To Exit this screen and continue your Alpine session press "Return".
+-<!--chtml endif-->
+ </BODY>
+ </HTML>
+
+diff -ur /home/dougb-f/alpine-2.00/pith/send.c ./pith/send.c
+--- /home/dougb-f/alpine-2.00/pith/send.c 2008-08-06 11:25:58.000000000 -0700
++++ ./pith/send.c 2011-05-22 14:42:15.000000000 -0700
+@@ -209,13 +209,6 @@
+
+
+ /*
+- * Phone home hash controls
+- */
+-#define PH_HASHBITS 24
+-#define PH_MAXHASH (1<<(PH_HASHBITS))
+-
+-
+-/*
+ * postponed_stream - return stream associated with postponed messages
+ * in argument.
+ */
+@@ -1676,48 +1669,6 @@
+ }
+
+
+-/*
+- * phone_home_from - make phone home request's from address IMpersonal.
+- * Doesn't include user's personal name.
+- */
+-ADDRESS *
+-phone_home_from(void)
+-{
+- ADDRESS *addr = mail_newaddr();
+- char tmp[32];
+-
+- /* garble up mailbox name */
+- snprintf(tmp, sizeof(tmp), "hash_%08u", phone_home_hash(ps_global->VAR_USER_ID));
+- tmp[sizeof(tmp)-1] = '\0';
+- addr->mailbox = cpystr(tmp);
+- addr->host = cpystr(ps_global->maildomain);
+- return(addr);
+-}
+-
+-
+-/*
+- * one-way-hash a username into an 8-digit decimal number
+- *
+- * Corey Satten, corey@cac.washington.edu, 7/15/98
+- */
+-unsigned int
+-phone_home_hash(char *s)
+-{
+- unsigned int h;
+-
+- for (h=0; *s; ++s) {
+- if (h & 1)
+- h = (h>>1) | (PH_MAXHASH/2);
+- else
+- h = (h>>1);
+-
+- h = ((h+1) * ((unsigned char) *s)) & (PH_MAXHASH - 1);
+- }
+-
+- return (h);
+-}
+-
+-
+ /*----------------------------------------------------------------------
+ Call the mailer, SMTP, sendmail or whatever
+
+diff -ur /home/dougb-f/alpine-2.00/pith/send.h ./pith/send.h
+--- /home/dougb-f/alpine-2.00/pith/send.h 2008-06-30 15:03:35.000000000 -0700
++++ ./pith/send.h 2011-05-22 14:42:15.000000000 -0700
+@@ -224,8 +224,6 @@
+ void pine_free_env(METAENV **);
+ int check_addresses(METAENV *);
+ void update_answered_flags(REPLY_S *);
+-ADDRESS *phone_home_from(void);
+-unsigned int phone_home_hash(char *);
+ int call_mailer(METAENV *, BODY *, char **, int, void (*)(char *, int),
+ void (*)(PIPE_S *, int, void *));
+ int write_postponed(METAENV *, BODY *);
+diff -ur /home/dougb-f/alpine-2.00/pith/state.h ./pith/state.h
+--- /home/dougb-f/alpine-2.00/pith/state.h 2008-06-03 08:54:15.000000000 -0700
++++ ./pith/state.h 2011-05-22 14:42:15.000000000 -0700
+@@ -187,7 +187,6 @@
+ unsigned force_prefer_plain:1;
+ unsigned force_no_prefer_plain:1;
+
+- unsigned phone_home:1;
+ unsigned painted_body_on_startup:1;
+ unsigned painted_footer_on_startup:1;
+ unsigned open_readonly_on_startup:1;
+diff -ur /home/dougb-f/alpine-2.00/po/POTFILES.in ./po/POTFILES.in
+--- /home/dougb-f/alpine-2.00/po/POTFILES.in 2008-06-03 12:27:23.000000000 -0700
++++ ./po/POTFILES.in 2011-05-22 14:42:15.000000000 -0700
+@@ -50,7 +50,6 @@
+ alpine/context.c
+ alpine/pine-use.c
+ alpine/imap.c
+-alpine/newuser.c
+ alpine/help.c
+ alpine/print.c
+ alpine/smime.c