aboutsummaryrefslogtreecommitdiff
path: root/mail/alpine
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2008-09-06 06:15:21 +0000
committerDoug Barton <dougb@FreeBSD.org>2008-09-06 06:15:21 +0000
commit91c52f85fc510b155eff587a6bc7cfb9f5332565 (patch)
tree77eac84ada1f2715ea027dfcea8ebf4cb3d61453 /mail/alpine
parentfb2863d7aab605968c610bdcab70d60f7c5e27e2 (diff)
downloadports-91c52f85fc510b155eff587a6bc7cfb9f5332565.tar.gz
ports-91c52f85fc510b155eff587a6bc7cfb9f5332565.zip
Notes
Diffstat (limited to 'mail/alpine')
-rw-r--r--mail/alpine/Makefile33
-rw-r--r--mail/alpine/files/patch-configure29
2 files changed, 49 insertions, 13 deletions
diff --git a/mail/alpine/Makefile b/mail/alpine/Makefile
index 766e50dd9a17..eee2b3b5d1b9 100644
--- a/mail/alpine/Makefile
+++ b/mail/alpine/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= alpine
PORTVERSION= 2.00
+PORTREVISION?= 1
CATEGORIES?= mail news ipv6
MASTER_SITES= ftp://ftp.cac.washington.edu/alpine/ \
http://dougbarton.us/Downloads/alpine-${PORTVERSION}/
@@ -62,19 +63,23 @@ CONFIGURE_ARGS+= --disable-mouse
.endif
.if defined(WITH_NLS)
-CONFIGURE_ARGS+= --with-nls
+CONFIGURE_ARGS+= --enable-nls
.else
-CONFIGURE_ARGS+= --without-nls
+CONFIGURE_ARGS+= --disable-nls
.endif
.if !defined(WITH_NOSPELL)
.if !defined(WITH_ISPELL)
-CONFIGURE_ARGS+=--with-spellcheck-prog="${LOCALBASE}/bin/aspell --dont-backup --mode=email check"
+CONFIGURE_ARGS+=--with-interactive-spellcheck=${LOCALBASE}/bin/aspell
+BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
RUN_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
.else
-CONFIGURE_ARGS+= --with-spellcheck-prog="${LOCALBASE}/bin/ispell"
+CONFIGURE_ARGS+= --with-interactive-spellcheck=${LOCALBASE}/bin/ispell
+BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
+.else
+CONFIGURE_ARGS+=--without-simple-spellcheck --without-interactive-spellcheck
.endif
.if !defined(PICO_ALPINE_SLAVE)
@@ -97,7 +102,7 @@ CONFIGURE_ARGS+= --without-ldap
.if defined(WITH_PASSFILE)
ALPINE_PASSFILE?= .alpine.pwd
-CONFIGURE_ARGS+= --with-passfile=".alpine.pwd"
+CONFIGURE_ARGS+= --with-passfile=.alpine.pwd
.endif
.if defined(WITH_CONS25)
@@ -120,15 +125,12 @@ PATCHFILES+= quota.patch.gz
PATCHFILES+= maildir.patch.gz
.endif
-.if defined(WITHOUT_SSL)
-MAKE_ARGS+= SSLTYPE=none
-.else
-EXTRA_OPTS+= SSLINCLUDE=${OPENSSLINC} SSLLIB=${OPENSSLLIB}
-.if defined(WITH_SSL_AND_PLAINTEXT)
-EXTRA_OPTS+= SSLTYPE=nopwd
+.if !defined(WITHOUT_SSL)
+MAKE_ARGS+= SSLINCLUDE=${OPENSSLINC} SSLLIB=${OPENSSLLIB}
+CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLDIR} \
+ --with-ssl-certs-dir=${OPENSSLDIR}/certs
.else
-EXTRA_OPTS+= SSLTYPE=unix
-.endif
+CONFIGURE_ARGS+= --without-ssl
.endif
MAN1= alpine.1 rpdump.1 rpload.1
@@ -147,6 +149,11 @@ post-patch:
@${CP} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.presed
@${SED} -e "s#doc/pico.1 doc/pilot.1 ##" \
${WRKSRC}/Makefile.in.presed > ${WRKSRC}/Makefile.in
+ @${CP} ${WRKSRC}/imap/src/osdep/unix/Makefile \
+ ${WRKSRC}/imap/src/osdep/unix/Makefile.presed
+ @${SED} -e "s#^LOCKPGM=.*#LOCKPGM= ${PREFIX}/libexec/mlock#" \
+ ${WRKSRC}/imap/src/osdep/unix/Makefile.presed \
+ > ${WRKSRC}/imap/src/osdep/unix/Makefile
@for i in ${WRKSRC}/README ${WRKSRC}/doc/alpine.1 \
${WRKSRC}/doc/tech-notes.txt ${WRKSRC}/doc/tech-notes/*.html \
${WRKSRC}/pith/pine.hlp ; do \
diff --git a/mail/alpine/files/patch-configure b/mail/alpine/files/patch-configure
new file mode 100644
index 000000000000..83a26817c9a7
--- /dev/null
+++ b/mail/alpine/files/patch-configure
@@ -0,0 +1,29 @@
+--- configure.orig 2008-08-21 18:41:04.000000000 -0700
++++ configure 2008-09-05 22:36:00.000000000 -0700
+@@ -23041,7 +23041,7 @@
+ case "$SPELLPROG" in
+ no)
+ ;;
+- yes)
++ yes|*aspell|*ispell)
+ # Extract the first word of "aspell", so it can be a program name with args.
+ set dummy aspell; ac_word=$2
+ { echo "$as_me:$LINENO: checking for $ac_word" >&5
+@@ -23233,7 +23233,7 @@
+ case "$ISPELLPROG" in
+ no)
+ ;;
+- yes)
++ yes|*aspell|*ispell)
+ # Extract the first word of "aspell", so it can be a program name with args.
+ set dummy aspell; ac_word=$2
+ { echo "$as_me:$LINENO: checking for $ac_word" >&5
+@@ -33251,7 +33251,7 @@
+ c_client_specials="${c_client_specials}SSLTYPE=none "
+ else
+
+- if test -n "$alpine_SSLCERTS" -a -d "$alpine_SSLCERTS" ; then
++ if test -n "$alpine_SSLCERTS" ; then
+ certdir="$alpine_SSLCERTS"
+ elif test -n "$alpine_SSLDIR" -a -d "${alpine_SSLDIR}/certs" ; then
+ certdir="${alpine_SSLDIR}/certs"