aboutsummaryrefslogtreecommitdiff
path: root/mail/althea
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-04-13 10:55:38 +0000
committerRene Ladan <rene@FreeBSD.org>2014-04-13 10:55:38 +0000
commitbac6e092c4705f6a79bf323ae7961d92aa017bb5 (patch)
tree945be4c82f4ab2b27427f5ba33627b6ec0e06991 /mail/althea
parent0bd8a54ab1df83aba8d606431f2ca378711e1d69 (diff)
downloadports-bac6e092c4705f6a79bf323ae7961d92aa017bb5.tar.gz
ports-bac6e092c4705f6a79bf323ae7961d92aa017bb5.zip
Notes
Diffstat (limited to 'mail/althea')
-rw-r--r--mail/althea/Makefile28
-rw-r--r--mail/althea/distinfo2
-rw-r--r--mail/althea/files/Makefile.bsd36
-rw-r--r--mail/althea/files/patch-MIME.cpp11
-rw-r--r--mail/althea/files/patch-MIME.h10
-rw-r--r--mail/althea/files/patch-SendMail.cpp10
-rw-r--r--mail/althea/files/patch-tolower.h10
-rw-r--r--mail/althea/pkg-descr7
-rw-r--r--mail/althea/pkg-plist30
9 files changed, 0 insertions, 144 deletions
diff --git a/mail/althea/Makefile b/mail/althea/Makefile
deleted file mode 100644
index 761ec9527c69..000000000000
--- a/mail/althea/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-# Created by: Mikhail Teterin <mi@aldan.algebra.com>
-# $FreeBSD$
-
-PORTNAME= althea
-PORTVERSION= 0.5.7
-PORTREVISION= 5
-CATEGORIES= mail
-MASTER_SITES= SF
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Yet another GTK-based mail reader for X. Supports IMAP
-
-DEPRECATED= Unmaintained since 2001
-EXPIRATION_DATE= 2014-04-12
-USES= gettext
-USE_OPENSSL= yes
-MAKE_ENV= MKDIR="${MKDIR}"
-MAKEFILE= ${FILESDIR}/Makefile.bsd
-USE_GNOME= gtk12
-
-NO_STAGE= yes
-post-patch:
-.for file in Documentation/help.html load_config.h save_config.h
- @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' ${WRKSRC}/${file}
-.endfor
-
-.include <bsd.port.mk>
diff --git a/mail/althea/distinfo b/mail/althea/distinfo
deleted file mode 100644
index 243a895e8554..000000000000
--- a/mail/althea/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (althea-0.5.7.tgz) = 915112e24b5ea7db38e7e3fdb63ff39fb0852ed0a27c540ad31329fc3d920aee
-SIZE (althea-0.5.7.tgz) = 357483
diff --git a/mail/althea/files/Makefile.bsd b/mail/althea/files/Makefile.bsd
deleted file mode 100644
index 16bb1c12143d..000000000000
--- a/mail/althea/files/Makefile.bsd
+++ /dev/null
@@ -1,36 +0,0 @@
-PROG= althea
-NO_MAN= forget it :(
-
-objs!= ${MAKE} -V OBJS -f ${.CURDIR}/Makefile
-SRCS:= ${objs:.o=.cpp} main.cpp
-
-BINDIR=${PREFIX}/bin
-DOCDIR=${PREFIX}/share/doc/${PROG}
-PIXDIR=${PREFIX}/share/${PROG}
-LOCALEDIR=${PREFIX}/share/locale
-
-MAIL_POLL_INTERVAL = 60000
-
-# Compiled-in pathes:
-CXXFLAGS+=-DPACKAGE=\"${PROG}\" -DDOCDIR=\"${DOCDIR}\" -DPIXDIR=\"${PIXDIR}\" -DLOCALEDIR=\"${LOCALEDIR}\" -DMAIL_POLL_INTERVAL=${MAIL_POLL_INTERVAL}
-CXXFLAGS+=-ftemplate-depth-30
-
-# Use the GTK's CFLAGS:
-CXXFLAGS+=`${GTK_CONFIG} --cflags gthread` -I${OPENSSLINC}
-
-# Use the GTK's libraries:
-LDADD+=`${GTK_CONFIG} --libs gthread` -L${OPENSSLLIB} -lssl -lcrypto
-
-# A hack to ensure C++ is called to do the final linking:
-CC:= ${CXX}
-
-${DOCDIR}/images ${PIXDIR}:
- ${MKDIR} $@
-
-beforeinstall: ${DOCDIR}/images ${PIXDIR}
- ${BSD_INSTALL_DATA} ${.CURDIR}/Documentation/help.html ${DOCDIR}
- ${BSD_INSTALL_DATA} ${.CURDIR}/Documentation/images/*.* ${DOCDIR}/images
- ${BSD_INSTALL_DATA} ${.CURDIR}/pixmaps/*.* ${PIXDIR}
- ${BSD_INSTALL_DATA} ${.CURDIR}/althearc.example ${PREFIX}/etc/
-
-.include <bsd.prog.mk>
diff --git a/mail/althea/files/patch-MIME.cpp b/mail/althea/files/patch-MIME.cpp
deleted file mode 100644
index 5bb9e9204ba3..000000000000
--- a/mail/althea/files/patch-MIME.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- MIME.cpp.orig Wed Jan 23 02:30:15 2002
-+++ MIME.cpp Fri Dec 27 03:56:30 2002
-@@ -91,7 +91,7 @@
- }
-
- void check(unsigned int convertedVal, ifstream &fileIn, int loc, int counter) {
-- unsigned char c;
-+ char c;
-
- fileIn.get(c);
- if ((unsigned int)c!=convertedVal) {
diff --git a/mail/althea/files/patch-MIME.h b/mail/althea/files/patch-MIME.h
deleted file mode 100644
index 2215bb630d7f..000000000000
--- a/mail/althea/files/patch-MIME.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- MIME.h.orig Wed Jan 23 02:30:15 2002
-+++ MIME.h Fri Dec 27 03:28:03 2002
-@@ -1,5 +1,7 @@
- #ifndef MIME_H
- #define MIME_H
-+namespace std {};
-+using namespace std;
-
-
- #include <string>
diff --git a/mail/althea/files/patch-SendMail.cpp b/mail/althea/files/patch-SendMail.cpp
deleted file mode 100644
index f35706059a43..000000000000
--- a/mail/althea/files/patch-SendMail.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- SendMail.cpp.orig Wed Jan 23 02:30:15 2002
-+++ SendMail.cpp Mon Jun 24 21:01:22 2002
-@@ -3,6 +3,7 @@
- // -- created 4/11/00 updated 4/11/00
- /////////////////////////////////////////
-
-+#include <pthread.h>
- #include "SendMail.h"
-
- extern Althea gAlthea;
diff --git a/mail/althea/files/patch-tolower.h b/mail/althea/files/patch-tolower.h
deleted file mode 100644
index 79caf3377034..000000000000
--- a/mail/althea/files/patch-tolower.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- tolower.h.orig Wed Jan 23 02:30:15 2002
-+++ tolower.h Fri Dec 27 03:27:01 2002
-@@ -1,5 +1,7 @@
- #ifndef TOLOWER_H
- #define TOLOWER_H
-+namespace std {};
-+using namespace std;
-
- #include <iostream>
- #include <string>
diff --git a/mail/althea/pkg-descr b/mail/althea/pkg-descr
deleted file mode 100644
index 95b739613c06..000000000000
--- a/mail/althea/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-The designers of Althea felt that there wasn't a stable, easy to
-use, GUI, IMAP (Internet Message Access Protocol) e-mail client
-for X/GTK+. The design goal was a stable e-mail client with the
-richness of usability of Microsoft's Outlook, Qualcomm's Eudora,
-and Cyrusoft's Mulberry.
-
-WWW: http://althea.sourceforge.net/
diff --git a/mail/althea/pkg-plist b/mail/althea/pkg-plist
deleted file mode 100644
index 2d36a19df365..000000000000
--- a/mail/althea/pkg-plist
+++ /dev/null
@@ -1,30 +0,0 @@
-bin/althea
-etc/althearc.example
-share/althea/address.xpm
-share/althea/althea.xpm
-share/althea/attach.xpm
-share/althea/check.xpm
-share/althea/close.xpm
-share/althea/delete.xpm
-share/althea/folder.xpm
-share/althea/forward.xpm
-share/althea/new.xpm
-share/althea/print.xpm
-share/althea/reply.xpm
-share/althea/save.xpm
-share/althea/send.xpm
-share/althea/server.xpm
-share/doc/althea/help.html
-share/doc/althea/images/althea.png
-share/doc/althea/images/altheaMenu.png
-share/doc/althea/images/configServer.png
-share/doc/althea/images/configSession.png
-share/doc/althea/images/helpMenu.png
-share/doc/althea/images/messageMenu.png
-share/doc/althea/images/sf.gif
-share/doc/althea/images/toolbar.png
-share/doc/althea/images/typicalSession.png
-share/doc/althea/images/typicalSessionSmall.png
-@dirrm share/doc/althea/images
-@dirrm share/doc/althea
-@dirrm share/althea