aboutsummaryrefslogtreecommitdiff
path: root/mail/arrow/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-09-18 00:40:20 +0000
committerSteve Price <steve@FreeBSD.org>2000-09-18 00:40:20 +0000
commite8dbbb9d588122d46573c10c51aa694475c316b7 (patch)
tree5c0c2caf4a054697835e0111fcc7f27512dbd5c7 /mail/arrow/Makefile
parent891b81ed4b1fe2ea8433febef7b792af4cc8fe8b (diff)
Adding arrow version 1.0.8.
A mail reader for X that lets you view, compose, and organize your mail. It groks PGP, GnuPG, POP, and APOP. PR: 19287 Submitted by: Mario S F Ferreira <lioux@linf.unb.br>
Notes
Notes: svn path=/head/; revision=32791
Diffstat (limited to 'mail/arrow/Makefile')
-rw-r--r--mail/arrow/Makefile108
1 files changed, 108 insertions, 0 deletions
diff --git a/mail/arrow/Makefile b/mail/arrow/Makefile
new file mode 100644
index 000000000000..0ab8e9101e4e
--- /dev/null
+++ b/mail/arrow/Makefile
@@ -0,0 +1,108 @@
+# New ports collection makefile for: Arrow
+# Date created: 14 June 2000
+# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
+#
+# $FreeBSD$
+#
+
+PORTNAME= arrow
+PORTVERSION= 1.0.8
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.newplanetsoftware.com/pub/arrow/source/
+DISTNAME= Arrow_source-${PORTVERSION}
+
+MAINTAINER= lioux@linf.unb.br
+
+BUILD_DEPENDS= nonexistent:${JXPORT}:configure \
+ makemake:${JXPORT}
+LIB_DEPENDS= jx-1_5_3.1:${JXPORT} \
+ jsearch-0_5_6.0:${PORTSDIR}/x11-toolkits/libjsearch \
+ jtoolbar-0_5_4.0:${PORTSDIR}/x11-toolkits/libjtoolbar \
+ jtree-1_1_7.1:${PORTSDIR}/x11-toolkits/libjtree
+
+WRKSRC= ${WRKDIR}/JX-1.5.3
+
+USE_XLIB= yes
+USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+MAKE_ENV= JX_INSTALL_ROOT="${X11BASE}/bin" \
+ JX_LIB_ROOT="${X11BASE}/lib"
+PLIST_SUB= PORTNAME="${PORTNAME}"
+
+# Make environment
+PORTINCLUDES= -I${X11BASE}/include/jx \
+ -I${X11BASE}/include/jcore \
+ -I${X11BASE}/include/jsearch \
+ -I${X11BASE}/include/jtoolbar \
+ -I${X11BASE}/include/jtree \
+ -I${X11BASE}/share/jx
+
+# Installs dir with proper permissions
+INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755
+# program files
+PROGRAMFILES= arrow/arrow
+# documents
+DOCFILES= LICENSE README.binary
+DOCDIR_PREFIX= ${PREFIX}/share/doc/${PORTNAME}
+# additional configuration and header files
+EXTRALIB_PREFIX= ${X11BASE}/lib/jx
+EXTRALIBFILES_MAKE_WRKSRC= include/make
+# main jx distribution files needed for building
+COPY_JXDIRS= include
+COPY_JXFILES= Makefile
+# main jx distribution port wrksrc
+JXPORT= ${PORTSDIR}/x11-toolkits/jx
+JXPORT_WRKSRC= ${JXPORT}/work/JX-1.5.3
+JX_MAKE_CONSTANTS= jsearch_constants jtoolbar_constants jtree_constants
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 300000
+ALL_TARGET= freebsd3.x
+.else
+ALL_TARGET= freebsd2.x
+.endif
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= PORTDOCS:="@comment "
+.else
+PLIST_SUB+= PORTDOCS:=
+.endif # !defined(NOPORTDOCS)
+
+post-extract:
+.for i in ${COPY_JXDIRS}
+ @${CP} -Rp ${JXPORT_WRKSRC}/${i} ${WRKSRC}
+.endfor
+.for i in ${COPY_JXFILES}
+ @${CP} -p ${JXPORT_WRKSRC}/${i} ${WRKSRC}
+.endfor
+
+post-patch:
+ @${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
+ ${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
+
+pre-build:
+.for i in ${JX_MAKE_CONSTANTS}
+ @${LN} -sf ${EXTRALIB_PREFIX}/make/${i} ${WRKSRC}/include/make
+.endfor
+
+post-build:
+ @cd ${WRKSRC}/programs/${PORTNAME}; ${SETENV} ${MAKE_ENV} makemake; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS}
+
+do-install:
+.if !defined(NOPORTDOCS)
+# Install all documentation
+ @${INSTALL_DATA_DIR} ${DOCDIR_PREFIX}
+.for i in ${DOCFILES}
+ @${INSTALL_DATA} ${WRKSRC}/programs/${PORTNAME}/${i} ${DOCDIR_PREFIX}
+.endfor
+.endif # !defined(NOPORTDOCS)
+# Install all programs
+.for i in ${PROGRAMFILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/programs/${i} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.post.mk>