aboutsummaryrefslogtreecommitdiff
path: root/mail/assp
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-25 18:27:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-25 18:27:25 +0000
commit661134d7997460f59572c36d76302e0e320576ab (patch)
tree777ffe88b7e138eb525ac26e3caf19681d72883b /mail/assp
parent43521c2a1ecf6ff45905f44a8884d8a0af9a8385 (diff)
downloadports-661134d7997460f59572c36d76302e0e320576ab.tar.gz
ports-661134d7997460f59572c36d76302e0e320576ab.zip
Notes
Diffstat (limited to 'mail/assp')
-rw-r--r--mail/assp/Makefile18
-rw-r--r--mail/assp/pkg-plist38
2 files changed, 22 insertions, 34 deletions
diff --git a/mail/assp/Makefile b/mail/assp/Makefile
index 29eedd03698b..92ed888572d6 100644
--- a/mail/assp/Makefile
+++ b/mail/assp/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= p5-Net-DNS>=0.68:${PORTSDIR}/dns/p5-Net-DNS \
USES= perl5 zip:infozip shebangfix
SHEBANG_FILES= *.pl
NO_BUILD= yes
+NO_ARCH= yes
USE_PERL5= run
ASSP_USER= assp
@@ -138,14 +139,17 @@ do-install:
${INSTALL_MAN} ${WRKDIR}/assp.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
${INSTALL_MAN} ${WRKDIR}/assplog.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
- ${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/daily
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/daily
${INSTALL_SCRIPT} ${WRKDIR}/510.assp ${STAGEDIR}${PREFIX}/etc/periodic/daily/
- ${MKDIR} ${STAGEDIR}${ASSP_HOME}
- ${MKDIR} ${STAGEDIR}${ASSP_LOG}
-
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${ASSP_HOME}
+ @${MKDIR} ${STAGEDIR}${ASSP_LOG}
+.for f in files images rebuildspamdb.pl reports
+ ${LN} -sf ${DATADIR}/${f} ${STAGEDIR}${ASSP_HOME}/
+.endfor
+ ${LN} -sf ${ASSP_LOG} ${STAGEDIR}${ASSP_HOME}/logs
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/*.htm ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/mail/assp/pkg-plist b/mail/assp/pkg-plist
index 0ae623669de2..e7962deb5721 100644
--- a/mail/assp/pkg-plist
+++ b/mail/assp/pkg-plist
@@ -98,32 +98,16 @@ sbin/assplog
%%DATADIR%%/stat.pl
%%PORTDOCS%%%%DOCSDIR%%/Legacy - ASSP Documentation.htm
%%PORTDOCS%%%%DOCSDIR%%/Regular Expression Tutorial.htm
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
man/man8/assp.8.gz
man/man8/assplog.8.gz
-@dirrmtry %%DATADIR%%/reports
-@dirrmtry %%DATADIR%%/logs
-@dirrmtry %%DATADIR%%/images
-@dirrmtry %%DATADIR%%/files
-@dirrmtry %%DATADIR%%
-@dirrmtry etc/periodic/daily
-@dirrmtry etc/periodic
-@exec ln -sf %D/%%DATADIR%%/files %%ASSP_HOME%%/
-@unexec rm -f %%ASSP_HOME%%/files
-@exec ln -sf %D/%%DATADIR%%/images %%ASSP_HOME%%/
-@unexec rm -f %%ASSP_HOME%%/images
-@exec ln -sf %D/%%DATADIR%%/rebuildspamdb.pl %%ASSP_HOME%%/
-@unexec rm -f %%ASSP_HOME%%/rebuildspamdb.pl
-@exec ln -sf %D/%%DATADIR%%/reports %%ASSP_HOME%%/
-@unexec rm -f %%ASSP_HOME%%/reports
-@exec ln -sf %%ASSP_LOG%% %%ASSP_HOME%%/logs
-@unexec rm -f %%ASSP_HOME%%/logs
-@cwd /
-@owner %%ASSP_USER%%
-@group %%ASSP_GROUP%%
-@mode 750
-@dirrmtry %%ASSP_LOG%%
-@dirrmtry %%ASSP_HOME%%
-@unexec if [ -d %%ASSP_HOME%% ]; then echo "If you are deinstalling ASSP completely, remove the %%ASSP_HOME%% directory."; fi
-@unexec if [ -d %%ASSP_LOG%% ]; then echo "If you are deinstalling ASSP completely, remove the %%ASSP_LOG%% directory."; fi
-@unexec echo "If you are deinstalling ASSP completely, delete the ASSP user and group."
+%%ASSP_HOME%%/files
+%%ASSP_HOME%%/images
+%%ASSP_HOME%%/rebuildspamdb.pl
+%%ASSP_HOME%%/reports
+%%ASSP_HOME%%/logs
+@dir %%DATADIR%%/logs
+@dir(%%ASSP_USER%%,%%ASSP_GROUP%%,750) %%ASSP_LOG%%
+@dir(%%ASSP_USER%%,%%ASSP_GROUP%%,750) %%ASSP_HOME%%
+@postunexec if [ -d %%ASSP_HOME%% ]; then echo "If you are deinstalling ASSP completely, remove the %%ASSP_HOME%% directory."; fi
+@postunexec if [ -d %%ASSP_LOG%% ]; then echo "If you are deinstalling ASSP completely, remove the %%ASSP_LOG%% directory."; fi
+@postunexec echo "If you are deinstalling ASSP completely, delete the ASSP user and group."