aboutsummaryrefslogtreecommitdiff
path: root/mail/assp
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-08-16 18:12:15 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-08-16 18:12:15 +0000
commit48bd66ae6ce598be61a55de78b8b0abc39ec2b75 (patch)
tree704d07653dac807206c8345b071240ef2e2ba3ea /mail/assp
parentd4eb4feea1426149bb2b3f9ab00d89e11dc24068 (diff)
downloadports-48bd66ae6ce598be61a55de78b8b0abc39ec2b75.tar.gz
ports-48bd66ae6ce598be61a55de78b8b0abc39ec2b75.zip
Notes
Diffstat (limited to 'mail/assp')
-rw-r--r--mail/assp/Makefile18
-rw-r--r--mail/assp/distinfo6
-rw-r--r--mail/assp/files/510.assp.in7
-rw-r--r--mail/assp/files/assplog.8.in27
-rw-r--r--mail/assp/files/patch-assp.pl50
-rw-r--r--mail/assp/files/patch-stats.sh115
-rw-r--r--mail/assp/files/periodic-assp.sh.in7
-rw-r--r--mail/assp/pkg-plist14
8 files changed, 133 insertions, 111 deletions
diff --git a/mail/assp/Makefile b/mail/assp/Makefile
index 8ee4d10d9745..a957e13a3c03 100644
--- a/mail/assp/Makefile
+++ b/mail/assp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= assp
-PORTVERSION= 1.3.3.8
-PORTREVISION= 1
+PORTVERSION= 1.3.3.10
CATEGORIES= mail
MASTER_SITES= SF
DISTNAME= ${PORTNAME:U}_${PORTVERSION}-Install
@@ -20,8 +19,7 @@ NO_BUILD= yes
USE_PERL5_RUN= yes
USE_DOS2UNIX= \
- ../Install.txt \
- ../changelog.txt \
+ ../1.3.3.8-1.3.3.10-changes.txt \
addservice.pl \
assp.pl \
files/URIBLCCTLDS.txt \
@@ -34,10 +32,12 @@ USE_DOS2UNIX= \
files/rbl-service.txt \
files/redre.txt \
files/whitedomains.txt \
+ images/assp.css \
+ images/editor.css \
+ images/shutdown.css \
move2num.pl \
rc/readme.txt \
rebuildspamdb.pl \
- repair.pl \
reports/helpreport.txt \
reports/notspamreport.txt \
reports/redremovereport.txt \
@@ -74,7 +74,7 @@ OPTIONS= EMVALID "RFC822 recipient address validator" on \
MYSQL "Use MySQL db to store white/red/delaylists" off \
SIMPLE "Use procedural Web Page interfaces" on
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME:U}_${PORTVERSION}-Install/${PORTNAME:U}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME:L}
.include <bsd.port.pre.mk>
@@ -131,7 +131,11 @@ post-patch:
do-install:
${MKDIR} ${PREFIX}/lib/assp
- ${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${PREFIX}/lib/assp
+ ${INSTALL_SCRIPT} ${WRKSRC}/addservice.pl ${PREFIX}/lib/assp
+ ${INSTALL_SCRIPT} ${WRKSRC}/assp.pl ${PREFIX}/lib/assp
+ ${INSTALL_SCRIPT} ${WRKSRC}/move2num.pl ${PREFIX}/lib/assp
+ ${INSTALL_SCRIPT} ${WRKSRC}/rebuildspamdb.pl ${PREFIX}/lib/assp
+ ${INSTALL_SCRIPT} ${WRKSRC}/stat.pl ${PREFIX}/lib/assp
${INSTALL_SCRIPT} ${WRKSRC}/stats.sh ${PREFIX}/lib/assp
${MKDIR} ${PREFIX}/lib/assp/files
${INSTALL_DATA} ${WRKSRC}/files/* ${PREFIX}/lib/assp/files
diff --git a/mail/assp/distinfo b/mail/assp/distinfo
index 0f6041ce1701..1055a1097d23 100644
--- a/mail/assp/distinfo
+++ b/mail/assp/distinfo
@@ -1,3 +1,3 @@
-MD5 (ASSP_1.3.3.8-Install.zip) = fad56889a74acc10769789bdc887f620
-SHA256 (ASSP_1.3.3.8-Install.zip) = 48a84aa63cbcff99833710c7ccbef69933558e98368982456f5ec8d201fad3ba
-SIZE (ASSP_1.3.3.8-Install.zip) = 332926
+MD5 (ASSP_1.3.3.10-Install.zip) = 8eae214508f426f4f0daef9993828358
+SHA256 (ASSP_1.3.3.10-Install.zip) = e5bfd52401b3f6be38ca5afc86b0d37556d1021f8feccadd2985f650a62d65d9
+SIZE (ASSP_1.3.3.10-Install.zip) = 315382
diff --git a/mail/assp/files/510.assp.in b/mail/assp/files/510.assp.in
index f5964e4d38a4..c6f970e70c51 100644
--- a/mail/assp/files/510.assp.in
+++ b/mail/assp/files/510.assp.in
@@ -6,17 +6,14 @@
cd %%ASSP_HOME%%
-[ -f nightly.log ] && mv nightly.log nightly.log.old
-
if [ ! -f %%PREFIX%%/lib/assp/rebuildspamdb.pl ]
then
echo "%%PREFIX%%/lib/assp/rebuildspamdb.pl does not exist"
rc_spamdb=2
else
echo ""
- echo "Running ASSP rebuildspamdb.pl (output to nightly.log)"
- echo "Running ASSP rebuildspamdb.pl:" >>nightly.log
- %%PERL%% %%PREFIX%%/lib/assp/rebuildspamdb.pl >>nightly.log && rc_spamdb=0 || rc_spamdb=3
+ echo "Running ASSP rebuildspamdb.pl:"
+ %%PERL%% %%PREFIX%%/lib/assp/rebuildspamdb.pl && rc_spamdb=0 || rc_spamdb=3
fi
if [ ! -f %%PREFIX%%/lib/assp/freshclam.sh ]
diff --git a/mail/assp/files/assplog.8.in b/mail/assp/files/assplog.8.in
index 260f39f0d388..c2e778c2b35c 100644
--- a/mail/assp/files/assplog.8.in
+++ b/mail/assp/files/assplog.8.in
@@ -63,6 +63,9 @@ Bayesian spam check failed
DL
Message from unknown sender delayed, sender requested to retry later
.TP
+EM
+message to ASSP's email interface (e.g., spam/notspam report, redlist addition)
+.TP
HL
Bad HELO greeting
.TP
@@ -81,10 +84,10 @@ Malformed RFC822 recipient address
ME
Maximum number of other errors exceeded
.TP
-NS
-asspnotspam@ report submission
+NP
+Email that passed without being processed
.TP
-Ok
+OK
Email that fully passed all tests
.TP
PB
@@ -99,24 +102,24 @@ SPF check failed
VI
Virus detected
.TP
-WA+
+W+
Whitelist addition by local user
.TP
-WL+
-Whitelist addition of address CC'd in whitelisted email
+W-
+Whitelist deletion by local user
.TP
-SR
-asspspam@ report submission
+WC
+Whitelist addition of address CC'd in whitelisted email
.SH BUGS
Note that
.I assplog
-suppresses some of the messages in the log (those that appear
+suppresses many of the messages in the log (those that appear
to duplicate information in other messages).
Unknown/new log messages are not colorized.
-For an accurate view of
-the log, use
+FOR A COMPLETE AND ACCURATE VIEW OF
+THE LOG, USE
.B "tail -f"
-directly on the log file.
+DIRECTLY ON THE LOG FILE.
.SH FILES
.IP %%ASSP_HOME%%/maillog.txt
location of ASSP log file
diff --git a/mail/assp/files/patch-assp.pl b/mail/assp/files/patch-assp.pl
index 26abee89dc47..ece8cab6a821 100644
--- a/mail/assp/files/patch-assp.pl
+++ b/mail/assp/files/patch-assp.pl
@@ -1,37 +1,37 @@
---- assp.pl.orig Thu Nov 1 16:37:53 2007
-+++ assp.pl Thu Nov 1 16:40:38 2007
+--- assp.pl.orig 2008-08-02 22:00:47.000000000 -0400
++++ assp.pl 2008-08-02 22:03:58.000000000 -0400
@@ -1,4 +1,4 @@
--#!/usr/bin/perl
+-#!/usr/bin/perl --
+#!/usr/local/bin/perl
-
- use File::Copy;
- use Encode;
-@@ -844,8 +844,8 @@
- [ScanWL,'Scan Whitelisted Senders',0,checkbox,0,'([01]?)',undef,''],
- [ScanNP,'Scan No Processing Senders',0,checkbox,0,'([01]?)',undef,''],
- [ScanLocal,'Scan Local Senders',0,checkbox,0,'([01]?)',undef,''],
--[AvClamdPort,'Port or file socket for ClamAV',20,textinput,'/tmp/clamd','(\S+)',undef,
+ #
+ # perl antispam smtp proxy
+ # (c) John Hanna, John Calvi, Robert Orso, AJ 2004 under the terms of the GPL
+@@ -817,8 +817,8 @@
+ ['ScanWL','Scan Whitelisted Senders',0,\&checkbox,0,'([01]?)',undef,''],
+ ['ScanNP','Scan No Processing Senders',0,\&checkbox,0,'([01]?)',undef,''],
+ ['ScanLocal','Scan Local Senders',0,\&checkbox,0,'([01]?)',undef,''],
+-['AvClamdPort','Port or file socket for ClamAV',20,\&textinput,'/tmp/clamd','(\S+)',undef,
- 'A socket specified in the clamav.conf file - LocalSocket. For example /tmp/clamd. If the socket has been setup as a TCP/IP socket (see the TCPSocket option in the clamav.conf file), then specify the TCP socket. For example 3310 '],
-+[AvClamdPort,'Port or file socket for ClamAV',20,textinput,'/var/run/clamav/clamd','(\S+)',undef,
-+ 'A socket specified in the clamav.conf file - LocalSocket. For example /var/run/clamav/clamd. If the socket has been setup as a TCP/IP socket (see the TCPSocket option in the clamav.conf file), then specify the TCP socket. For example 3310 '],
- [AvError,'Reply Message to Refuse Infected E<!--get rid of google autofill-->mail',80,textinput,'554 5.7.1 Mail appears infected with \'$infection\'.','(5\d\d .*)',undef,
++['AvClamdPort','Port or file socket for ClamAV',20,\&textinput,'/var/run/assp/clamd','(\S+)',undef,
++ 'A socket specified in the clamav.conf file - LocalSocket. For example /var/run/assp/clamd. If the socket has been setup as a TCP/IP socket (see the TCPSocket option in the clamav.conf file), then specify the TCP socket. For example 3310 '],
+ ['AvError','Reply Message to Refuse Infected E<!--get rid of google autofill-->mail',80,\&textinput,'554 5.7.1 Mail appears infected with \'$infection\'.','(5\d\d .*)',undef,
'Reply message to refuse infected mail. The string $infection is replaced with the name of the detected virus.<br />
For example: 554 5.7.1 Mail appears infected with \'$infection\' -- disinfect and resend.'],
-@@ -1003,7 +1003,7 @@
+@@ -973,7 +973,7 @@
'<span class="negative"> 0 = no report, 1 = to SENDER, 2 = to TO address (below), 3 = BOTH</span>'],
- [EmailRedlistTo,'To Address for Redlist-Reports',40,textinput,'','(.+)',undef,
+ ['EmailRedlistTo','To Address for Redlist-Reports',40,\&textinput,'','(.+)',undef,
'Email sent from ASSP acknowledging your submissions will be sent to this address. For example: admin@domain.com'],
--[EmailFrom,'From Address for Reports',40,textinput,'<spammaster@yourdomain.com>','(.+)',undef,
-+[EmailFrom,'From Address for Reports',40,textinput,'<postmaster@yourdomain.com>','(.+)',undef,
+-['EmailFrom','From Address for Reports',40,\&textinput,'<spammaster@yourdomain.com>','(.+)',undef,
++['EmailFrom','From Address for Reports',40,\&textinput,'<postmaster@yourdomain.com>','(.+)',undef,
'Email sent from ASSP acknowledging your submissions will be sent from this address.'],
-
-
-@@ -1214,7 +1214,7 @@
+ ['NoHaiku','Legacy: Don\'t reply to messages to the Email Interface',0,\&checkbox,0,'([01]?)',undef,
+ 'Check this option to suppress email reports for spam and not-spam reports, whitelist and redlist additions/deletions via the email interface.<br /><hr />
+@@ -1166,7 +1166,7 @@
[0,0,0,'heading','Server Setup'],
- [AsAService,'Run ASSP as a Windows Service**',0,checkbox,0,'([01]?)',undef,
+ ['AsAService','Run ASSP as a Windows Service**',0,\&checkbox,0,'([01]?)',undef,
'In Windows NT/2000/XP/2003 ASSP can be installed as a service. This setting tells ASSP that this has been done -- it does not install the Windows service for you. Installing ASSP as a service requires several steps which are detailed in the <a href="http://www.asspsmtp.org/wiki/Quick_Start_for_Win32">Quick Start for Win32</a> wiki page.'],
--[AsADaemon,'Run ASSP as a Daemon**',0,checkbox,0,'([01]?)',undef,
-+[AsADaemon,'Run ASSP as a Daemon**',0,checkbox,1,'([01]?)',undef,
+-['AsADaemon','Run ASSP as a Daemon**',0,\&checkbox,0,'([01]?)',undef,
++['AsADaemon','Run ASSP as a Daemon**',0,\&checkbox,1,'([01]?)',undef,
'In Linux/BSD/Unix/OSX fork and close file handles. Similar to the command "perl assp.pl &amp;", but better.'],
- [runAsUser,'Run as UID**',20,textinput,'','(\S*)',undef,
+ ['runAsUser','Run as UID**',20,\&textinput,'','(\S*)',undef,
'The *nix user name to assume after startup (*nix only).<p><small><i>Examples:</i> assp, nobody</small></p>'],
diff --git a/mail/assp/files/patch-stats.sh b/mail/assp/files/patch-stats.sh
index 2c0730818b49..af695d3ffb9a 100644
--- a/mail/assp/files/patch-stats.sh
+++ b/mail/assp/files/patch-stats.sh
@@ -1,5 +1,5 @@
---- stats.sh.orig Thu Nov 8 10:30:36 2007
-+++ stats.sh Thu Nov 8 10:43:14 2007
+--- stats.sh.orig 2008-08-06 17:43:32.000000000 -0400
++++ stats.sh 2008-08-06 17:47:16.000000000 -0400
@@ -1,15 +1,23 @@
#!/bin/sh
@@ -43,7 +43,7 @@
#
# I got the idea for this script from Mark Constable. He submitted
# a similar script to follow the Courier-MTA /var/log/maillog
-@@ -46,91 +47,283 @@
+@@ -46,91 +47,308 @@
# Some fields are truncated (with a hard-coded length value, usually 40)
# to keep each line more or less intact on your screen as things scroll by
# Colors are coded with ANSI Color coding, your mileage may vary ...
@@ -149,33 +149,39 @@
+ $(p+7) )
+ next
+ }
-+ /[Ee]mail whitelist addition/ {
-+ if ($3 != "Email") {
-+ email_wa_ip = $4
-+ email_wa_name = $5
-+ }
-+ else {
-+ printf("%s %s \033[1;36m%-15s\033[0m \033[1;36mWA+ %s\033[0m \033[1;32m%s\033[0m \033[1;36m%s\033[0m\n",
-+ $1,
-+ $2,
-+ email_wa_ip,
-+ substr(email_wa_name,1,40),
-+ "-adds-",
-+ $(p+6) )
-+ }
++ /[Em]ail whitelist (addition|deletion):/ {
++ printf("%s %s \033[1;36m%-15s\033[0m \033[1;36mW%s %s\033[0m \033[1;37m%s\033[0m \033[1;36m%s\033[0m\n",
++ $1,
++ $2,
++ $(p+4),
++ (/addition:/) ? "+" : "-",
++ substr($(p+5),1,40),
++ (/addition:/) ? "-adds-" : "-deletes-",
++ $(p+9) )
+ next
+ }
+ /whitelist addition:/ && !/[Ee]mail/ {
-+ printf("%s %s \033[1;32m%-15s\033[0m \033[1;37mWL+ %s\033[0m \033[1;32m%s\033[0m \033[1;37m%s\033[0m\n",
++ printf("%s %s \033[1;36m%-15s\033[0m \033[1;36mWC %s\033[0m \033[1;37m%s\033[0m \033[1;36m%s\033[0m\n",
++ $1,
++ $2,
++ $(p+4),
++ substr($(p+5),1,40),
++ "-adds-",
++ $(p+10) )
++ next
++ next
++ }
++ /[Ee]mail (hamreport|help|spamreport|redlist)/ {
++ printf("%s %s\033[1;36m %-15s EM %s %s%s\033[0m\n",
+ $1,
+ $2,
+ $(p+4),
-+ substr($(p+5),1,40),
-+ "-adds-",
-+ $(p+10) )
++ $(p+5),
++ $(p+7),
++ ($(p+8)) ? " " $(p+8) : "" )
+ next
+ }
-+ /Bayesian Check Prob/ {
++ /Bayesian Check ( - )?Prob/ {
+ # suppress
+ next
+ }
@@ -193,7 +199,7 @@
+ next
+ }
+ /message ok/ {
-+ printf("%s %s \033[1;32m%-15s Ok %s -> %s\033[0m\n",
++ printf("%s %s \033[1;32m%-15s OK %s -> %s\033[0m\n",
+ $1,
+ $2,
+ $(p+4),
@@ -257,7 +263,7 @@
+ # suppress
+ next
+ }
-+ /failed (DNS|URI)BL|failed (R|URI)BL checks|Received-RBL: fail|\[DNSBL].* rejected by / {
++ /failed (DNS|URI)BL|failed (R|URI)BL checks|Received-RBL: fail/ {
+ printf("%s %s \033[1;35m%-15s BL %s -> %s\033[0m\n",
+ $1,
+ $2,
@@ -266,11 +272,21 @@
+ $(p+7) )
+ next
+ }
-+ /Received-SPF: (pass|neutral)| SPF: (soft)?fail|SPFstrict/ {
++ /(\[DNSBL]|\[DNSBLcache]).* rejected by / {
++ printf("%s %s \033[1;35m%-15s BL %s (%s blacklisted by %s)\033[0m\n",
++ $1,
++ $2,
++ $(p+4),
++ substr($(p+5),1,40),
++ $(p+7),
++ $(p+10) )
++ next
++ }
++ /Received-SPF(\(cache\))?: (pass|neutral)| SPF: (soft)?fail|SPFstrict/ {
+ # suppress
+ next
+ }
-+ /failed SPF checks|Received-SPF: ((soft)?fail|error)/ {
++ /failed SPF checks|Received-SPF(\(cache\))?: ((soft)?fail|error)| SPF: neutral/ {
+ printf("%s %s \033[1;35m%-15s SP %s -> %s\033[0m\n",
+ $1,
+ $2,
@@ -311,7 +327,7 @@
+ # suppress
+ next
+ }
-+ /recipient delayed/ {
++ /(recipient|bounce) delayed/ {
+ printf("%s %s \033[1;35m%-15s DL %s -> %s\033[0m\n",
+ $1,
+ $2,
@@ -320,24 +336,12 @@
+ $(p+8) )
+ next
+ }
-+ /Admin (update:|connection from )/ {
-+ printf("\033[1;33m%s\033[0m\n", $0)
-+ next
-+ }
-+ /[Ee]mail spamreport/ {
-+ printf("%s %s\033[1;36m %-15s SR %s\033[0m\n",
-+ $1,
-+ $2,
-+ $(p+4),
-+ $(p+5) )
++ /DATA phase delayed/ {
++ # suppress
+ next
+ }
-+ /[Ee]mail hamreport/ {
-+ printf("%s %s\033[1;36m %-15s NS %s\033[0m\n",
-+ $1,
-+ $2,
-+ $(p+4),
-+ $(p+5) )
++ /(Admin (update:|connection from ))|AdminUpdate:/ {
++ printf("\033[1;33m%s\033[0m\n", $0)
+ next
+ }
+ /ClamAV: scanning/ {
@@ -367,7 +371,7 @@
+ substr($(p+14),8,40) )
+ next
+ }
-+ /PB:.*score:.*reason:/ {
++ /PB:( deleting\(black\)|.*score:.*reason:)/ {
+ # suppress
+ next
+ printf("%s %s\033[1;34m %-15s PB %s %s %s %s (%s)\033[0m\n",
@@ -378,7 +382,11 @@
+ substr($(p+12),8,40) )
+ next
+ }
-+ /PBextreme:monitoring|([ValidHelo]|[InvalidHelo]|[PTRmissing])[scoring]/ {
++ /PBextreme:monitoring/ {
++ # suppress
++ next
++ }
++ /(\[ValidHelo]|\[InvalidHelo]|\[PTRinvalid]|\[PTRmissing])\[scoring]/ {
+ # suppress
+ next
+ }
@@ -399,6 +407,23 @@
+ substr($(p+5),1,40) )
+ next
+ }
++ /Message proxied without processing/ {
++ # suppress
++ next
++ }
++ /message proxied without processing/ {
++ printf("%s %s \033[1;32m%-15s NP %s -> %s\033[0m\n",
++ $1,
++ $2,
++ $(p+4),
++ substr($(p+5),1,40),
++ $(p+7) )
++ next
++ }
++ /Regex:(Black|NoProcessingDomain)/ {
++ # suppress
++ next
++ }
+ {
+ printf("%s %s ", $1, $2)
+ for (i=3; i<=NF; i++)
diff --git a/mail/assp/files/periodic-assp.sh.in b/mail/assp/files/periodic-assp.sh.in
index f5964e4d38a4..c6f970e70c51 100644
--- a/mail/assp/files/periodic-assp.sh.in
+++ b/mail/assp/files/periodic-assp.sh.in
@@ -6,17 +6,14 @@
cd %%ASSP_HOME%%
-[ -f nightly.log ] && mv nightly.log nightly.log.old
-
if [ ! -f %%PREFIX%%/lib/assp/rebuildspamdb.pl ]
then
echo "%%PREFIX%%/lib/assp/rebuildspamdb.pl does not exist"
rc_spamdb=2
else
echo ""
- echo "Running ASSP rebuildspamdb.pl (output to nightly.log)"
- echo "Running ASSP rebuildspamdb.pl:" >>nightly.log
- %%PERL%% %%PREFIX%%/lib/assp/rebuildspamdb.pl >>nightly.log && rc_spamdb=0 || rc_spamdb=3
+ echo "Running ASSP rebuildspamdb.pl:"
+ %%PERL%% %%PREFIX%%/lib/assp/rebuildspamdb.pl && rc_spamdb=0 || rc_spamdb=3
fi
if [ ! -f %%PREFIX%%/lib/assp/freshclam.sh ]
diff --git a/mail/assp/pkg-plist b/mail/assp/pkg-plist
index e7e362d45716..e318a42bfeab 100644
--- a/mail/assp/pkg-plist
+++ b/mail/assp/pkg-plist
@@ -13,7 +13,6 @@ lib/assp/files/nodelay.txt
lib/assp/files/rbl-service.txt
lib/assp/files/redre.txt
lib/assp/files/whitedomains.txt
-lib/assp/images/Thumbs.db
lib/assp/images/assp.css
lib/assp/images/dropShadow.gif
lib/assp/images/editor.css
@@ -26,12 +25,9 @@ lib/assp/images/opensource-logo.gif
lib/assp/images/plusIcon.png
lib/assp/images/shutdown.css
lib/assp/images/sourceforge-logo.gif
-lib/assp/images/valid-xhtml10.gif
lib/assp/images/village.gif
-lib/assp/images/xml-pill.gif
lib/assp/move2num.pl
lib/assp/rebuildspamdb.pl
-lib/assp/repair.pl
lib/assp/reports/helpreport.txt
lib/assp/reports/notspamreport.txt
lib/assp/reports/redremovereport.txt
@@ -50,8 +46,8 @@ sbin/assplog
%%PORTDOCS%%%%DOCSDIR%%/Legacy - ASSP Documentation.htm
%%PORTDOCS%%%%DOCSDIR%%/Regular Expression Tutorial.htm
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@unexec rm -f %D%%ASSP_HOME%%/reports 2>/dev/null || true
-@unexec rm -f %D%%ASSP_HOME%%/images 2>/dev/null || true
-@unexec rm -f %D%%ASSP_HOME%%/files 2>/dev/null || true
-@unexec rmdir %D%%ASSP_HOME%% 2>/dev/null || true
-@unexec if [ -d %D%%ASSP_HOME%% ]; then echo "If you are deinstalling ASSP completely, remove the %D%%ASSP_HOME%% directory."; fi
+@unexec rm %%ASSP_HOME%%/reports
+@unexec rm %%ASSP_HOME%%/images
+@unexec rm %%ASSP_HOME%%/files
+@unexec rmdir %%ASSP_HOME%% 2>/dev/null || true
+@unexec if [ -d %%ASSP_HOME%% ]; then echo "If you are deinstalling ASSP completely, remove the %%ASSP_HOME%% directory."; fi