aboutsummaryrefslogtreecommitdiff
path: root/mail/atmail
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-19 18:41:16 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-19 18:41:16 +0000
commit9ea4dbe63d5288e19c2caabb7b00bae7e5a0af9b (patch)
treee4fab25729fb09cf893abf44f2a6e04478bc5c99 /mail/atmail
parent168141761d8d9bc0cd6fd0350e9fa3023c1c6299 (diff)
Stage and use OPTIONS helpers. I added the same permissions stuff to the plist
as was in the Makefile, but I really don't think that applying 755 to everything is necessary...
Notes
Notes: svn path=/head/; revision=362277
Diffstat (limited to 'mail/atmail')
-rw-r--r--mail/atmail/Makefile38
-rw-r--r--mail/atmail/files/pkg-message.in9
-rw-r--r--mail/atmail/pkg-plist4
3 files changed, 17 insertions, 34 deletions
diff --git a/mail/atmail/Makefile b/mail/atmail/Makefile
index bfa3b1f464f0..f378c0722908 100644
--- a/mail/atmail/Makefile
+++ b/mail/atmail/Makefile
@@ -6,44 +6,26 @@ PORTVERSION= 1.0.4
CATEGORIES= mail
MASTER_SITES= http://atmail.org/download/
DISTNAME= atmailopen
-EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Open Source Webmail Client
+USES= tar:tgz
USE_PHP= mysql pcre session
WRKSRC= ${WRKDIR}/${DISTNAME}
NO_BUILD= yes
SUB_FILES= pkg-message
+PLIST_SUB+= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-OPTIONS_DEFINE= LDAP MBSTRING
-MBSTRING_DESC= Support for UTF8 folder names
+OPTIONS_DEFINE= LDAP MBSTRING ICONV
+MBSTRING_DESC= Support for UTF8 folder names
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_PHP+= ldap
-.endif
-
-.if ${PORT_OPTIONS:MMBSTRING}
-USE_PHP+= mbstring
-.endif
-
-.if ${PORT_OPTIONS:MICONV}
-USE_PHP+= iconv
-.endif
+LDAP_USE= PHP=ldap
+MBSTRING_USE= PHP=mbstring
+ICONV_USE= PHP=iconv
do-install:
- @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
- @${CHMOD} -R 755 ${WWWDIR}
-
-post-install:
- @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' \
- >> ${TMPPLIST}
- @${ECHO_CMD} '@exec ${CHMOD} -R 755 ${WWWDIR}' \
- >> ${TMPPLIST}
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
.include <bsd.port.mk>
diff --git a/mail/atmail/files/pkg-message.in b/mail/atmail/files/pkg-message.in
index 3bfeda9a4110..ca6bb2e7c4da 100644
--- a/mail/atmail/files/pkg-message.in
+++ b/mail/atmail/files/pkg-message.in
@@ -2,16 +2,15 @@
POST-INSTALL CONFIGURATION FOR ATMAIL
=====================================
-1) Before the post-install of atmail ,please make sure
-your SMTP server work well first.
- Better turn off magic_quotes_gpc setting in the
-php.ini.
+1) Before the post-install of atmail, please make sure
+ your SMTP server work well first.
+ Better turn off magic_quotes_gpc setting in php.ini.
2) Add the following to your Apache configuration, and
restart the server:
### Add the AcceptPathInfo directive only for Apache 2.0.30 or later.
- Alias /atmail %%WWWDIR%%/
+ Alias /atmail %%WWWDIR%%
AcceptPathInfo On
<Directory %%WWWDIR%%>
AllowOverride None
diff --git a/mail/atmail/pkg-plist b/mail/atmail/pkg-plist
index 59332a00226c..fdff01b8622c 100644
--- a/mail/atmail/pkg-plist
+++ b/mail/atmail/pkg-plist
@@ -1,4 +1,6 @@
-@exec mkdir -p %D/www/atmail/users
+@mode 755
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%WWWDIR%%/CHANGELOG
%%WWWDIR%%/LICENSE
%%WWWDIR%%/README