aboutsummaryrefslogtreecommitdiff
path: root/mail/automx
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-12-21 21:18:36 +0000
committerChris Rees <crees@FreeBSD.org>2013-12-21 21:18:36 +0000
commit1850501650923de019005bc2b5565a771540c0f5 (patch)
treee4454db598a19030aa362d816a43dce561e0b6cf /mail/automx
parent9cfe09443080cf75d2342180978ec4baeef191ee (diff)
downloadports-1850501650923de019005bc2b5565a771540c0f5.tar.gz
ports-1850501650923de019005bc2b5565a771540c0f5.zip
Notes
Diffstat (limited to 'mail/automx')
-rw-r--r--mail/automx/Makefile41
-rw-r--r--mail/automx/distinfo4
-rw-r--r--mail/automx/files/patch-src-automx-test78
-rw-r--r--mail/automx/pkg-descr18
-rw-r--r--mail/automx/pkg-plist6
5 files changed, 106 insertions, 41 deletions
diff --git a/mail/automx/Makefile b/mail/automx/Makefile
index 14fc5689a7ad..57800e4083d8 100644
--- a/mail/automx/Makefile
+++ b/mail/automx/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= automx
-PORTVERSION= 0.9
-PORTREVISION= 1
+PORTVERSION= 0.9.2
CATEGORIES= mail
MASTER_SITES= http://www.automx.org/download/
@@ -13,7 +12,6 @@ LICENSE= GPLv3
RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_wsgi.so:${PORTSDIR}/www/mod_wsgi2 \
${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml \
- bash:${PORTSDIR}/shells/bash \
wget:${PORTSDIR}/ftp/wget
USE_APACHE_RUN= 22+
@@ -22,42 +20,27 @@ NO_BUILD= yes
PORTDATA= *
PORTDOCS= *
-MAN1= ${PORTNAME}-test.1
-MAN5= ${PORTNAME}.conf.5 ${PORTNAME}_ldap.5 ${PORTNAME}_sql.5
-
PKGMESSAGE= ${WRKDIR}/pkg-message
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
- ${REINPLACE_CMD} -e '1s,/bin/bash,${LOCALBASE}/bin/bash,' \
- ${WRKSRC}/src/automx-test
# Generate pkg-message from INSTALL file; include lines from Section 5 onwards
- line=$$(${SED} -ne '/^5. Web Server/=' ${WRKSRC}/INSTALL) && \
+ line=$$(${SED} -ne '/^Web Server/=' ${WRKSRC}/INSTALL) && \
${SED} -ne "$$line,\$$p" ${WRKSRC}/INSTALL > ${PKGMESSAGE}
do-install:
- ${MKDIR} ${DATADIR}
- (cd ${WRKSRC}/src && ${COPYTREE_SHARE} ${PORTNAME} ${PYTHONPREFIX_SITELIBDIR})
- ${INSTALL_DATA} ${WRKSRC}/src/automx_wsgi.py ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/src/automx-test ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/src/automx.conf \
- ${PREFIX}/etc/automx.conf.sample
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC}/src && \
+ ${COPYTREE_SHARE} ${PORTNAME} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR})
+ ${INSTALL_DATA} ${WRKSRC}/src/automx_wsgi.py ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/automx-test ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/src/conf/automx.conf \
+ ${STAGEDIR}${PREFIX}/etc/automx.conf.sample
.for s in 1 5
-. for m in ${MAN$s}
- ${INSTALL_MAN} ${WRKSRC}/doc/man/man$s/$m ${MAN$sPREFIX}/man/man$s
-. endfor
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/man$s/* ${STAGEDIR}${PREFIX}/man/man$s/
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "[^m]*" ${DOCSDIR})
-.endif
-
-post-install:
- [ -f ${PREFIX}/etc/${PORTNAME}.conf ] || \
- ${CP} -p ${PREFIX}/etc/${PORTNAME}.conf.sample \
- ${PREFIX}/etc/${PORTNAME}.conf
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "[^m]*" ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/mail/automx/distinfo b/mail/automx/distinfo
index 8c81eeffa815..d7627fedf4cb 100644
--- a/mail/automx/distinfo
+++ b/mail/automx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (automx-0.9.tar.gz) = 66dcd2f643c46f7046094beb3385e1129d70f28f438d83166e0b346f4c724e8c
-SIZE (automx-0.9.tar.gz) = 81770
+SHA256 (automx-0.9.2.tar.gz) = 98cd634ea019f993bd5e361697b03c725f0172e3d34cc19e2e5c2c43a287c665
+SIZE (automx-0.9.2.tar.gz) = 55622
diff --git a/mail/automx/files/patch-src-automx-test b/mail/automx/files/patch-src-automx-test
new file mode 100644
index 000000000000..193fa2f2d62f
--- /dev/null
+++ b/mail/automx/files/patch-src-automx-test
@@ -0,0 +1,78 @@
+--- src/automx-test.orig 2013-03-30 18:45:31.000000000 +0000
++++ src/automx-test 2013-12-21 20:34:11.520592847 +0000
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #
+ # automx - auto configuration service
+ # Copyright (c) 2011-2013 [*] sys4 AG
+@@ -18,19 +18,20 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+ #
++# Ported to sh to avoid a dependency on bash by crees@FreeBSD.org
++#
+ #
+ VERSION="0.9.2"
+
+ trap clean_exit EXIT
+-function clean_exit() {
+- [[ -f "$OLREQUEST" ]] && rm "$OLREQUEST"
+- [[ -f "$MBREQUEST" ]] && rm "$MBREQUEST"
++clean_exit() {
++ rm -f "$OLREQUEST" "$MBREQUEST"
+ }
+
+ # We need a mail address
+-if [[ $1 ]]; then
++if [ -n "$1" ]; then
+ PROFILE="$1"
+-else
++else
+ echo "Provide the mail address for which configuration settings should be retrieved."
+ read -ep "Mail address: " PROFILE
+ fi
+@@ -43,7 +44,7 @@
+
+ # Test Mozilla schema
+ AUTOCONF="autoconfig.$DOMAIN"
+-if [[ $(dig +short $AUTOCONF) ]]; then
++if [ -n "$(dig +short $AUTOCONF)" ]; then
+ CON="http://$AUTOCONF/mail/config-v1.1.xml?emailaddress=$PROFILE"
+ echo
+ echo "Testing Autoconfig ..."
+@@ -59,13 +60,12 @@
+
+ # Test Microsoft schema
+ AUTODISC="autodiscover.$DOMAIN"
+-if [[ -z $(dig +short $AUTODISC) ]]; then
++if [ -z "$(dig +short $AUTODISC)" ]; then
+ # default domain does not exist, try to discover non-default
+ AUTODISC="$(dig +short -t srv _autodiscover._tcp.$DOMAIN)"
+- AUTODISC="${AUTODISC//* /}"
+- AUTODISC="${AUTODISC%.*}"
++ AUTODISC="$(echo $AUTODISC | sed 's,[^ ]* ,,g;s,\.[^.]*$,,')"
+ fi
+-if [[ $AUTODISC ]]; then
++if [ -n "$AUTODISC" ]; then
+ # Test Microsoft Outlook schema
+ CON="https://$AUTODISC/autodiscover/autodiscover.xml"
+ cat <<-REQ >$OLREQUEST
+@@ -76,7 +76,7 @@
+ <EMailAddress>$PROFILE</EMailAddress>
+ </Request>
+ </Autodiscover>
+- REQ
++REQ
+
+ echo
+ echo "Testing Autodiscover (Microsoft Outlook(tm)) ..."
+@@ -94,7 +94,7 @@
+ <EMailAddress>$PROFILE</EMailAddress>
+ </Request>
+ </Autodiscover>
+- REQ
++REQ
+
+ echo
+ echo "Testing Autodiscover (mobilesync) ..."
diff --git a/mail/automx/pkg-descr b/mail/automx/pkg-descr
index e5cfad0510b8..9e2a8d8b5e53 100644
--- a/mail/automx/pkg-descr
+++ b/mail/automx/pkg-descr
@@ -1,15 +1,15 @@
-automx makes setting up a mail account easy. All your users need to provide
-is real name, mail address and password. Their mail client and automx will
+automx makes setting up a mail account easy. All your users need to provide
+is real name, mail address and password. Their mail client and automx will
safely handle the rest.
-automx runs on your server and handles mail account profile requests from
-your mail clients. Put an end to endless phone calls trying to coach users to
-configure settings, whose dialogs they can't find. Stop wasting your time
+automx runs on your server and handles mail account profile requests from
+your mail clients. Put an end to endless phone calls trying to coach users to
+configure settings, whose dialogs they can't find. Stop wasting your time
writing Tutorials nobody reads.
-automx unifies Microsofts and Mozillas mail account provisioning standards in
-one powerful Open Source tool. Choose from many backends, including LDAP and
-SQL, and let automx create standard and individualized profiles for multiple
-domains on the fly!
+automx unifies Microsoft's and Mozilla's mail account provisioning standards
+in one powerful Open Source tool. Choose from many backends, including LDAP
+and SQL, and let automx create standard and individualized profiles for
+multiple domains on the fly!
WWW: http://www.automx.org/en/
diff --git a/mail/automx/pkg-plist b/mail/automx/pkg-plist
index d61e645b1a26..b74e571dc7e3 100644
--- a/mail/automx/pkg-plist
+++ b/mail/automx/pkg-plist
@@ -1,7 +1,11 @@
bin/automx-test
@unexec cmp -s %D/etc/automx.conf %D/etc/automx.conf.sample && rm -f %D/etc/automx.conf || true
etc/automx.conf.sample
-@exec [ -f %B/automx.conf ] || cp -p %D/%F %B/automx.conf
+@exec cp -np %D/%F %B/automx.conf
+man/man1/automx-test.1.gz
+man/man5/automx.conf.5.gz
+man/man5/automx_ldap.5.gz
+man/man5/automx_sql.5.gz
%%PYTHON_SITELIBDIR%%/automx/__init__.py
%%PYTHON_SITELIBDIR%%/automx/config.py
%%PYTHON_SITELIBDIR%%/automx/ordereddict.py