aboutsummaryrefslogtreecommitdiff
path: root/mail/balsa/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-12-05 03:38:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-12-05 03:38:08 +0000
commit80c06677042ea3a4fbab231ca25afa94820fef67 (patch)
treebed38b9b84592545b20415d8d0b19276a43f9b44 /mail/balsa/Makefile
parenta947a5913799531441e25f8852df3a52a59115fa (diff)
downloadports-80c06677042ea3a4fbab231ca25afa94820fef67.tar.gz
ports-80c06677042ea3a4fbab231ca25afa94820fef67.zip
Notes
Diffstat (limited to 'mail/balsa/Makefile')
-rw-r--r--mail/balsa/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 4e838d2467d4..98a7bbf992df 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= balsa
-PORTVERSION= 2.3.6
-PORTREVISION= 3
+PORTVERSION= 2.3.7
CATEGORIES= mail gnome
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/
DISTNAME= balsa-${PORTVERSION}
@@ -45,6 +44,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
MAN1= balsa.1
OPTIONS= LDAP "Enable LDAP support" on \
+ GTKSPELL "Spell checking support" on \
GPG "Enable GnuPG support" off
.include <bsd.port.pre.mk>
@@ -59,6 +59,11 @@ USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap
.endif
+.if !defined(WITHOUT_GTKSPELL)
+LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
+CONFIGURE_ARGS+=--with-gtkspell
+.endif
+
.if ${PREFIX}==${X11BASE}
PLIST_SUB+= GTKICON="@comment "
.else