aboutsummaryrefslogtreecommitdiff
path: root/mail/balsa
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2002-02-13 04:46:10 +0000
committerAde Lovett <ade@FreeBSD.org>2002-02-13 04:46:10 +0000
commit546a2d618744bc42c4498214436869ca1688a0a7 (patch)
tree02bd1ee9d9be74f241bdffa9a3e3e18fb250b4d0 /mail/balsa
parent11074b85c828404470a75608046e8cedeffb6063 (diff)
downloadports-546a2d618744bc42c4498214436869ca1688a0a7.tar.gz
ports-546a2d618744bc42c4498214436869ca1688a0a7.zip
Notes
Diffstat (limited to 'mail/balsa')
-rw-r--r--mail/balsa/Makefile4
-rw-r--r--mail/balsa/distinfo2
-rw-r--r--mail/balsa/files/patch-aa13
-rw-r--r--mail/balsa/files/patch-src::sendmsg-window.c13
4 files changed, 22 insertions, 10 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index a6cf9293fe21..bbc2ea360ca6 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= balsa
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.1
CATEGORIES= mail gnome
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/ \
ftp://ftp.newton.cx/pub/balsa/
@@ -20,6 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/libesmtp-config:${PORTSDIR}/mail/libesmtp
RUN_DEPENDS= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell \
${LOCALBASE}/bin/libesmtp-config:${PORTSDIR}/mail/libesmtp
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= yes
USE_LIBTOOL= yes
@@ -32,6 +33,7 @@ CONFIGURE_ARGS= --enable-threads \
--with-ssl
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -lgiconv"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= balsa.1
diff --git a/mail/balsa/distinfo b/mail/balsa/distinfo
index e857076aca97..ab18b144c2ba 100644
--- a/mail/balsa/distinfo
+++ b/mail/balsa/distinfo
@@ -1 +1 @@
-MD5 (balsa-1.3.0.tar.gz) = 7309370fe64d633df5fe46b1a1a25a82
+MD5 (balsa-1.3.1.tar.bz2) = 579750f97d72cad987b8acf6edcafaa5
diff --git a/mail/balsa/files/patch-aa b/mail/balsa/files/patch-aa
index 3bb9576ba09e..804be0daff2d 100644
--- a/mail/balsa/files/patch-aa
+++ b/mail/balsa/files/patch-aa
@@ -1,13 +1,10 @@
-
-$FreeBSD$
-
---- src/Makefile.in.orig Tue Nov 6 12:02:00 2001
-+++ src/Makefile.in Tue Nov 6 12:03:19 2001
-@@ -216,7 +216,6 @@
+--- src/Makefile.in.orig Thu Feb 7 05:56:51 2002
++++ src/Makefile.in Thu Feb 7 09:53:04 2002
+@@ -230,7 +230,6 @@
$(top_builddir)/libmutt/libmutt.a \
$(top_builddir)/libinit_balsa/libinit_balsa.a \
-lpspell \
-- -lltdl \
+- -lltdl \
+ -lgdbm \
$(INTLLIBS) \
$(PCRE_LIBS) \
- $(PTHREAD_LIB)
diff --git a/mail/balsa/files/patch-src::sendmsg-window.c b/mail/balsa/files/patch-src::sendmsg-window.c
new file mode 100644
index 000000000000..f569907e8faf
--- /dev/null
+++ b/mail/balsa/files/patch-src::sendmsg-window.c
@@ -0,0 +1,13 @@
+ADDED FILE: files/patch-src::sendmsg-window.c
+
+--- src/sendmsg-window.c.orig Thu Feb 7 10:04:41 2002
++++ src/sendmsg-window.c Thu Feb 7 10:04:50 2002
+@@ -785,7 +785,7 @@
+ return;
+ }
+ if (pid == 0) {
+- setpgrp();
++ setpgrp(0, 0);
+
+ command = g_strdup_printf(balsa_app.extern_editor_command, filename);
+ cmdline = g_strsplit(command, " ", 1024);