aboutsummaryrefslogtreecommitdiff
path: root/mail/balsa
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-12-29 07:05:29 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-12-29 07:05:29 +0000
commitcdbf6a818265051327ab37c8e0ac680dccc701be (patch)
treed5ebd2fec74e7746dcaf762a91f2fab7d11038d7 /mail/balsa
parentb17ed67ddc622dd079a043f7258ada45d65a8a2e (diff)
downloadports-cdbf6a818265051327ab37c8e0ac680dccc701be.tar.gz
ports-cdbf6a818265051327ab37c8e0ac680dccc701be.zip
Notes
Diffstat (limited to 'mail/balsa')
-rw-r--r--mail/balsa/Makefile2
-rw-r--r--mail/balsa/distinfo6
-rw-r--r--mail/balsa/files/patch-libbalsa_mailbox_local.c33
-rw-r--r--mail/balsa/files/patch-libbalsa_mailbox_local.h11
-rw-r--r--mail/balsa/files/patch-libbalsa_mailbox_maildir.c83
-rw-r--r--mail/balsa/files/patch-libbalsa_mailbox_mbox.c18
-rw-r--r--mail/balsa/files/patch-libbalsa_mailbox_mh.c247
7 files changed, 378 insertions, 22 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 98a7bbf992df..c8e397cf9d3e 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= balsa
-PORTVERSION= 2.3.7
+PORTVERSION= 2.3.8
CATEGORIES= mail gnome
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/
DISTNAME= balsa-${PORTVERSION}
diff --git a/mail/balsa/distinfo b/mail/balsa/distinfo
index c50c70a0df5b..6c9d93ec60ef 100644
--- a/mail/balsa/distinfo
+++ b/mail/balsa/distinfo
@@ -1,3 +1,3 @@
-MD5 (balsa-2.3.7.tar.bz2) = d50a439a8b8c2be99e3b0108d5d6073e
-SHA256 (balsa-2.3.7.tar.bz2) = c6e70550b1b4d6a60b47768d8076c6b6e2e6b250d06fe08149dda561d4dea438
-SIZE (balsa-2.3.7.tar.bz2) = 3192144
+MD5 (balsa-2.3.8.tar.bz2) = 517c0a1cbd4dc85ec06a6c7b0f522ffa
+SHA256 (balsa-2.3.8.tar.bz2) = bc4c72ac1043d428fbd04313beb0b3ba2bb861b3cb34025e3158b957e29603b9
+SIZE (balsa-2.3.8.tar.bz2) = 3206115
diff --git a/mail/balsa/files/patch-libbalsa_mailbox_local.c b/mail/balsa/files/patch-libbalsa_mailbox_local.c
new file mode 100644
index 000000000000..90d988400c78
--- /dev/null
+++ b/mail/balsa/files/patch-libbalsa_mailbox_local.c
@@ -0,0 +1,33 @@
+--- libbalsa/mailbox_local.c.orig Thu Dec 29 01:47:25 2005
++++ libbalsa/mailbox_local.c Thu Dec 29 01:48:23 2005
+@@ -375,7 +375,7 @@ typedef struct {
+ #else /* GLIB_CHECK_VERSION(2, 8, 0) */
+ int fd;
+ #endif /* GLIB_CHECK_VERSION(2, 8, 0) */
+- guint (*fileno)(LibBalsaMailboxLocal * local, guint msgno);
++ guint (*sti_fileno)(LibBalsaMailboxLocal * local, guint msgno);
+ LibBalsaMailboxLocal *local;
+ } LibBalsaMailboxLocalSaveTreeInfo;
+
+@@ -399,9 +399,9 @@ lbm_local_save_tree_item(guint msgno, gu
+ if (msgno == 0) {
+ info.msgno = msgno;
+ info.value.total = a;
+- } else if (save_info->fileno) {
+- info.msgno = save_info->fileno(save_info->local, msgno);
+- info.value.parent = save_info->fileno(save_info->local, a);
++ } else if (save_info->sti_fileno) {
++ info.msgno = save_info->sti_fileno(save_info->local, msgno);
++ info.value.parent = save_info->sti_fileno(save_info->local, a);
+ } else {
+ info.msgno = msgno;
+ info.value.parent = a;
+@@ -466,7 +466,7 @@ lbm_local_save_tree(LibBalsaMailboxLocal
+ return;
+ }
+
+- save_info.fileno = LIBBALSA_MAILBOX_LOCAL_GET_CLASS(local)->fileno;
++ save_info.sti_fileno = LIBBALSA_MAILBOX_LOCAL_GET_CLASS(local)->sti_fileno;
+ save_info.local = local;
+ #if GLIB_CHECK_VERSION(2, 8, 0)
+ save_info.array =
diff --git a/mail/balsa/files/patch-libbalsa_mailbox_local.h b/mail/balsa/files/patch-libbalsa_mailbox_local.h
new file mode 100644
index 000000000000..985646513b23
--- /dev/null
+++ b/mail/balsa/files/patch-libbalsa_mailbox_local.h
@@ -0,0 +1,11 @@
+--- libbalsa/mailbox_local.h.orig Thu Dec 29 01:49:05 2005
++++ libbalsa/mailbox_local.h Thu Dec 29 01:49:13 2005
+@@ -66,7 +66,7 @@ struct _LibBalsaMailboxLocalClass {
+ gint (*check_files)(const gchar * path, gboolean create);
+ void (*set_path)(LibBalsaMailboxLocal * local, const gchar * path);
+ void (*remove_files)(LibBalsaMailboxLocal * local);
+- guint (*fileno)(LibBalsaMailboxLocal * local, guint msgno);
++ guint (*sti_fileno)(LibBalsaMailboxLocal * local, guint msgno);
+ };
+
+ GObject *libbalsa_mailbox_local_new(const gchar * path, gboolean create);
diff --git a/mail/balsa/files/patch-libbalsa_mailbox_maildir.c b/mail/balsa/files/patch-libbalsa_mailbox_maildir.c
index 811795eed8ea..ee8d9dcb9c6d 100644
--- a/mail/balsa/files/patch-libbalsa_mailbox_maildir.c
+++ b/mail/balsa/files/patch-libbalsa_mailbox_maildir.c
@@ -1,11 +1,84 @@
---- libbalsa/mailbox_maildir.c.orig Mon Jul 26 02:10:16 2004
-+++ libbalsa/mailbox_maildir.c Mon Jul 26 02:10:50 2004
-@@ -27,6 +27,8 @@
- #include <libgnome/gnome-config.h>
- #include <libgnome/gnome-i18n.h>
+--- libbalsa/mailbox_maildir.c.orig Tue Dec 27 04:44:40 2005
++++ libbalsa/mailbox_maildir.c Thu Dec 29 01:52:57 2005
+@@ -25,6 +25,8 @@
+ #define _XOPEN_SOURCE 500
+ #define _XOPEN_SOURCE_EXTENDED 1
+#include <sys/types.h>
+#include <sys/stat.h>
#include <unistd.h>
#include <fcntl.h>
#include <errno.h>
+@@ -50,7 +52,7 @@ struct message_info {
+ /* The message's order when parsing; needed for saving the message
+ * tree in a form that will match the msgnos when the mailbox is
+ * reopened. */
+- guint fileno;
++ guint mi_fileno;
+ };
+ #define REAL_FLAGS(flags) (flags & LIBBALSA_MESSAGE_FLAGS_REAL)
+ #define FLAGS_REALLY_DIFFER(orig_flags, flags) \
+@@ -194,7 +196,7 @@ libbalsa_mailbox_maildir_class_init(LibB
+ libbalsa_mailbox_local_class->set_path = lbm_maildir_set_path;
+ libbalsa_mailbox_local_class->remove_files = lbm_maildir_remove_files;
+ libbalsa_mailbox_local_class->load_message = lbm_maildir_load_message;
+- libbalsa_mailbox_local_class->fileno = lbm_maildir_fileno;
++ libbalsa_mailbox_local_class->sti_fileno = lbm_maildir_fileno;
+ }
+
+ static void
+@@ -408,7 +410,7 @@ static LibBalsaMessageFlag parse_filenam
+ }
+
+ static void lbm_maildir_parse(LibBalsaMailboxMaildir * mdir,
+- const gchar *subdir, guint * fileno)
++ const gchar *subdir, guint * md_fileno)
+ {
+ gchar *path;
+ GDir *dir;
+@@ -463,12 +465,12 @@ static void lbm_maildir_parse(LibBalsaMa
+ msg_info->key=key;
+ msg_info->filename=g_strdup(filename);
+ msg_info->flags = msg_info->orig_flags = flags;
+- msg_info->fileno = 0;
++ msg_info->mi_fileno = 0;
+ }
+ msg_info->subdir = subdir;
+- if (!msg_info->fileno)
++ if (!msg_info->mi_fileno)
+ /* First time we saw this key. */
+- msg_info->fileno = ++*fileno;
++ msg_info->mi_fileno = ++*md_fileno;
+ }
+ g_dir_close(dir);
+ }
+@@ -476,16 +478,16 @@ static void lbm_maildir_parse(LibBalsaMa
+ static void
+ lbm_maildir_parse_subdirs(LibBalsaMailboxMaildir * mdir)
+ {
+- guint msgno, fileno = 0;
++ guint msgno, md_fileno = 0;
+
+ for (msgno = mdir->msgno_2_msg_info->len; msgno > 0; --msgno) {
+ struct message_info *msg_info =
+ message_info_from_msgno(mdir, msgno);
+- msg_info->fileno = 0;
++ msg_info->mi_fileno = 0;
+ }
+
+- lbm_maildir_parse(mdir, "cur", &fileno);
+- lbm_maildir_parse(mdir, "new", &fileno);
++ lbm_maildir_parse(mdir, "cur", &md_fileno);
++ lbm_maildir_parse(mdir, "new", &md_fileno);
+ }
+
+ static gboolean
+@@ -927,7 +929,7 @@ lbm_maildir_fileno(LibBalsaMailboxLocal
+ msg_info =
+ message_info_from_msgno((LibBalsaMailboxMaildir *) local, msgno);
+
+- return msg_info->fileno;
++ return msg_info->mi_fileno;
+ }
+
+ /* Called with mailbox locked. */
diff --git a/mail/balsa/files/patch-libbalsa_mailbox_mbox.c b/mail/balsa/files/patch-libbalsa_mailbox_mbox.c
index d6843e323af4..2511938ff5de 100644
--- a/mail/balsa/files/patch-libbalsa_mailbox_mbox.c
+++ b/mail/balsa/files/patch-libbalsa_mailbox_mbox.c
@@ -1,5 +1,5 @@
---- libbalsa/mailbox_mbox.c.orig Tue Sep 20 13:01:57 2005
-+++ libbalsa/mailbox_mbox.c Thu Sep 22 20:32:25 2005
+--- libbalsa/mailbox_mbox.c.orig Tue Dec 27 14:54:34 2005
++++ libbalsa/mailbox_mbox.c Thu Dec 29 01:44:01 2005
@@ -26,6 +26,7 @@
#include <gmime/gmime-stream-fs.h>
@@ -8,12 +8,12 @@
#include <stdlib.h>
#include <unistd.h>
#include <fcntl.h>
-@@ -215,7 +216,7 @@ libbalsa_mailbox_mbox_create(const gchar
- if(!create)
- return(-1);
+@@ -214,7 +215,7 @@ lbm_mbox_check_files(const gchar * path,
+ } else if (create) {
+ gint fd;
-- if ((fd = creat(path, S_IRUSR | S_IWUSR)) == -1) {
+- if ((fd = creat(path, S_IRUSR | S_IWUSR)) == -1) {
+ if ((fd = open(path, O_CREAT | O_TRUNC | O_WRONLY, S_IRUSR | S_IWUSR)) == -1) {
- g_warning("An error:\n%s\n occurred while trying to "
- "create the mailbox \"%s\"\n",
- strerror(errno), path);
+ g_warning("An error:\n%s\n occurred while trying to "
+ "create the mailbox \"%s\"\n",
+ strerror(errno), path);
diff --git a/mail/balsa/files/patch-libbalsa_mailbox_mh.c b/mail/balsa/files/patch-libbalsa_mailbox_mh.c
index 7266a6867b3d..ecce74d29884 100644
--- a/mail/balsa/files/patch-libbalsa_mailbox_mh.c
+++ b/mail/balsa/files/patch-libbalsa_mailbox_mh.c
@@ -1,11 +1,250 @@
---- libbalsa/mailbox_mh.c.orig Mon Jul 26 02:11:26 2004
-+++ libbalsa/mailbox_mh.c Mon Jul 26 02:11:39 2004
+--- libbalsa/mailbox_mh.c.orig Tue Dec 27 04:44:41 2005
++++ libbalsa/mailbox_mh.c Thu Dec 29 01:55:40 2005
@@ -27,6 +27,8 @@
- #define _POSIX_SOURCE 1
- #include <libgnome/gnome-i18n.h>
+ /* to compile this on BSD/Darwin */
+ #undef _POSIX_SOURCE
+#include <sys/types.h>
+#include <sys/stat.h>
#include <unistd.h>
#include <fcntl.h>
#include <errno.h>
+@@ -46,7 +48,7 @@ struct message_info {
+ LibBalsaMessageFlag flags;
+ LibBalsaMessageFlag orig_flags;
+ LibBalsaMessage *message;
+- gint fileno;
++ gint mi_fileno;
+ };
+
+ static LibBalsaMailboxLocalClass *parent_class = NULL;
+@@ -278,7 +280,7 @@ libbalsa_mailbox_mh_load_config(LibBalsa
+
+ #define MH_BASENAME(msgno) \
+ g_strdup_printf((msgno->orig_flags & LIBBALSA_MESSAGE_FLAG_DELETED) ? \
+- ",%d" : "%d", msg_info->fileno)
++ ",%d" : "%d", msg_info->mi_fileno)
+
+ static GMimeStream *
+ libbalsa_mailbox_mh_get_message_stream(LibBalsaMailbox * mailbox,
+@@ -338,7 +340,7 @@ static gint
+ lbm_mh_compare_fileno(const struct message_info ** a,
+ const struct message_info ** b)
+ {
+- return (*a)->fileno - (*b)->fileno;
++ return (*a)->mi_fileno - (*b)->mi_fileno;
+ }
+
+ #define INVALID_FLAG ((unsigned) -1)
+@@ -357,7 +359,7 @@ lbm_mh_parse_mailbox(LibBalsaMailboxMh *
+
+ while ((filename = g_dir_read_name(dir)) != NULL) {
+ LibBalsaMessageFlag delete_flag = 0;
+- guint fileno;
++ guint mh_fileno;
+
+ if (filename[0] == ',') {
+ filename++;
+@@ -366,24 +368,24 @@ lbm_mh_parse_mailbox(LibBalsaMailboxMh *
+ if (lbm_mh_check_filename(filename) == FALSE)
+ continue;
+
+- if (sscanf(filename, "%d", &fileno) != 1)
++ if (sscanf(filename, "%d", &mh_fileno) != 1)
+ break; /* FIXME report error? */
+- if (fileno > mh->last_fileno)
+- mh->last_fileno = fileno;
++ if (mh_fileno > mh->last_fileno)
++ mh->last_fileno = mh_fileno;
+
+ if (add_msg_info && mh->messages_info) {
+ struct message_info *msg_info =
+ g_hash_table_lookup(mh->messages_info,
+- GINT_TO_POINTER(fileno));
++ GINT_TO_POINTER(mh_fileno));
+ if (!msg_info) {
+ msg_info = g_new0(struct message_info, 1);
+ msg_info->flags = INVALID_FLAG;
+ g_hash_table_insert(mh->messages_info,
+- GINT_TO_POINTER(fileno), msg_info);
++ GINT_TO_POINTER(mh_fileno), msg_info);
+ g_ptr_array_add(mh->msgno_2_msg_info, msg_info);
+ /* dummy entry in mindex for now */
+ g_ptr_array_add(LIBBALSA_MAILBOX(mh)->mindex, NULL);
+- msg_info->fileno = fileno;
++ msg_info->mi_fileno = mh_fileno;
+ }
+ msg_info->orig_flags = delete_flag;
+ }
+@@ -401,17 +403,17 @@ static const gchar *LibBalsaMailboxMhRep
+ static const gchar *LibBalsaMailboxMhRecent = "recent:";
+
+ static void
+-lbm_mh_set_flag(LibBalsaMailboxMh * mh, guint fileno, LibBalsaMessageFlag flag)
++lbm_mh_set_flag(LibBalsaMailboxMh * mh, guint mh_fileno, LibBalsaMessageFlag flag)
+ {
+ struct message_info *msg_info;
+
+- if (!fileno)
++ if (!mh_fileno)
+ return;
+
+- msg_info = g_hash_table_lookup(mh->messages_info, GINT_TO_POINTER(fileno));
++ msg_info = g_hash_table_lookup(mh->messages_info, GINT_TO_POINTER(mh_fileno));
+
+ if (!msg_info) {
+- g_print("MH sequence info for nonexistent message %d\n", fileno);
++ g_print("MH sequence info for nonexistent message %d\n", mh_fileno);
+ return;
+ }
+
+@@ -440,7 +442,7 @@ lbm_mh_handle_seq_line(LibBalsaMailboxMh
+
+ for (seq = sequences; *seq; seq++) {
+ guint end = 0;
+- guint fileno;
++ guint mh_fileno;
+
+ if (!**seq)
+ continue;
+@@ -451,11 +453,11 @@ lbm_mh_handle_seq_line(LibBalsaMailboxMh
+ if (sscanf(line, "%d", &end) != 1)
+ break; /* FIXME report error? */
+ }
+- if (sscanf(*seq, "%d", &fileno) != 1)
++ if (sscanf(*seq, "%d", &mh_fileno) != 1)
+ break; /* FIXME report error? */
+ do
+- lbm_mh_set_flag(mh, fileno, flag);
+- while (++fileno <= end);
++ lbm_mh_set_flag(mh, mh_fileno, flag);
++ while (++mh_fileno <= end);
+ }
+
+ g_strfreev(sequences);
+@@ -587,7 +589,7 @@ lbm_mh_check(LibBalsaMailboxMh * mh, con
+ sequences = g_strsplit(p, " ", 0);
+ for (seq = sequences; *seq; seq++) {
+ guint end = 0;
+- guint fileno;
++ guint mh_fileno;
+
+ if (!**seq)
+ continue;
+@@ -598,15 +600,15 @@ lbm_mh_check(LibBalsaMailboxMh * mh, con
+ if (sscanf(p, "%d", &end) != 1)
+ break; /* FIXME report error? */
+ }
+- if (sscanf(*seq, "%d", &fileno) != 1)
++ if (sscanf(*seq, "%d", &mh_fileno) != 1)
+ break; /* FIXME report error? */
+ do {
+- p = g_strdup_printf("%s/%d", path, fileno);
++ p = g_strdup_printf("%s/%d", path, mh_fileno);
+ if (access(p, F_OK) == 0)
+ retval = TRUE;
+ g_free(p);
+ /* One undeleted unread message is enough. */
+- } while (!retval && ++fileno <= end);
++ } while (!retval && ++mh_fileno <= end);
+ }
+ g_strfreev(sequences);
+ break;
+@@ -693,7 +695,7 @@ libbalsa_mailbox_mh_check(LibBalsaMailbo
+ else {
+ g_ptr_array_remove(mh->msgno_2_msg_info, msg_info);
+ g_hash_table_remove(mh->messages_info,
+- GINT_TO_POINTER(msg_info->fileno));
++ GINT_TO_POINTER(msg_info->mi_fileno));
+ libbalsa_mailbox_local_msgno_removed(mailbox, msgno);
+ if (renumber > msgno)
+ /* First message that needs renumbering. */
+@@ -773,11 +775,11 @@ lbm_mh_flag_line(struct message_info *ms
+ if (!(msg_info->flags & flag))
+ return;
+
+- if (li->last < msg_info->fileno - 1) {
++ if (li->last < msg_info->mi_fileno - 1) {
+ lbm_mh_print_line(li);
+- li->first = msg_info->fileno;
++ li->first = msg_info->mi_fileno;
+ }
+- li->last = msg_info->fileno;
++ li->last = msg_info->mi_fileno;
+ }
+
+ static gboolean
+@@ -858,7 +860,7 @@ libbalsa_mailbox_mh_sync(LibBalsaMailbox
+ /* free old information */
+ g_ptr_array_remove(mh->msgno_2_msg_info, msg_info);
+ g_hash_table_remove(mh->messages_info,
+- GINT_TO_POINTER(msg_info->fileno));
++ GINT_TO_POINTER(msg_info->mi_fileno));
+ libbalsa_mailbox_local_msgno_removed(mailbox, msgno);
+ } else {
+ lbm_mh_flag_line(msg_info, LIBBALSA_MESSAGE_FLAG_NEW, &unseen);
+@@ -1092,7 +1094,7 @@ libbalsa_mailbox_mh_fetch_message_struct
+ * we'll just add new lines and let the next sync merge them with any
+ * existing lines. */
+ static void
+-lbm_mh_update_sequences(LibBalsaMailboxMh * mh, gint fileno,
++lbm_mh_update_sequences(LibBalsaMailboxMh * mh, gint mh_fileno,
+ LibBalsaMessageFlag flags)
+ {
+ FILE *fp;
+@@ -1103,13 +1105,13 @@ lbm_mh_update_sequences(LibBalsaMailboxM
+ return;
+
+ if (flags & LIBBALSA_MESSAGE_FLAG_NEW)
+- fprintf(fp, "unseen: %d\n", fileno);
++ fprintf(fp, "unseen: %d\n", mh_fileno);
+ if (flags & LIBBALSA_MESSAGE_FLAG_FLAGGED)
+- fprintf(fp, "flagged: %d\n", fileno);
++ fprintf(fp, "flagged: %d\n", mh_fileno);
+ if (flags & LIBBALSA_MESSAGE_FLAG_REPLIED)
+- fprintf(fp, "replied: %d\n", fileno);
++ fprintf(fp, "replied: %d\n", mh_fileno);
+ if (flags & LIBBALSA_MESSAGE_FLAG_RECENT)
+- fprintf(fp, "recent: %d\n", fileno);
++ fprintf(fp, "recent: %d\n", mh_fileno);
+ fclose(fp);
+ }
+
+@@ -1126,7 +1128,7 @@ libbalsa_mailbox_mh_add_message(LibBalsa
+ int fd;
+ GMimeStream *out_stream;
+ GMimeFilter *crlffilter;
+- int fileno;
++ int mh_fileno;
+ int retries;
+ GMimeStream *in_stream;
+
+@@ -1169,14 +1171,14 @@ libbalsa_mailbox_mh_add_message(LibBalsa
+ libbalsa_mime_stream_shared_unlock(stream);
+ g_object_unref(in_stream);
+
+- fileno = mh->last_fileno;
++ mh_fileno = mh->last_fileno;
+ retries = 10;
+ do {
+ /* rename tempfile to message-number-name */
+ char *new_filename;
+ gint rename_status;
+
+- new_filename = g_strdup_printf("%s/%d", path, ++fileno);
++ new_filename = g_strdup_printf("%s/%d", path, ++mh_fileno);
+ rename_status = libbalsa_safe_rename(tmp, new_filename);
+ g_free(new_filename);
+ if (rename_status != -1)
+@@ -1199,9 +1201,9 @@ libbalsa_mailbox_mh_add_message(LibBalsa
+ "Too high activity?");
+ return FALSE;
+ }
+- mh->last_fileno = fileno;
++ mh->last_fileno = mh_fileno;
+
+- lbm_mh_update_sequences(mh, fileno,
++ lbm_mh_update_sequences(mh, mh_fileno,
+ flags | LIBBALSA_MESSAGE_FLAG_RECENT);
+
+ return TRUE;