aboutsummaryrefslogtreecommitdiff
path: root/mail/balsa
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-12-25 18:17:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-12-25 18:17:08 +0000
commit279a353d0b0b0ac0f47415df9d166e52c78425ae (patch)
tree61fa51991e80096c3def05729b9e3782215457d3 /mail/balsa
parent1bbed6b25b379cbc6640ee449eb3fa4c3c500b43 (diff)
downloadports-279a353d0b0b0ac0f47415df9d166e52c78425ae.tar.gz
ports-279a353d0b0b0ac0f47415df9d166e52c78425ae.zip
Notes
Diffstat (limited to 'mail/balsa')
-rw-r--r--mail/balsa/Makefile12
-rw-r--r--mail/balsa/distinfo6
-rw-r--r--mail/balsa/files/patch-configure44
-rw-r--r--mail/balsa/files/patch-libbalsa_mailbox_local.c18
-rw-r--r--mail/balsa/files/patch-libbalsa_misc.c12
-rw-r--r--mail/balsa/files/patch-src_print-gtk.c17
-rw-r--r--mail/balsa/files/patch-src_threads.h14
-rw-r--r--mail/balsa/pkg-plist1
8 files changed, 48 insertions, 76 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 38419a32de52..147bf446c696 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -7,10 +7,9 @@
#
PORTNAME= balsa
-PORTVERSION= 2.3.28
-PORTREVISION= 2
+PORTVERSION= 2.4.2
CATEGORIES= mail gnome
-MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/
+MASTER_SITES= http://pawsa.fedorapeople.org/balsa/
DISTNAME= balsa-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
@@ -20,7 +19,8 @@ LIB_DEPENDS= aspell.16:${PORTSDIR}/textproc/aspell \
pcre.0:${PORTSDIR}/devel/pcre \
esmtp.6:${PORTSDIR}/mail/libesmtp \
gmime-2.0.4:${PORTSDIR}/mail/gmime2 \
- gnome-keyring:${PORTSDIR}/security/gnome-keyring
+ gnome-keyring:${PORTSDIR}/security/gnome-keyring \
+ canberra-gtk.0:${PORTSDIR}/audio/libcanberra
USE_GMAKE= yes
USE_BZIP2= yes
@@ -36,7 +36,9 @@ GNU_CONFIGURE= yes
USE_ICONV= yes
CONFIGURE_ARGS= --enable-threads \
--disable-more-warnings \
- --with-ssl
+ --with-ssl \
+ --without-nm \
+ --with-canberra
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}"
diff --git a/mail/balsa/distinfo b/mail/balsa/distinfo
index 070a9cd5a213..e0ccae423ab3 100644
--- a/mail/balsa/distinfo
+++ b/mail/balsa/distinfo
@@ -1,3 +1,3 @@
-MD5 (balsa-2.3.28.tar.bz2) = c9ea1f5683fc094b1ffcab7b9e66dd5c
-SHA256 (balsa-2.3.28.tar.bz2) = c9160312fd9b3f7aa71d0a77450a1b2637f786c040133cc60a53a780f99fa58c
-SIZE (balsa-2.3.28.tar.bz2) = 3066523
+MD5 (balsa-2.4.2.tar.bz2) = 1eb90a92c089e194a595072a57c57394
+SHA256 (balsa-2.4.2.tar.bz2) = 48bde6ff926fcc5d47853b87242cc890bdb21b5c74a2454a2b5c0269e9340090
+SIZE (balsa-2.4.2.tar.bz2) = 3079414
diff --git a/mail/balsa/files/patch-configure b/mail/balsa/files/patch-configure
index 8d66051ff19c..bece457022fd 100644
--- a/mail/balsa/files/patch-configure
+++ b/mail/balsa/files/patch-configure
@@ -1,15 +1,6 @@
---- configure.orig 2009-01-01 17:16:25.000000000 -0500
-+++ configure 2009-01-01 17:18:27.000000000 -0500
-@@ -23250,7 +23250,7 @@ cat >>confdefs.h <<\_ACEOF
- #define HAVE_GTK_PRINT 1
- _ACEOF
-
-- gnome_print_extras=""
-+ #gnome_print_extras=""
- else
- gnome_print_extras="libgnomeprint-2.2 >= 2.1.4 libgnomeprintui-2.2 >= 2.1.4"
- fi
-@@ -23889,7 +23889,7 @@ if { as_var=$as_ac_Lib; eval "test \"\${
+--- configure.orig 2009-12-25 12:47:41.000000000 -0500
++++ configure 2009-12-25 12:55:51.000000000 -0500
+@@ -15258,7 +15258,7 @@ if { as_var=$as_ac_Lib; eval "test \"\${
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -18,7 +9,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -24383,7 +24383,7 @@ if test "${ac_cv_lib_ldap_ldap_search+se
+@@ -15752,7 +15752,7 @@ if test "${ac_cv_lib_ldap_ldap_search+se
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -27,7 +18,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -24448,7 +24448,7 @@ cat >>confdefs.h <<\_ACEOF
+@@ -15817,7 +15817,7 @@ cat >>confdefs.h <<\_ACEOF
#define ENABLE_LDAP 1
_ACEOF
@@ -36,7 +27,7 @@
else
{ { $as_echo "$as_me:$LINENO: error: *** You enabled LDAP but ldap library is not found." >&5
$as_echo "$as_me: error: *** You enabled LDAP but ldap library is not found." >&2;}
-@@ -26363,13 +26363,13 @@ _ACEOF
+@@ -18216,13 +18216,13 @@ _ACEOF
else
@@ -54,7 +45,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -26383,11 +26383,11 @@ cat >>conftest.$ac_ext <<_ACEOF
+@@ -18236,11 +18236,11 @@ cat >>conftest.$ac_ext <<_ACEOF
#ifdef __cplusplus
extern "C"
#endif
@@ -68,7 +59,7 @@
;
return 0;
}
-@@ -26413,12 +26413,12 @@ $as_echo "$ac_try_echo") >&5
+@@ -18266,12 +18266,12 @@ $as_echo "$ac_try_echo") >&5
test "$cross_compiling" = yes ||
$as_test_x conftest$ac_exeext
}; then
@@ -83,7 +74,7 @@
fi
rm -rf conftest.dSYM
-@@ -26426,19 +26426,19 @@ rm -f core conftest.err conftest.$ac_obj
+@@ -18279,19 +18279,19 @@ rm -f core conftest.err conftest.$ac_obj
conftest$ac_exeext conftest.$ac_ext
LIBS=$ac_check_lib_save_LIBS
fi
@@ -109,7 +100,7 @@
{ (exit 1); exit 1; }; }
fi
-@@ -26446,18 +26446,18 @@ fi
+@@ -18299,18 +18299,18 @@ fi
fi
@@ -136,7 +127,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -26465,7 +26465,7 @@ cat confdefs.h >>conftest.$ac_ext
+@@ -18318,7 +18318,7 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
@@ -145,7 +136,7 @@
_ACEOF
rm -f conftest.$ac_objext
if { (ac_try="$ac_compile"
-@@ -26498,15 +26498,15 @@ rm -f core conftest.err conftest.$ac_obj
+@@ -18351,15 +18351,15 @@ rm -f core conftest.err conftest.$ac_obj
$as_echo "$ac_header_compiler" >&6; }
# Is the header present?
@@ -164,7 +155,7 @@
_ACEOF
if { (ac_try="$ac_cpp conftest.$ac_ext"
case "(($ac_try" in
-@@ -26540,44 +26540,44 @@ $as_echo "$ac_header_preproc" >&6; }
+@@ -18393,44 +18393,44 @@ $as_echo "$ac_header_preproc" >&6; }
# So? What about this header?
case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
yes:no: )
@@ -234,3 +225,12 @@
{ (exit 1); exit 1; }; }
fi
+@@ -18733,7 +18733,7 @@ fi
+
+
+ cat >>confdefs.h <<\_ACEOF
+-#define _XOPEN_SOURCE 500
++/*#define _XOPEN_SOURCE 500*/
+ _ACEOF
+
+ { $as_echo "$as_me:$LINENO: checking whether localtime_r is declared" >&5
diff --git a/mail/balsa/files/patch-libbalsa_mailbox_local.c b/mail/balsa/files/patch-libbalsa_mailbox_local.c
index 90d988400c78..ebe5653298ec 100644
--- a/mail/balsa/files/patch-libbalsa_mailbox_local.c
+++ b/mail/balsa/files/patch-libbalsa_mailbox_local.c
@@ -1,15 +1,15 @@
---- libbalsa/mailbox_local.c.orig Thu Dec 29 01:47:25 2005
-+++ libbalsa/mailbox_local.c Thu Dec 29 01:48:23 2005
-@@ -375,7 +375,7 @@ typedef struct {
- #else /* GLIB_CHECK_VERSION(2, 8, 0) */
- int fd;
- #endif /* GLIB_CHECK_VERSION(2, 8, 0) */
+--- libbalsa/mailbox_local.c.orig 2009-05-23 03:02:12.000000000 -0400
++++ libbalsa/mailbox_local.c 2009-12-25 12:39:52.000000000 -0500
+@@ -440,7 +440,7 @@ libbalsa_mailbox_local_load_config(LibBa
+
+ typedef struct {
+ GArray * array;
- guint (*fileno)(LibBalsaMailboxLocal * local, guint msgno);
+ guint (*sti_fileno)(LibBalsaMailboxLocal * local, guint msgno);
LibBalsaMailboxLocal *local;
} LibBalsaMailboxLocalSaveTreeInfo;
-@@ -399,9 +399,9 @@ lbm_local_save_tree_item(guint msgno, gu
+@@ -464,9 +464,9 @@ lbm_local_save_tree_item(guint msgno, gu
if (msgno == 0) {
info.msgno = msgno;
info.value.total = a;
@@ -22,12 +22,12 @@
} else {
info.msgno = msgno;
info.value.parent = a;
-@@ -466,7 +466,7 @@ lbm_local_save_tree(LibBalsaMailboxLocal
+@@ -524,7 +524,7 @@ lbm_local_save_tree(LibBalsaMailboxLocal
return;
}
- save_info.fileno = LIBBALSA_MAILBOX_LOCAL_GET_CLASS(local)->fileno;
+ save_info.sti_fileno = LIBBALSA_MAILBOX_LOCAL_GET_CLASS(local)->sti_fileno;
save_info.local = local;
- #if GLIB_CHECK_VERSION(2, 8, 0)
save_info.array =
+ g_array_new(FALSE, FALSE, sizeof(LibBalsaMailboxLocalTreeInfo));
diff --git a/mail/balsa/files/patch-libbalsa_misc.c b/mail/balsa/files/patch-libbalsa_misc.c
deleted file mode 100644
index 22af56e0eac5..000000000000
--- a/mail/balsa/files/patch-libbalsa_misc.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- libbalsa/misc.c.orig Fri Feb 18 18:05:54 2005
-+++ libbalsa/misc.c Sat Mar 19 14:44:04 2005
-@@ -23,7 +23,9 @@
- #include "config.h"
-
- #define _SVID_SOURCE 1
-+#ifndef __FreeBSD__
- #define _XOPEN_SOURCE 500
-+#endif
- #include <ctype.h>
- #include <dirent.h>
- #include <errno.h>
diff --git a/mail/balsa/files/patch-src_print-gtk.c b/mail/balsa/files/patch-src_print-gtk.c
deleted file mode 100644
index 2e2d0ae705ad..000000000000
--- a/mail/balsa/files/patch-src_print-gtk.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/print-gtk.c.orig Thu May 3 22:59:46 2007
-+++ src/print-gtk.c Thu May 3 23:01:30 2007
-@@ -378,12 +378,14 @@ get_default_user_units(void)
- gchar *e = _("default:mm");
-
- #ifdef HAVE_LANGINFO
-+#ifdef _NL_MEASUREMENT_MEASUREMENT
- gchar *imperial = NULL;
-
- imperial = nl_langinfo(_NL_MEASUREMENT_MEASUREMENT);
- if (imperial && imperial[0] == 2 )
- return GTK_UNIT_INCH; /* imperial */
- if (imperial && imperial[0] == 1 )
-+#endif
- return GTK_UNIT_MM; /* metric */
- #endif
-
diff --git a/mail/balsa/files/patch-src_threads.h b/mail/balsa/files/patch-src_threads.h
index 62c60b878960..585d798ba6f9 100644
--- a/mail/balsa/files/patch-src_threads.h
+++ b/mail/balsa/files/patch-src_threads.h
@@ -1,12 +1,10 @@
---- src/threads.h.orig Tue Dec 31 14:06:47 2002
-+++ src/threads.h Tue Dec 31 14:07:32 2002
-@@ -21,6 +21,9 @@
-
- #ifndef __THREADS_H__
+--- src/threads.h.orig 2009-08-30 05:03:26.000000000 -0400
++++ src/threads.h 2009-12-25 12:41:53.000000000 -0500
+@@ -23,6 +23,7 @@
#define __THREADS_H__
-+
+
+ #include <unistd.h>
+#include <pthread.h>
-+
+
/* FIXME: mailbox_lock is really an internal libbalsa mutex. */
extern pthread_mutex_t mailbox_lock;
-
diff --git a/mail/balsa/pkg-plist b/mail/balsa/pkg-plist
index eb9cc41a074b..91891313b630 100644
--- a/mail/balsa/pkg-plist
+++ b/mail/balsa/pkg-plist
@@ -141,6 +141,7 @@ share/locale/en_CA/LC_MESSAGES/balsa.mo
share/locale/en_GB/LC_MESSAGES/balsa.mo
share/locale/es/LC_MESSAGES/balsa.mo
share/locale/et/LC_MESSAGES/balsa.mo
+share/locale/eu/LC_MESSAGES/balsa.mo
share/locale/fi/LC_MESSAGES/balsa.mo
share/locale/fr/LC_MESSAGES/balsa.mo
share/locale/ga/LC_MESSAGES/balsa.mo