aboutsummaryrefslogtreecommitdiff
path: root/mail/bogofilter
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-06-21 14:44:17 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-06-21 14:44:17 +0000
commit07487e2a7e303cb895a46f3cec82418ce6e38ba4 (patch)
treef6e32c6c05ec1b27d3d6cfce291c554defb6df03 /mail/bogofilter
parent8e7fa9577c04481762aca502418c8a1ccb9dba72 (diff)
downloadports-07487e2a7e303cb895a46f3cec82418ce6e38ba4.tar.gz
ports-07487e2a7e303cb895a46f3cec82418ce6e38ba4.zip
Notes
Diffstat (limited to 'mail/bogofilter')
-rw-r--r--mail/bogofilter/Makefile2
-rw-r--r--mail/bogofilter/files/patch-src_bf__resize.in29
2 files changed, 30 insertions, 1 deletions
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 32d8cfed2b74..45df0ee68385 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bogofilter
PORTVERSION= 0.94.14
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/mail/bogofilter/files/patch-src_bf__resize.in b/mail/bogofilter/files/patch-src_bf__resize.in
new file mode 100644
index 000000000000..a7f425f7cda3
--- /dev/null
+++ b/mail/bogofilter/files/patch-src_bf__resize.in
@@ -0,0 +1,29 @@
+--- a/src/bf_resize.in Mon Jun 13 21:56:45 2005
++++ b/src/bf_resize.in Mon Jun 20 13:50:17 2005
+@@ -35,19 +35,19 @@
+ # count pages in database files
+ for DB in $DATABASES ; do
+ COUNT=`bogoutil --db-print-leafpage-count="$DB"`
+- let PAGES="$PAGES + $COUNT"
++ PAGES=$(( $PAGES + $COUNT ))
+ done
+
+ # be generous, double count
+-let PAGES="$PAGES + $PAGES"
++PAGES=$(( $PAGES + $PAGES ))
+
+ # and update or create DB_CONFIG
+ : >> "$BOGOHOME"/DB_CONFIG
+-(
+- set +e
+- egrep -v '^set_lk_max_(locks|objects)' "$BOGOHOME"/DB_CONFIG >"$BOGOHOME"/DB_CONFIG.new
+-)
+-if [ $? -ge 2 ] ; then exit 1 ; fi
++set +e
++egrep -v '^set_lk_max_(locks|objects)' "$BOGOHOME"/DB_CONFIG >"$BOGOHOME"/DB_CONFIG.new
++s=$?
++set -e
++if [ $s -ge 2 ] ; then exit 1 ; fi
+ echo >>"$BOGOHOME"/DB_CONFIG.new set_lk_max_locks $PAGES
+ echo >>"$BOGOHOME"/DB_CONFIG.new set_lk_max_objects $PAGES
+ mv "$BOGOHOME"/DB_CONFIG.new "$BOGOHOME"/DB_CONFIG