aboutsummaryrefslogtreecommitdiff
path: root/mail/bogofilter
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-07-01 06:26:49 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-07-01 06:26:49 +0000
commit0d5d668fd75c633c469b7fdb203178a1a8dfe575 (patch)
tree3c44a4e6576322984f9ce9bd9d5a3f120d8a0ec1 /mail/bogofilter
parent9785389fb4aa30e7e5fb22ab49f505f05ed23841 (diff)
downloadports-0d5d668fd75c633c469b7fdb203178a1a8dfe575.tar.gz
ports-0d5d668fd75c633c469b7fdb203178a1a8dfe575.zip
Notes
Diffstat (limited to 'mail/bogofilter')
-rw-r--r--mail/bogofilter/Makefile2
-rw-r--r--mail/bogofilter/files/patch-SVNr698911
-rw-r--r--mail/bogofilter/files/patch-SVNr699014
-rw-r--r--mail/bogofilter/files/patch-SVNr699111
-rw-r--r--mail/bogofilter/files/patch-SVNr6993-minimal11
5 files changed, 48 insertions, 1 deletions
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 7d7b5da54b5c..ee7640bb9081 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bogofilter
PORTVERSION= 1.2.3
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= mail
MASTER_SITES= SF/bogofilter/bogofilter-current/bogofilter-${PORTVERSION}
diff --git a/mail/bogofilter/files/patch-SVNr6989 b/mail/bogofilter/files/patch-SVNr6989
new file mode 100644
index 000000000000..ce087c919b73
--- /dev/null
+++ b/mail/bogofilter/files/patch-SVNr6989
@@ -0,0 +1,11 @@
+--- src/bogoconfig.c (Revision 6988)
++++ src/bogoconfig.c (Revision 6989)
+@@ -102,7 +102,7 @@
+ LONGOPTIONS_DB
+ /* bogofilter specific options */
+ { "classify-files", N, 0, 'B' },
+- { "syslog-tag", N, 0, 'L' },
++ { "syslog-tag", R, 0, 'L' },
+ { "classify-mbox", N, 0, 'M' },
+ { "unregister-nonspam", N, 0, 'N' },
+ { "dataframe", N, 0, 'R' },
diff --git a/mail/bogofilter/files/patch-SVNr6990 b/mail/bogofilter/files/patch-SVNr6990
new file mode 100644
index 000000000000..5cf982e5f243
--- /dev/null
+++ b/mail/bogofilter/files/patch-SVNr6990
@@ -0,0 +1,14 @@
+--- src/bogotune.c (Revision 6989)
++++ src/bogotune.c (Revision 6990)
+@@ -1852,6 +1852,11 @@
+ if (ds_path == NULL)
+ ds_path = get_directory(PR_ENV_HOME);
+
++ if (ds_path == NULL) {
++ fprintf(stderr, "Cannot derive bogofilter directory from environment, aborting.\n");
++ exit(EX_ERROR);
++ }
++
+ set_bogohome(ds_path);
+ bfp = bfpath_create(ds_path);
+
diff --git a/mail/bogofilter/files/patch-SVNr6991 b/mail/bogofilter/files/patch-SVNr6991
new file mode 100644
index 000000000000..393103d22d86
--- /dev/null
+++ b/mail/bogofilter/files/patch-SVNr6991
@@ -0,0 +1,11 @@
+--- src/longoptions.h (Revision 6990)
++++ src/longoptions.h (Revision 6991)
+@@ -133,7 +133,7 @@
+
+ #define LONGOPTIONS_DB \
+ { "db-transaction", R, 0, O_DB_TRANSACTION }, \
+- { "timestamp-date", N, 0, 'y' }, \
++ { "timestamp-date", R, 0, 'y' }, \
+ lo1 lo2
+
+ #endif
diff --git a/mail/bogofilter/files/patch-SVNr6993-minimal b/mail/bogofilter/files/patch-SVNr6993-minimal
new file mode 100644
index 000000000000..4d8a0c123bb0
--- /dev/null
+++ b/mail/bogofilter/files/patch-SVNr6993-minimal
@@ -0,0 +1,11 @@
+--- src/bogoconfig.c (Revision 6992)
++++ src/bogoconfig.c (Revision 6993)
+@@ -121,7 +121,7 @@
+ { "debug-to-stdout", N, 0, 'D' },
+ { "no-header-tags", N, 0, 'H' },
+ { "query", N, 0, 'Q' },
+- { "db-cachesize", N, 0, 'k' },
++ { "db-cachesize", R, 0, 'k' },
+ { "ns-esf", R, 0, O_NS_ESF },
+ { "sp-esf", R, 0, O_SP_ESF },
+ { "ham-cutoff", R, 0, O_HAM_CUTOFF },