aboutsummaryrefslogtreecommitdiff
path: root/mail/bsmtp
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2007-07-24 17:36:02 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2007-07-24 17:36:02 +0000
commitd368a7dd35d14b4e492777bfbc2f06102c359f93 (patch)
tree91a2bd4d7d0a9622f07d9dd9184a9c4e772dcea7 /mail/bsmtp
parent76eb368f1382305db93c3e466ddcd6c9c36682d7 (diff)
downloadports-d368a7dd35d14b4e492777bfbc2f06102c359f93.tar.gz
ports-d368a7dd35d14b4e492777bfbc2f06102c359f93.zip
Notes
Diffstat (limited to 'mail/bsmtp')
-rw-r--r--mail/bsmtp/Makefile7
-rw-r--r--mail/bsmtp/files/config.sed4
-rw-r--r--mail/bsmtp/files/patch-configure15
-rw-r--r--mail/bsmtp/files/patch-rsmtp.in14
4 files changed, 31 insertions, 9 deletions
diff --git a/mail/bsmtp/Makefile b/mail/bsmtp/Makefile
index ac474d684ff7..f504d5ec6aa9 100644
--- a/mail/bsmtp/Makefile
+++ b/mail/bsmtp/Makefile
@@ -6,7 +6,7 @@
PORTNAME= bsmtp
PORTVERSION= 1.02
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= naddy
@@ -32,7 +32,10 @@ UUPREFIX= ${LOCALBASE}
post-patch:
@${CP} ${WRKSRC}/bsmtp.m4.8.9.in ${WRKSRC}/bsmtp.m4.8.10.in
- @${CP} ${FILESDIR}/bsmtp.m4.*.in ${WRKSRC}/
+ @${CP} ${FILESDIR}/bsmtp.m4.8.11.in ${WRKSRC}/
+.for v in 12 13 14
+ @${CP} ${FILESDIR}/bsmtp.m4.8.12.in ${WRKSRC}/bsmtp.m4.8.$v.in
+.endfor
pre-configure:
@${SED} <${FILESDIR}/config.sed >${WRKSRC}/config.sed \
diff --git a/mail/bsmtp/files/config.sed b/mail/bsmtp/files/config.sed
index 1c90cb181839..47dad38823a7 100644
--- a/mail/bsmtp/files/config.sed
+++ b/mail/bsmtp/files/config.sed
@@ -20,9 +20,9 @@ s,@DAEMONUID@,66,
s,@INPROTO@,BSMTP,
s,@LOCALHOSTNAME@,`hostname`,
s,@DOMAINSUFFIX@,none,
-s,@SENDMAILVERS@,8.11,
+s,@SENDMAILVERS@,8.13,
s,@INSTALLMAILER@,true,
-s,@MAILERVERSION@,8.11,
+s,@MAILERVERSION@,8.13,
s,@FLOCK@,true,
s,@LOCKDEFINE@,-DUSE_FLOCK,
s,@BATCHER@,batcher.new,
diff --git a/mail/bsmtp/files/patch-configure b/mail/bsmtp/files/patch-configure
index 096a7de0a43f..56ff15c81d87 100644
--- a/mail/bsmtp/files/patch-configure
+++ b/mail/bsmtp/files/patch-configure
@@ -1,20 +1,21 @@
$FreeBSD$
---- configure.orig Fri Feb 22 17:30:58 2002
-+++ configure Fri Feb 22 17:32:13 2002
-@@ -41,6 +41,10 @@
+--- configure.orig
++++ configure
+@@ -41,6 +41,11 @@
"batcher",
"batcher.c",
"bsmtp.c",
++ "bsmtp.m4.8.14",
++ "bsmtp.m4.8.13",
+ "bsmtp.m4.8.12",
+ "bsmtp.m4.8.11",
+ "bsmtp.m4.8.10",
-+ "bsmtp.m4.8.9",
"bsmtp.m4.8.9",
"bsmtp.m4.8.8",
"bsmtp.m4.8.7",
-@@ -198,6 +202,12 @@
+@@ -198,6 +203,16 @@
$default[$i] = '8.8';
} elsif ($value{'@SENDMAILVERS@'} =~ /^\s*8\.9(\..*)?\s*$/) {
$default[$i] = '8.9';
@@ -24,6 +25,10 @@ $FreeBSD$
+ $default[$i] = '8.11';
+ } elsif ($value{'@SENDMAILVERS@'} =~ /^\s*8\.12(\..*)?\s*$/) {
+ $default[$i] = '8.12';
++ } elsif ($value{'@SENDMAILVERS@'} =~ /^\s*8\.13(\..*)?\s*$/) {
++ $default[$i] = '8.13';
++ } elsif ($value{'@SENDMAILVERS@'} =~ /^\s*8\.14(\..*)?\s*$/) {
++ $default[$i] = '8.14';
} else {
$default[$i] = ''; # Will not be installed
}
diff --git a/mail/bsmtp/files/patch-rsmtp.in b/mail/bsmtp/files/patch-rsmtp.in
new file mode 100644
index 000000000000..c8be41aa310d
--- /dev/null
+++ b/mail/bsmtp/files/patch-rsmtp.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- rsmtp.in.orig
++++ rsmtp.in
+@@ -72,7 +72,7 @@
+ print STDERR "Recipient: $r\n" if ($debug);
+ push (@recipients, $r);
+ }
+- $sendmail="$sendmailproto -f$mailfrom -p@INPROTO@:$fromhost";
++ $sendmail="$sendmailproto -f$mailfrom -p@INPROTO@:$fromhost --";
+ while (defined $recipients[0]) {
+ $sendmail .= " " . $recipients[0];
+ shift (@recipients);