aboutsummaryrefslogtreecommitdiff
path: root/mail/cclient/Makefile
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-25 02:40:49 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-25 02:40:49 +0000
commitbd84b72bdf932f2957b5e0279c0b5ae31a654f5d (patch)
tree421cf0315fdf901461aba316b458b7292110c51c /mail/cclient/Makefile
parentc56260ec484f7d960b9422613b6b4b8f39e682d9 (diff)
downloadports-bd84b72bdf932f2957b5e0279c0b5ae31a654f5d.tar.gz
ports-bd84b72bdf932f2957b5e0279c0b5ae31a654f5d.zip
Notes
Diffstat (limited to 'mail/cclient/Makefile')
-rw-r--r--mail/cclient/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/mail/cclient/Makefile b/mail/cclient/Makefile
index e09b50c897b2..59449c478125 100644
--- a/mail/cclient/Makefile
+++ b/mail/cclient/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= cclient
-PORTVERSION= 0104241750
+PORTVERSION= 0106191041
CATEGORIES= mail devel
-MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
- ftp://ftp.nuug.no/pub/anders/distfiles/%SUBDIR%/ \
- http://www.freenix.no/~anders/%SUBDIR%/ \
- ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/imap/%SUBDIR%/ \
- http://mirror.nucba.ac.jp/mirror/%SUBDIR%/
+MASTER_SITES= ftp://ftp.cac.washington.edu/imap/ \
+ http://www.freenix.no/~anders/ \
+ ftp://ftp.funet.fi/pub/mirrors/ftp.cac.washington.edu/imap/ \
+ http://mirror.nucba.ac.jp/mirror/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
MASTER_SITE_SUBDIR= . old
DISTNAME= imap-2001.BETA.SNAP-${PORTVERSION}
EXTRACT_SUFX= .tar.Z
@@ -52,6 +52,7 @@ post-configure:
HEADERS= dummy.h env.h env_unix.h fdstring.h flstring.h fs.h ftl.h \
imap4r1.h linkage.c linkage.h mail.h misc.h nl.h nntp.h \
osdep.h pop3.h rfc822.h smtp.h tcp.h utf8.h c-client.h
+PORTREV_H= ${PREFIX}/include/c-client/portrevision.h
do-install:
${MKDIR} ${PREFIX}/include/c-client
@@ -64,13 +65,17 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/c-client/c-client.a \
${PREFIX}/lib/lib${SHLIBBASE}.a
-.if defined(WITH_SSL)
post-install:
+ @${ECHO} "#define CCLIENT_PORTVERSION \"${PORTVERSION}\"" >${PORTREV_H}
+.if defined(WITH_SSL)
@${ECHO} "================================================================================"
@${ECHO} "Warning: You have chosen to include SSL support. Applications/ports that use"
@${ECHO} "the cclient library but do not support SSL may stop working or have problems
@${ECHO} "linking. Linking explicitly with ssl (-lssl -lcrypto) may or may not help."
@${ECHO} "================================================================================"
+ @${ECHO} "#define CCLIENT_SSLENABLED \"yes\"" >>${PORTREV_H}
+.else
+ @${ECHO} "#define CCLIENT_SSLENABLED \"no\"" >>${PORTREV_H}
.endif
.include <bsd.port.post.mk>