aboutsummaryrefslogtreecommitdiff
path: root/mail/cclient
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2007-07-01 20:57:04 +0000
committerAnders Nordby <anders@FreeBSD.org>2007-07-01 20:57:04 +0000
commita138d284c8fda23091a9ddd17f72b9304c8164de (patch)
tree357eb057f11bf13b740b9c5904b54a91e3d256f2 /mail/cclient
parent1dfb934a2381e8013f999cd0ab5b5a27bb13bbb3 (diff)
downloadports-a138d284c8fda23091a9ddd17f72b9304c8164de.tar.gz
ports-a138d284c8fda23091a9ddd17f72b9304c8164de.zip
Notes
Diffstat (limited to 'mail/cclient')
-rw-r--r--mail/cclient/Makefile6
-rw-r--r--mail/cclient/files/patch-ab16
2 files changed, 10 insertions, 12 deletions
diff --git a/mail/cclient/Makefile b/mail/cclient/Makefile
index 0deb781608f3..7fc277500046 100644
--- a/mail/cclient/Makefile
+++ b/mail/cclient/Makefile
@@ -25,10 +25,12 @@ OPTIONS= SSL "Compile with SSL support" on \
IPV6 "Support IPv6" on \
MBX_DEFAULT "Use MBX as default mailbox format" off
+.include <bsd.port.pre.mk>
+
USE_LDCONFIG= yes
ALL_TARGET= bsf
.if defined(WITHOUT_SSL)
-MAKE_ARGS+= SSLTYPE=none
+MAKE_ARGS+= SSLTYPE=none SSLDIR=${OPENSSLBASE}
.else
USE_OPENSSL= yes
.if defined(WITH_SSL_AND_PLAINTEXT)
@@ -46,8 +48,6 @@ SHLIBNAME= lib${SHLIBBASE}.so.${SHLIBMAJ}
MAKE_ENV= SHLIBNAME=${SHLIBNAME} SHLIBBASE=${SHLIBBASE}
PLIST_SUB= SHLIBNAME=${SHLIBNAME} SHLIBBASE=${SHLIBBASE}
-.include <bsd.port.pre.mk>
-
post-patch:
.for file in Makefile src/osdep/unix/Makefile src/osdep/unix/Makefile.gss
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" ${WRKSRC}/${file}
diff --git a/mail/cclient/files/patch-ab b/mail/cclient/files/patch-ab
index de2e3b67231e..eb46cc1b9425 100644
--- a/mail/cclient/files/patch-ab
+++ b/mail/cclient/files/patch-ab
@@ -1,5 +1,5 @@
---- src/osdep/unix/Makefile.orig Thu Apr 21 00:48:34 2005
-+++ src/osdep/unix/Makefile Mon May 30 19:08:25 2005
+--- src/osdep/unix/Makefile.orig Sat Apr 30 22:51:13 2005
++++ src/osdep/unix/Makefile Sun Jul 1 22:29:26 2007
@@ -22,8 +22,8 @@
EXTRAAUTHENTICATORS=
@@ -17,13 +17,11 @@
-SSLDIR=/usr/local/ssl
-SSLCERTS=$(SSLDIR)/certs
-+SSLDIR=$(OPENSSLBASE)
++#SSLDIR=/usr/local/ssl
+SSLCERTS=$(PREFIX)/certs
SSLKEYS=$(SSLCERTS)
--SSLINCLUDE=$(SSLDIR)/include
--SSLLIB=$(SSLDIR)/lib
-+SSLINCLUDE=$(OPENSSLINC)
-+SSLLIB=$(OPENSSLLIB)
+ SSLINCLUDE=$(SSLDIR)/include
+ SSLLIB=$(SSLDIR)/lib
-SSLCRYPTO=-lcrypto
+SSLCRYPTO=-lcrypto -lcrypt
@@ -121,7 +119,7 @@
# Dependencies
-@@ -850,7 +867,7 @@
+@@ -850,7 +863,7 @@
# OS-dependent
@@ -130,7 +128,7 @@
osdep.h env_unix.h tcp_unix.h \
osdep.c env_unix.c fs_unix.c ftl_unix.c nl_unix.c tcp_unix.c ip_unix.c\
auths.c crexcl.c flockcyg.c flocklnx.c flocksim.c nfstest.c fsync.c \
-@@ -864,12 +881,19 @@
+@@ -864,12 +877,19 @@
write.c sslstdio.c \
strerror.c strpbrk.c strstr.c strtok.c strtoul.c \
OSCFLAGS