aboutsummaryrefslogtreecommitdiff
path: root/mail/cclient
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2007-06-26 08:08:56 +0000
committerAnders Nordby <anders@FreeBSD.org>2007-06-26 08:08:56 +0000
commit05399447ff6102854158310f4eab91a49c4515b3 (patch)
tree9fcdaf2f3515dbd7c529d95ddccb5b515b4c9601 /mail/cclient
parent8b80fc98bf6cf0bd78586a52e1841e6277a725c8 (diff)
Add OPTIONS list.
Add knob to choose mbx as default mailbox format, in cclient. PR: 88941, 88942 Submitted by: Mats Dufberg <mats@dufberg.se>
Notes
Notes: svn path=/head/; revision=194276
Diffstat (limited to 'mail/cclient')
-rw-r--r--mail/cclient/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/mail/cclient/Makefile b/mail/cclient/Makefile
index e57f4caf10cd..0deb781608f3 100644
--- a/mail/cclient/Makefile
+++ b/mail/cclient/Makefile
@@ -20,6 +20,11 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= anders@FreeBSD.org
COMMENT= Mark Crispin's C-client mail access routines
+OPTIONS= SSL "Compile with SSL support" on \
+ SSL_AND_PLAINTEXT "Allow plain text passwords and SSL" off \
+ IPV6 "Support IPv6" on \
+ MBX_DEFAULT "Use MBX as default mailbox format" off
+
USE_LDCONFIG= yes
ALL_TARGET= bsf
.if defined(WITHOUT_SSL)
@@ -53,6 +58,10 @@ post-patch:
@${REINPLACE_CMD} -e "s|^IP=4|IP=6|" ${WRKSRC}/Makefile \
${WRKSRC}/src/osdep/unix/Makefile
.endif
+.if defined(WITH_MBX_DEFAULT)
+ @${REINPLACE_CMD} -e "s|^CREATEPROTO=unixproto|CREATEPROTO=mbxproto|" \
+ ${WRKSRC}/src/osdep/unix/Makefile
+.endif
post-configure:
@${ECHO_MSG} ">> The c-client shared library will be named ${SHLIBNAME}"