aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail-notification
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-29 15:07:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-29 15:07:08 +0000
commitccd8b41cb80e11aa97e86dc22fb9488900bbdc3f (patch)
tree19b9911a535a69cbc6b769f3442909abba87a1b2 /mail/claws-mail-notification
parent0ca6315ec56597d2090db3e4eded87e6f7571f6b (diff)
Notes
Diffstat (limited to 'mail/claws-mail-notification')
-rw-r--r--mail/claws-mail-notification/Makefile29
-rw-r--r--mail/claws-mail-notification/distinfo3
-rw-r--r--mail/claws-mail-notification/files/patch-configure.ac15
-rw-r--r--mail/claws-mail-notification/pkg-descr1
4 files changed, 48 insertions, 0 deletions
diff --git a/mail/claws-mail-notification/Makefile b/mail/claws-mail-notification/Makefile
new file mode 100644
index 000000000000..3a91f0162109
--- /dev/null
+++ b/mail/claws-mail-notification/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: sylpheed-claws-notification
+# Date created: 7 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= notification
+PORTVERSION= 0.1
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+DISTNAME= notification_plugin-${PORTVERSION}
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= New/unread mail notification plugin for sylpheed-claws
+
+BUILD_DEPENDS= sylpheed-claws>=1.9.99:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=1.9.99:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+PLIST_FILES=lib/sylpheed-claws/plugins/notification_plugin.a \
+ lib/sylpheed-claws/plugins/notification_plugin.la \
+ lib/sylpheed-claws/plugins/notification_plugin.so
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-notification/distinfo b/mail/claws-mail-notification/distinfo
new file mode 100644
index 000000000000..681741d5d061
--- /dev/null
+++ b/mail/claws-mail-notification/distinfo
@@ -0,0 +1,3 @@
+MD5 (notification_plugin-0.1.tar.gz) = c444356be018d7a7674ff07d13a98e0b
+SHA256 (notification_plugin-0.1.tar.gz) = 52ea77411ee08aa1120695e5ead8325590178e4a3043adf10fa2117c8c8f3807
+SIZE (notification_plugin-0.1.tar.gz) = 325272
diff --git a/mail/claws-mail-notification/files/patch-configure.ac b/mail/claws-mail-notification/files/patch-configure.ac
new file mode 100644
index 000000000000..89b80858e256
--- /dev/null
+++ b/mail/claws-mail-notification/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Fri Apr 7 16:38:31 2006
++++ configure.ac Fri Apr 7 16:39:41 2006
+@@ -42,7 +42,11 @@
+
+ dnl Check for sylpheed-claws
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.15.94)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=${prefix}/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
diff --git a/mail/claws-mail-notification/pkg-descr b/mail/claws-mail-notification/pkg-descr
new file mode 100644
index 000000000000..e3ea9ccc3aa3
--- /dev/null
+++ b/mail/claws-mail-notification/pkg-descr
@@ -0,0 +1 @@
+This plugin provides various ways to notify the user of new and unread email.