aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail-pdf_viewer
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-06-30 15:35:25 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-06-30 15:35:25 +0000
commit844764d885c63340a00da02b7bd883e8b35fb20d (patch)
tree22daedc6be9e3e1ef5665c2a7062411e12278f73 /mail/claws-mail-pdf_viewer
parent5c84a954be8c3a11d8ae34e20c36320ce9d78eb0 (diff)
Notes
Diffstat (limited to 'mail/claws-mail-pdf_viewer')
-rw-r--r--mail/claws-mail-pdf_viewer/Makefile42
-rw-r--r--mail/claws-mail-pdf_viewer/distinfo2
-rw-r--r--mail/claws-mail-pdf_viewer/pkg-descr4
-rw-r--r--mail/claws-mail-pdf_viewer/pkg-plist19
4 files changed, 67 insertions, 0 deletions
diff --git a/mail/claws-mail-pdf_viewer/Makefile b/mail/claws-mail-pdf_viewer/Makefile
new file mode 100644
index 000000000000..a94beecc7ae5
--- /dev/null
+++ b/mail/claws-mail-pdf_viewer/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: claws-mail-pdf_viewer
+# Date created: 2007-03-02
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdf_viewer
+PORTVERSION= 0.9.2
+CATEGORIES= mail
+MASTER_SITES= http://www.claws-mail.org/downloads/plugins/
+PKGNAMEPREFIX= claws-mail-
+
+MAINTAINER= pawel@FreeBSD.org
+COMMENT= This claws-mail plugin enables viewing of PDF and PS files
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= poppler-glib:${PORTSDIR}/graphics/poppler-glib
+BUILD_DEPENDS= claws-mail>=3.8.1:${PORTSDIR}/mail/claws-mail
+RUN_DEPENDS= claws-mail>=3.8.1:${PORTSDIR}/mail/claws-mail
+
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_GHOSTSCRIPT=yes
+USE_AUTOTOOLS= autoconf
+MAKE_JOBS_SAFE= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-pdf_viewer/distinfo b/mail/claws-mail-pdf_viewer/distinfo
new file mode 100644
index 000000000000..c5fb497b60d3
--- /dev/null
+++ b/mail/claws-mail-pdf_viewer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pdf_viewer-0.9.2.tar.gz) = 59890f32fbb99a88feadce9799fbc556413635478f76b75ed6f0c856820af7d4
+SIZE (pdf_viewer-0.9.2.tar.gz) = 404561
diff --git a/mail/claws-mail-pdf_viewer/pkg-descr b/mail/claws-mail-pdf_viewer/pkg-descr
new file mode 100644
index 000000000000..49be145ab9d1
--- /dev/null
+++ b/mail/claws-mail-pdf_viewer/pkg-descr
@@ -0,0 +1,4 @@
+This plugin enables the viewing of PDF and PostScript
+attachments using the Poppler lib.
+
+WWW: http://www.claws-mail.org/plugin.php?plugin=pdf_viewer
diff --git a/mail/claws-mail-pdf_viewer/pkg-plist b/mail/claws-mail-pdf_viewer/pkg-plist
new file mode 100644
index 000000000000..fe45be768faf
--- /dev/null
+++ b/mail/claws-mail-pdf_viewer/pkg-plist
@@ -0,0 +1,19 @@
+lib/claws-mail/plugins/pdf_viewer.a
+lib/claws-mail/plugins/pdf_viewer.la
+lib/claws-mail/plugins/pdf_viewer.so
+%%NLS%%share/locale/ca/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/de/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/es/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/id_ID/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/it/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/pdf_viewer.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/pdf_viewer.mo