aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail-perl
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-29 14:35:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-29 14:35:40 +0000
commit6470d34864662296f97144110bfb5aa2b264b25c (patch)
treea0aac7268b99b5c523c961849cc957ce52907541 /mail/claws-mail-perl
parent693fe0e9eee133047f0208a4a19307e8d8f36cbb (diff)
downloadports-6470d34864662296f97144110bfb5aa2b264b25c.tar.gz
ports-6470d34864662296f97144110bfb5aa2b264b25c.zip
Notes
Diffstat (limited to 'mail/claws-mail-perl')
-rw-r--r--mail/claws-mail-perl/Makefile42
-rw-r--r--mail/claws-mail-perl/distinfo3
-rw-r--r--mail/claws-mail-perl/files/patch-configure.ac15
-rw-r--r--mail/claws-mail-perl/pkg-descr3
4 files changed, 63 insertions, 0 deletions
diff --git a/mail/claws-mail-perl/Makefile b/mail/claws-mail-perl/Makefile
new file mode 100644
index 000000000000..910e01bd2727
--- /dev/null
+++ b/mail/claws-mail-perl/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: sylpheed-claws-perl
+# Date created: 3 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= perl
+PORTVERSION= 0.9
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
+PKGNAMEPREFIX= sylpheed-claws-
+DISTNAME= perl_plugin-${PORTVERSION}
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Perl filtering plugin for sylpheed-claws
+
+BUILD_DEPENDS= sylpheed-claws>=2.1:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws>=2.1:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+USE_PERL5= yes
+
+PLIST_FILES= lib/sylpheed-claws/plugins/perl_plugin.a \
+ lib/sylpheed-claws/plugins/perl_plugin.la \
+ lib/sylpheed-claws/plugins/perl_plugin.so \
+ share/sylpheed-claws/matcherrc2perlfilter.pl
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires newer Perl, but you can use databases/p5-DBI-137 instead
+.endif
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/sylpheed-claws
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/matcherrc2perlfilter.pl \
+ ${PREFIX}/share/sylpheed-claws/
+
+.include <bsd.port.post.mk>
diff --git a/mail/claws-mail-perl/distinfo b/mail/claws-mail-perl/distinfo
new file mode 100644
index 000000000000..c5377c10fbbe
--- /dev/null
+++ b/mail/claws-mail-perl/distinfo
@@ -0,0 +1,3 @@
+MD5 (perl_plugin-0.9.tar.gz) = 70a74d7b5f231f0e1be4b992d37c77a3
+SHA256 (perl_plugin-0.9.tar.gz) = 945c354d9282384e9f93302cb5208a98bccb8ec931dd0f30ac5b51e9d2bc0317
+SIZE (perl_plugin-0.9.tar.gz) = 343395
diff --git a/mail/claws-mail-perl/files/patch-configure.ac b/mail/claws-mail-perl/files/patch-configure.ac
new file mode 100644
index 000000000000..2387d5d9f163
--- /dev/null
+++ b/mail/claws-mail-perl/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Sun Mar 19 08:03:29 2006
++++ configure.ac Sun Apr 9 14:35:56 2006
+@@ -41,7 +41,11 @@
+
+ dnl check for sylpheed-claws
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 2.0.0.81)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=${prefix}/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
diff --git a/mail/claws-mail-perl/pkg-descr b/mail/claws-mail-perl/pkg-descr
new file mode 100644
index 000000000000..d9b5d7dd2853
--- /dev/null
+++ b/mail/claws-mail-perl/pkg-descr
@@ -0,0 +1,3 @@
+This plugin is intended to extend the filtering possibilities of
+Sylpheed-Claws. It provides a Perl interface to Sylpheed-Claws' filtering
+mechanism, allowing the use of full Perl power in email filters.