aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail-plugins
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-06-11 17:49:58 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-06-11 17:49:58 +0000
commite04fbcb48e64d6c8d38c007e1eaf198ec6574a4f (patch)
tree17e48332edcc46d8e6fbb5b6f7e0cb7894eee983 /mail/claws-mail-plugins
parent033acbba3ca1ad4ebb5410cffebfaa24169c3da6 (diff)
downloadports-e04fbcb48e64d6c8d38c007e1eaf198ec6574a4f.tar.gz
ports-e04fbcb48e64d6c8d38c007e1eaf198ec6574a4f.zip
Notes
Diffstat (limited to 'mail/claws-mail-plugins')
-rw-r--r--mail/claws-mail-plugins/Makefile35
-rw-r--r--mail/claws-mail-plugins/pkg-descr6
2 files changed, 41 insertions, 0 deletions
diff --git a/mail/claws-mail-plugins/Makefile b/mail/claws-mail-plugins/Makefile
new file mode 100644
index 000000000000..82d6202b9b63
--- /dev/null
+++ b/mail/claws-mail-plugins/Makefile
@@ -0,0 +1,35 @@
+# Created by: Rozhuk Ivan <rozhuk.im@gmail.com>
+# $FreeBSD$
+
+PORTNAME= claws-mail-plugins
+PORTVERSION= 3.17
+CATEGORIES= mail news
+
+MAINTAINER= portmaster@BSDforge.com
+COMMENT= claws-mail plugins meta-port
+
+LICENSE= BSD2CLAUSE
+
+USES= metaport
+
+.include "../claws-mail/Makefile.claws.plugins"
+
+# pgpcore, pgpinline, pgpmime, smime
+CLAWS_PLUGINS+= pgp
+
+.for _addon in ${CLAWS_PLUGINS:O}
+. if exists(../claws-mail-${_addon})
+OPTIONS_DEFINE+= ${_addon:tu}
+${_addon:tu}_DESC!= ${MAKE} -C ../claws-mail-${_addon} -V COMMENT
+. endif
+.endfor
+
+.include <bsd.port.options.mk>
+
+.for _addon in ${CLAWS_PLUGINS}
+. if ${PORT_OPTIONS:M${_addon:tu}} != ""
+RUN_DEPENDS+= claws-mail-${_addon}>=0:mail/claws-mail-${_addon}
+. endif
+.endfor
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-plugins/pkg-descr b/mail/claws-mail-plugins/pkg-descr
new file mode 100644
index 000000000000..fcc7c4f72b43
--- /dev/null
+++ b/mail/claws-mail-plugins/pkg-descr
@@ -0,0 +1,6 @@
+This add-on provides joystick drivers and button mapping services
+for Kodi. It uses Kodi's Peripheral API.
+
+This port is for multimedia/kodi-devel only.
+
+WWW: https://github.com/xbmc/peripheral.joystick