aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail-python
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-21 20:52:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-21 20:52:49 +0000
commitd84105a14f891e95974d8894c1cd89cf47db05b8 (patch)
tree7c08acf0fdcad991b415803724fdcfc58b475c3a /mail/claws-mail-python
parent8adf4b7f7af7be625444897818950127c99a6dd9 (diff)
downloadports-d84105a14f891e95974d8894c1cd89cf47db05b8.tar.gz
ports-d84105a14f891e95974d8894c1cd89cf47db05b8.zip
Notes
Diffstat (limited to 'mail/claws-mail-python')
-rw-r--r--mail/claws-mail-python/Makefile14
-rw-r--r--mail/claws-mail-python/distinfo6
-rw-r--r--mail/claws-mail-python/pkg-plist11
3 files changed, 23 insertions, 8 deletions
diff --git a/mail/claws-mail-python/Makefile b/mail/claws-mail-python/Makefile
index 2c9a7d2cfa40..e59e537ba0fb 100644
--- a/mail/claws-mail-python/Makefile
+++ b/mail/claws-mail-python/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= python
-PORTVERSION= 0.2
+PORTVERSION= 0.3
CATEGORIES= mail
MASTER_SITES= http://www.claws-mail.org/downloads/plugins/
PKGNAMEPREFIX= claws-mail-
@@ -15,8 +15,8 @@ DISTNAME= python_plugin-${PORTVERSION}
MAINTAINER= miwi@FreeBSD.org
COMMENT= Python plugin for claws-mail
-BUILD_DEPENDS= claws-mail>=3.7.3:${PORTSDIR}/mail/claws-mail
-RUN_DEPENDS= claws-mail>=3.7.3:${PORTSDIR}/mail/claws-mail
+BUILD_DEPENDS= claws-mail>=3.7.4:${PORTSDIR}/mail/claws-mail
+RUN_DEPENDS= claws-mail>=3.7.4:${PORTSDIR}/mail/claws-mail
USE_GNOME= pygtk2
USE_GMAKE= yes
@@ -25,4 +25,12 @@ USE_AUTOTOOLS= autoconf:262
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
.include <bsd.port.mk>
diff --git a/mail/claws-mail-python/distinfo b/mail/claws-mail-python/distinfo
index a1a906f60112..11494c0aed88 100644
--- a/mail/claws-mail-python/distinfo
+++ b/mail/claws-mail-python/distinfo
@@ -1,3 +1,3 @@
-MD5 (python_plugin-0.2.tar.gz) = f61b47d43a0855ff4af29352288e8599
-SHA256 (python_plugin-0.2.tar.gz) = 869714d19dc61305102cf89583a67996da39cdcbe24d2ccccbaefe784f941c47
-SIZE (python_plugin-0.2.tar.gz) = 355469
+MD5 (python_plugin-0.3.tar.gz) = 4a05a745e9185ae77b432d95ed53df69
+SHA256 (python_plugin-0.3.tar.gz) = 39269926b36eb439b7b77deefd893c25f7cf571db32f56a22d500dbdac0dbf7b
+SIZE (python_plugin-0.3.tar.gz) = 364757
diff --git a/mail/claws-mail-python/pkg-plist b/mail/claws-mail-python/pkg-plist
index af470305629f..18ed55a8281d 100644
--- a/mail/claws-mail-python/pkg-plist
+++ b/mail/claws-mail-python/pkg-plist
@@ -1,5 +1,12 @@
lib/claws-mail/plugins/python_plugin.a
lib/claws-mail/plugins/python_plugin.la
lib/claws-mail/plugins/python_plugin.so
-@dirrmtry lib/claws-mail/plugins
-@dirrmtry lib/claws-mail
+%%NLS%%share/locale/ca/LC_MESSAGES/python_plugin.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/python_plugin.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/python_plugin.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/python_plugin.mo
+%%NLS%%share/locale/id/LC_MESSAGES/python_plugin.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/python_plugin.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/python_plugin.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/python_plugin.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/python_plugin.mo