aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-28 14:40:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-28 14:40:05 +0000
commitcf8e735ab435108386d6e3b7083fbf6e8abee88c (patch)
tree8c970d31cefce12e33891e603eccb616bdd5ad5f /mail/claws-mail/files
parentb1dbe19b0172cf6c3f416f92b8ac39a312faf201 (diff)
downloadports-cf8e735ab435108386d6e3b7083fbf6e8abee88c.tar.gz
ports-cf8e735ab435108386d6e3b7083fbf6e8abee88c.zip
Notes
Diffstat (limited to 'mail/claws-mail/files')
-rw-r--r--mail/claws-mail/files/patch-Makefile.in28
-rw-r--r--mail/claws-mail/files/patch-src_compose.c29
-rw-r--r--mail/claws-mail/files/patch-src_prefs_common.c31
3 files changed, 28 insertions, 60 deletions
diff --git a/mail/claws-mail/files/patch-Makefile.in b/mail/claws-mail/files/patch-Makefile.in
new file mode 100644
index 000000000000..06c9c39ab9b4
--- /dev/null
+++ b/mail/claws-mail/files/patch-Makefile.in
@@ -0,0 +1,28 @@
+--- Makefile.in.orig 2008-06-28 00:29:01.000000000 +0200
++++ Makefile.in 2008-06-28 00:29:43.000000000 +0200
+@@ -39,7 +39,7 @@
+ $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
+ $(srcdir)/claws-mail.pc.in $(srcdir)/config.h.in \
+ $(top_srcdir)/configure ABOUT-NLS AUTHORS COPYING ChangeLog \
+- INSTALL NEWS TODO
++ INSTALL NEWS TODO RELEASE_NOTES
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ am__aclocal_m4_deps = $(top_srcdir)/m4/aclocal-include.m4 \
+ $(top_srcdir)/m4/aspell.m4 $(top_srcdir)/m4/check-type.m4 \
+@@ -304,7 +304,6 @@
+ ChangeLog.gtk1 \
+ ChangeLog.pre2.0.0 \
+ ChangeLog.2.0.0-3.0.0 \
+- RELEASE_NOTES \
+ claws-mail-128x128.png \
+ claws-mail-64x64.png \
+ claws-mail.pc.in \
+@@ -325,8 +324,6 @@
+ clawsinclude_HEADERS = \
+ config.h
+
+-relnotesdir = $(docdir)
+-relnotes_DATA = RELEASE_NOTES
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
+
diff --git a/mail/claws-mail/files/patch-src_compose.c b/mail/claws-mail/files/patch-src_compose.c
deleted file mode 100644
index d3c6a9939677..000000000000
--- a/mail/claws-mail/files/patch-src_compose.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/compose.c 2008/04/30 06:46:01 1.382.2.446
-+++ src/compose.c 2008/05/04 15:58:59 1.382.2.447
-@@ -1591,7 +1591,7 @@
-
- } else {
- qmark = prefs_common.quotemark;
-- body_fmt = prefs_common.quotefmt;
-+ body_fmt = gettext(prefs_common.quotefmt);
- }
- }
-
-@@ -1746,7 +1746,7 @@
- g_free(msgfile);
- } else {
- const gchar *qmark = NULL;
-- const gchar *body_fmt = prefs_common.fw_quotefmt;
-+ const gchar *body_fmt = gettext(prefs_common.fw_quotefmt);
- MsgInfo *full_msginfo;
-
- full_msginfo = procmsg_msginfo_get_full_info(msginfo);
-@@ -1767,7 +1767,7 @@
-
- } else {
- qmark = prefs_common.fw_quotemark;
-- body_fmt = prefs_common.fw_quotefmt;
-+ body_fmt = gettext(prefs_common.fw_quotefmt);
- }
-
- /* empty quotemark is not allowed */
diff --git a/mail/claws-mail/files/patch-src_prefs_common.c b/mail/claws-mail/files/patch-src_prefs_common.c
deleted file mode 100644
index 4a5f21ffe602..000000000000
--- a/mail/claws-mail/files/patch-src_prefs_common.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/prefs_common.c 2008/04/24 05:39:34 1.204.2.167
-+++ src/prefs_common.c 2008/05/04 15:59:02 1.204.2.168
-@@ -226,7 +226,7 @@
- NULL, NULL, NULL},
- {"compose_subject_format", "",
- &prefs_common.compose_subject_format, P_STRING, NULL, NULL, NULL},
-- {"compose_body_format", NULL,
-+ {"compose_body_format", N_("Hello,\\n"),
- &prefs_common.compose_body_format, P_STRING, NULL, NULL, NULL},
-
- {"linewrap_length", "72", &prefs_common.linewrap_len, P_INT,
-@@ -293,12 +293,16 @@
- /* Quote */
- {"reply_quote_mark", "> ", &prefs_common.quotemark, P_STRING,
- NULL, NULL, NULL},
-- {"reply_quote_format", NULL,
-+ {"reply_quote_format", N_("On %d\\n%f wrote:\\n\\n%q"),
- &prefs_common.quotefmt, P_STRING, NULL, NULL, NULL},
-
- {"forward_quote_mark", "> ", &prefs_common.fw_quotemark, P_STRING,
- NULL, NULL, NULL},
-- {"forward_quote_format", NULL, &prefs_common.fw_quotefmt, P_STRING,
-+ {"forward_quote_format",
-+ N_("\\n\\nBegin forwarded message:\\n\\n"
-+ "?d{Date: %d\\n}?f{From: %f\\n}?t{To: %t\\n}?c{Cc: %c\\n}"
-+ "?n{Newsgroups: %n\\n}?s{Subject: %s\\n}\\n\\n%M"),
-+ &prefs_common.fw_quotefmt, P_STRING,
- NULL, NULL, NULL},
- {"quote_chars", ">", &prefs_common.quote_chars, P_STRING,
- NULL, NULL, NULL},
-