aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail/files
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-28 15:22:44 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-28 15:22:44 +0000
commit022e6ba4efec368587d7dba4d095c5184cc3faa6 (patch)
tree75eef9bf091fa698bbbe45377d675ec32ea49cb0 /mail/claws-mail/files
parentc065da2c3beff76b0555cbabf02034a5aa6b8ecb (diff)
Notes
Diffstat (limited to 'mail/claws-mail/files')
-rw-r--r--mail/claws-mail/files/patch-configure16
-rw-r--r--mail/claws-mail/files/patch-po-Makefile.in.in31
-rw-r--r--mail/claws-mail/files/patch-src-matcher_parser_lex.c13
-rw-r--r--mail/claws-mail/files/patch-src-quote_fmt_lex.c13
-rw-r--r--mail/claws-mail/files/patch-tools-launch_firebird17
-rw-r--r--mail/claws-mail/files/patch-tools-launch_phoenix17
6 files changed, 82 insertions, 25 deletions
diff --git a/mail/claws-mail/files/patch-configure b/mail/claws-mail/files/patch-configure
index 4ad7933e4f6f..d0ba8d95c09d 100644
--- a/mail/claws-mail/files/patch-configure
+++ b/mail/claws-mail/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Fri Jan 24 13:41:56 2003
-+++ configure Thu Jan 30 03:24:00 2003
-@@ -1502,7 +1502,7 @@
+--- configure.orig Sat Jul 12 15:59:49 2003
++++ configure Sun Jul 27 13:26:36 2003
+@@ -1509,7 +1509,7 @@
ac_configure="$SHELL $ac_aux_dir/configure" # This should be Cygnus configure.
@@ -8,17 +8,17 @@
+PACKAGE=sylpheed-claws
MAJOR_VERSION=0
- MINOR_VERSION=8
-@@ -2000,7 +2000,7 @@
+ MINOR_VERSION=9
+@@ -2022,7 +2022,7 @@
fi
--if test -d "$gnomedir"; then
+-if test -n "$gnomedatadir"; then
+if false; then
SYLPHEED_GNOME_TRUE=
SYLPHEED_GNOME_FALSE='#'
else
-@@ -8472,6 +8472,7 @@
+@@ -8506,6 +8506,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -26,7 +26,7 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -12094,9 +12095,9 @@
+@@ -12501,9 +12502,9 @@
localedir='${prefix}/${DATADIRNAME}/locale'
diff --git a/mail/claws-mail/files/patch-po-Makefile.in.in b/mail/claws-mail/files/patch-po-Makefile.in.in
new file mode 100644
index 000000000000..007d2a254062
--- /dev/null
+++ b/mail/claws-mail/files/patch-po-Makefile.in.in
@@ -0,0 +1,31 @@
+--- po/Makefile.in.in.orig Sat Jun 21 20:49:51 2003
++++ po/Makefile.in.in Sun Jul 27 14:05:49 2003
+@@ -8,7 +8,7 @@
+ # Please note that the actual code of GNU gettext is covered by the GNU
+ # General Public License and is *not* in the public domain.
+
+-PACKAGE = @PACKAGE@
++PACKAGE = sylpheed
+ VERSION = @VERSION@
+
+ SHELL = /bin/sh
+@@ -44,7 +44,7 @@
+ DUMMYPOFILES = @DUMMYPOFILES@
+ DISTFILES.common = Makefile.in.in remove-potcdate.sin \
+ $(DISTFILES.common.extra1) $(DISTFILES.common.extra2) $(DISTFILES.common.extra3)
+-DISTFILES = $(DISTFILES.common) Makevars POTFILES.in $(DOMAIN).pot stamp-po \
++DISTFILES = $(DISTFILES.common) Makevars POTFILES.in sylpheed.pot stamp-po \
+ $(POFILES) $(GMOFILES) \
+ $(DISTFILES.extra1) $(DISTFILES.extra2) $(DISTFILES.extra3)
+
+@@ -158,8 +158,8 @@
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+ $(mkinstalldirs) $(DESTDIR)$$dir; \
+ if test -r $$cat; then realcat=$$cat; else realcat=$(srcdir)/$$cat; fi; \
+- $(INSTALL_DATA) $$realcat $(DESTDIR)$$dir/$(DOMAIN).mo; \
+- echo "installing $$realcat as $(DESTDIR)$$dir/$(DOMAIN).mo"; \
++ $(INSTALL_DATA) $$realcat $(DESTDIR)$$dir/$(DOMAIN)-claws.mo; \
++ echo "installing $$realcat as $(DESTDIR)$$dir/$(DOMAIN)-claws.mo"; \
+ for lc in '' $(EXTRA_LOCALE_CATEGORIES); do \
+ if test -n "$$lc"; then \
+ if (cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc 2>/dev/null) | grep ' -> ' >/dev/null; then \
diff --git a/mail/claws-mail/files/patch-src-matcher_parser_lex.c b/mail/claws-mail/files/patch-src-matcher_parser_lex.c
new file mode 100644
index 000000000000..729a9bc884bc
--- /dev/null
+++ b/mail/claws-mail/files/patch-src-matcher_parser_lex.c
@@ -0,0 +1,13 @@
+--- src/matcher_parser_lex.c.orig Mon Jul 28 15:43:46 2003
++++ src/matcher_parser_lex.c Mon Jul 28 15:44:11 2003
+@@ -21,7 +21,10 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <stdlib.h>
++#include <osreldate.h>
++#if __FreeBSD_version >= 500028
+ #include <stdint.h> /* May break IA64 test-noansi-r */
++#endif
+
+ /* end standard C headers. */
+
diff --git a/mail/claws-mail/files/patch-src-quote_fmt_lex.c b/mail/claws-mail/files/patch-src-quote_fmt_lex.c
new file mode 100644
index 000000000000..bf915d2cd2a7
--- /dev/null
+++ b/mail/claws-mail/files/patch-src-quote_fmt_lex.c
@@ -0,0 +1,13 @@
+--- src/quote_fmt_lex.c.orig Mon Jul 28 15:40:54 2003
++++ src/quote_fmt_lex.c Mon Jul 28 15:42:07 2003
+@@ -21,7 +21,10 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <stdlib.h>
++#include <osreldate.h>
++#if __FreeBSD_version >= 500028
+ #include <stdint.h> /* May break IA64 test-noansi-r */
++#endif
+
+ /* end standard C headers. */
+
diff --git a/mail/claws-mail/files/patch-tools-launch_firebird b/mail/claws-mail/files/patch-tools-launch_firebird
new file mode 100644
index 000000000000..7ee768bce1d5
--- /dev/null
+++ b/mail/claws-mail/files/patch-tools-launch_firebird
@@ -0,0 +1,17 @@
+--- tools/launch_firebird.orig Sun Jul 27 13:28:33 2003
++++ tools/launch_firebird Sun Jul 27 13:30:11 2003
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # Copyright © 2002 Mohammed Sameer <Uniball@linux-egypt.org>
+ #
+@@ -45,7 +45,7 @@
+
+ STR=`$FIREBIRD -remote "ping()" 2>&1 | grep No`
+ #echo $STR
+-if [[ "$STR" == "No running window found." ]]; then
++if [ "$STR" == "No running window found." ]; then
+ firebird_new;
+ else
+ firebird_running;
diff --git a/mail/claws-mail/files/patch-tools-launch_phoenix b/mail/claws-mail/files/patch-tools-launch_phoenix
deleted file mode 100644
index be8bb323529d..000000000000
--- a/mail/claws-mail/files/patch-tools-launch_phoenix
+++ /dev/null
@@ -1,17 +0,0 @@
---- tools/launch_phoenix.orig Wed Jan 8 10:53:19 2003
-+++ tools/launch_phoenix Thu Jan 30 01:31:21 2003
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- # Copyright © 2002 Mohammed Sameer <Uniball@linux-egypt.org>
- #
-@@ -39,7 +39,7 @@
-
- STR=`phoenix -remote "ping()" 2>&1 | grep No`
- #echo $STR
--if [[ "$STR" == "No running window found." ]]; then
-+if [ "$STR" = "No running window found." ]; then
- phoenix_new;
- else
- phoenix_running;