aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-10-03 09:43:51 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-10-03 09:43:51 +0000
commit24e3decc6adaf432ac2b736b32b84b043f62ab40 (patch)
treea12386dcc12f6d5071dea9eadac002f4354d3e9c /mail/claws-mail
parente1a90e3019334b3a3cd33efccc686f77830dce78 (diff)
downloadports-24e3decc6adaf432ac2b736b32b84b043f62ab40.tar.gz
ports-24e3decc6adaf432ac2b736b32b84b043f62ab40.zip
Notes
Diffstat (limited to 'mail/claws-mail')
-rw-r--r--mail/claws-mail/Makefile23
-rw-r--r--mail/claws-mail/distinfo4
-rw-r--r--mail/claws-mail/files/patch-configure64
3 files changed, 68 insertions, 23 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 1b297d6f346a..5d097c73b994 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sylpheed-claws
-PORTVERSION= 0.9.12a
+PORTVERSION= 0.9.12b
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -19,8 +19,6 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
MAINTAINER= netchild@FreeBSD.org
COMMENT= A lightweight and very featureful GTK+ based e-mail and news client
-BROKEN= Does not compile
-
THEMEVERSION= 20040525
THEMEFILE= sylpheed-iconset-${THEMEVERSION}.tar.gz
@@ -48,6 +46,13 @@ CONFIGURE_ARGS= --enable-openssl --with-openssl-includes=${OPENSSLINC} \
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_SSL)
+SSLTEST!=test ${OPENSSLVER} \< 0.9.7 && ${ECHO_CMD} bad || ${TRUE}
+. if ${SSLTEST} == "bad"
+IGNORE=You need at least OpenSSL v0.9.7
+. endif
+.endif
+
.if ${HAVE_GNOME:Mgnomehier} != ""
PLIST_SUB+= GNOME=""
.else
@@ -77,15 +82,15 @@ CONFIGURE_ARGS+= --disable-imlib
USE_GNOME+= imlib
CONFIGURE_ARGS+= --disable-gdk-pixbuf
.endif
-.if defined(WITH_GPGME) || defined(WITH_ALL)
+#.if defined(WITH_GPGME) || defined(WITH_ALL)
PLIST_SUB+= GPGME=""
LIB_DEPENDS+= gpgme.9:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+= --enable-gpgme
-.else
-PLIST_SUB+= GPGME="@comment "
-CONFIGURE_ARGS+= --disable-gpgme
-.endif
+#.else
+#PLIST_SUB+= GPGME="@comment "
+#CONFIGURE_ARGS+= --disable-gpgme
+#.endif
.if defined(WITH_COMPFACE) || defined(WITH_ALL)
LIB_DEPENDS+= compface.1:${PORTSDIR}/mail/faces
CONFIGURE_ARGS+= --enable-compface
@@ -138,7 +143,7 @@ pre-everything::
@${ECHO} " WITH_ALL Enable all options below"
@${ECHO} ""
@${ECHO} " WITH_PIXBUF Enable GDK Pixbuf support"
- @${ECHO} " WITH_GPGME Enable GnuPG support using GPGME"
+ @${ECHO} " WITH_GPGME Enable GnuPG support using GPGME (temporary enabled unconditionally)"
@${ECHO} " WITH_COMPFACE Enable compface (X-Face) support"
@${ECHO} " WITH_JCONV Enable enhanced charset conversion"
@${ECHO} " WITH_ASPELL Enable spell-checking support"
diff --git a/mail/claws-mail/distinfo b/mail/claws-mail/distinfo
index 9a1f5050aef0..b1bf06d92484 100644
--- a/mail/claws-mail/distinfo
+++ b/mail/claws-mail/distinfo
@@ -1,4 +1,4 @@
-MD5 (sylpheed-claws-0.9.12a.tar.bz2) = 382caecd2b21cbcd9b8d07816025a87c
-SIZE (sylpheed-claws-0.9.12a.tar.bz2) = 3078119
+MD5 (sylpheed-claws-0.9.12b.tar.bz2) = f986e1226ce02c5791bd677a42765d41
+SIZE (sylpheed-claws-0.9.12b.tar.bz2) = 3086333
MD5 (sylpheed-iconset-20040525.tar.gz) = a2aa029cdee6cc22a0305774b70a5a70
SIZE (sylpheed-iconset-20040525.tar.gz) = 856996
diff --git a/mail/claws-mail/files/patch-configure b/mail/claws-mail/files/patch-configure
index f5fee614d635..4c5df65601b0 100644
--- a/mail/claws-mail/files/patch-configure
+++ b/mail/claws-mail/files/patch-configure
@@ -1,15 +1,7 @@
---- configure.bak Mon Jun 28 19:14:16 2004
-+++ configure Tue Jun 29 17:16:24 2004
-@@ -19691,6 +19691,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -23957,9 +23958,9 @@
- localedir='${prefix}/${DATADIRNAME}/locale'
+--- configure.orig Sun Sep 26 03:21:32 2004
++++ configure Sun Sep 26 03:33:17 2004
+@@ -24006,9 +24006,9 @@
+ localedir='${prefix}/share/locale'
-manualdir='${prefix}/${DATADIRNAME}/${PACKAGE}/manual'
@@ -20,3 +12,51 @@
if test "x${datadir}" = 'x${prefix}/share'; then
+@@ -27646,46 +27646,14 @@
+ echo "$as_me:$LINENO: checking for openssl >= 0.9.7" >&5
+ echo $ECHO_N "checking for openssl >= 0.9.7... $ECHO_C" >&6
+
+- if $PKG_CONFIG --exists "openssl >= 0.9.7" ; then
+- echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+- succeeded=yes
+-
+- echo "$as_me:$LINENO: checking OPENSSL_CFLAGS" >&5
+-echo $ECHO_N "checking OPENSSL_CFLAGS... $ECHO_C" >&6
+- OPENSSL_CFLAGS=`$PKG_CONFIG --cflags "openssl >= 0.9.7"`
+- echo "$as_me:$LINENO: result: $OPENSSL_CFLAGS" >&5
+-echo "${ECHO_T}$OPENSSL_CFLAGS" >&6
+-
+- echo "$as_me:$LINENO: checking OPENSSL_LIBS" >&5
+-echo $ECHO_N "checking OPENSSL_LIBS... $ECHO_C" >&6
+- OPENSSL_LIBS=`$PKG_CONFIG --libs "openssl >= 0.9.7"`
+- echo "$as_me:$LINENO: result: $OPENSSL_LIBS" >&5
+-echo "${ECHO_T}$OPENSSL_LIBS" >&6
+- else
+- OPENSSL_CFLAGS=""
+- OPENSSL_LIBS=""
+- ## If we have a custom action on failure, don't print errors, but
+- ## do set a variable so people can do so.
+- OPENSSL_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "openssl >= 0.9.7"`
+-
+- fi
+-
+-
+-
+ else
+ echo "*** Your version of pkg-config is too old. You need version $PKG_CONFIG_MIN_VERSION or newer."
+ echo "*** See http://www.freedesktop.org/software/pkgconfig"
+ fi
+ fi
+
+- if test $succeeded = yes; then
+- :
+- else
+- ac_cv_enable_openssl=no
+- fi
+-
+ if test x$ac_cv_enable_openssl = xyes; then
++OPENSSL_LIBS=-lssl
+
+ cat >>confdefs.h <<\_ACEOF
+ #define USE_OPENSSL 1