aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-12 22:11:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-12 22:11:50 +0000
commit3166ed7b052349083478d079602606287a176ab0 (patch)
treee815490624bea8650e92377368c6396bdd428ef3 /mail/claws-mail
parentd195f23eb7f13965b226c39ec0f9dd75972c0a0b (diff)
downloadports-3166ed7b052349083478d079602606287a176ab0.tar.gz
ports-3166ed7b052349083478d079602606287a176ab0.zip
Notes
Diffstat (limited to 'mail/claws-mail')
-rw-r--r--mail/claws-mail/Makefile61
-rw-r--r--mail/claws-mail/distinfo6
-rw-r--r--mail/claws-mail/files/patch-tools-README.sylprint18
-rw-r--r--mail/claws-mail/files/patch-tools-sylprint.pl14
-rw-r--r--mail/claws-mail/pkg-plist18
5 files changed, 36 insertions, 81 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 7899b39e5290..4ea1d1ca76d2 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= claws-mail
-PORTVERSION= 3.0.2
-PORTREVISION= 1
+PORTVERSION= 3.3.0
CATEGORIES= mail news ipv6
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= sylpheed-claws
DISTFILES= ${EXTRACT_ONLY} \
${THEMEFILE}
@@ -18,8 +17,6 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= netchild@FreeBSD.org
COMMENT= A lightweight and very featureful GTK+ based e-mail and news client
-FORBIDDEN= http://VuXML.FreeBSD.org/a59afa47-c930-11dc-810c-0016179b2dd5.html
-
LIB_DEPENDS= etpan:${PORTSDIR}/mail/libetpan \
cairo:${PORTSDIR}/graphics/cairo \
expat:${PORTSDIR}/textproc/expat2 \
@@ -41,7 +38,6 @@ USE_XORG= ice sm x11 xau xcursor xdmcp xext xfixes xi xinerama xrandr \
xrender
USE_GNOME= gnomehack pkgconfig gtk20 glib20 atk libartlgpl2 pango libxml2
GNU_CONFIGURE= yes
-USE_GCC= 3.3+
WANT_GNOME= yes
INSTALLS_ICONS= yes
@@ -57,35 +53,24 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-OPTIONS= ALL "Enable all options." off \
+OPTIONS= ALL "Enable all options except GNUTLS." off \
ASPELL "Enable spell checking support." on \
- CLAMAV "Enable virus-checking support." off \
+ BOGOFILTER "Enable bogofilter support." off \
COMPFACE "Enable X-Face support." on \
DEBUG "Enable debug support." off \
DILLO "Enable Dillo HTML viewer." off \
- GNOMEPRINT "Enable extended print support (GNOME)." off \
+ GNOMEPRINT "Enable extended print support (deprecated)." off \
+ GNUTLS "Enable gnuTLS support." off \
GPGME "Enable PGP/GnuPG support using GPGME." off \
IPV6 "Enable ipv6 support." on \
JPILOT "Enable JPilot support." off \
LDAP "Enable LDAP support." off \
SA_PLUG "Enable SpamAssassin support." off \
- SSL "Enable OpenSSL support." on \
STARTUP "Enable startup notification support." on \
THEMES "Install additional themes." on
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_SSL)
-# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-CONFIGURE_ARGS+= --enable-openssl --with-openssl-includes=${OPENSSLINC} \
- --with-openssl-libs=${OPENSSLLIB}
-CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
- OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
-.else
-CONFIGURE_ARGS+= --disable-openssl
-.endif
-
.if ${HAVE_GNOME:Mgnomeprint} != "" || defined(WITH_GNOMEPRINT)
PLIST_SUB+= GNOMEPRINT=""
USE_GNOME+= libgnomeprint libgnomeprintui libgnomecanvas
@@ -95,18 +80,15 @@ PLIST_SUB+= GNOMEPRINT="@comment "
CONFIGURE_ARGS+= --disable-gnomeprint
.endif
-.if exists(${LOCALBASE}/include/clamav.h)
-WITH_CLAMAV= yes
-.endif
-
-.if defined(WITH_CLAMAV) || defined(WITH_ALL)
-CONFIGURE_ARGS+= --enable-clamav-plugin
-PLIST_SUB+= CLAM_PLUG=""
-BUILD_DEPENDS= ${LOCALBASE}/sbin/clamd:${PORTSDIR}/security/clamav
+.if defined(WITH_BOGOFILTER) || defined(WITH_ALL)
+RUN_DEPENDS+= bogofilter:${PORTSDIR}/mail/bogofilter
+CONFIGURE_ARGS+= --enable-bogofilter-plugin
+PLIST_SUB+= BOGO_PLUG=""
.else
-CONFIGURE_ARGS+= --disable-clamav-plugin
-PLIST_SUB+= CLAM_PLUG="@comment "
+CONFIGURE_ARGS+= --disable-bogofilter-plugin
+PLIST_SUB+= BOGO_PLUG="@comment "
.endif
+
.if defined(WITH_COMPFACE) || defined(WITH_ALL)
LIB_DEPENDS+= compface.1:${PORTSDIR}/mail/faces
CONFIGURE_ARGS+= --enable-compface
@@ -140,6 +122,17 @@ PLIST_SUB+= SA_PLUG=""
CONFIGURE_ARGS+= --disable-spamassassin-plugin
PLIST_SUB+= SA_PLUG="@comment "
.endif
+.if defined(WITH_GNUTLS)
+CONFIGURE_ARGS+= --enable-gnutls --disable-openssl
+LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
+.else
+CONFIGURE_ARGS+= --disable-gnutls
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+CONFIGURE_ARGS+= --enable-openssl --with-openssl-includes=${OPENSSLINC} \
+ --with-openssl-libs=${OPENSSLLIB}
+CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
+.endif
.if defined(WITH_GPGME) || defined(WITH_ALL)
PLIST_SUB+= GPGME=""
CONFIGURE_ARGS+= --enable-pgpmime-plugin --enable-pgpcore-plugin \
@@ -191,8 +184,6 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e \
's|-lresolv||g; s|-lpisock\"|-liconv &|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
- ${WRKSRC}/tools/README.sylprint ${WRKSRC}/tools/sylprint.pl
@${REINPLACE_CMD} -e 's|/etc|${LOCALBASE}&|g ; s|/usr/share|${LOCALBASE}/share|g' \
${WRKSRC}/src/procmime.c
@${REINPLACE_CMD} -e "s|po intl src|po src| ; s:@CLAWS_GNOME2:#@CLAWS_GNOME2:g" ${WRKSRC}/Makefile.in
@@ -205,7 +196,7 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
-.for i in NEWS README RELEASE_NOTES TODO tools/README.sylprint
+.for i in NEWS README RELEASE_NOTES TODO
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
@${INSTALL_DATA} ${WRKSRC}/tools/README ${DOCSDIR}/README.tools
@@ -233,8 +224,6 @@ post-install:
@${FIND} ${DATADIR}/themes -type d -print0 | ${XARGS} -0 ${CHMOD} 755
@${FIND} ${DATADIR}/themes -type f -print0 | ${XARGS} -0 ${CHMOD} 644
.endif
- @${INSTALL_SCRIPT} ${WRKSRC}/tools/sylprint.pl ${PREFIX}/bin
- @${INSTALL_DATA} ${WRKSRC}/tools/sylprint.rc ${PREFIX}/etc/sylprint.rc.example
@${MKDIR} ${PREFIX}/share/pixmaps
@${INSTALL_DATA} ${WRKSRC}/claws-mail*.png ${PREFIX}/share/pixmaps/
diff --git a/mail/claws-mail/distinfo b/mail/claws-mail/distinfo
index 30ffd6a631ff..f8f69903d544 100644
--- a/mail/claws-mail/distinfo
+++ b/mail/claws-mail/distinfo
@@ -1,6 +1,6 @@
-MD5 (claws-mail-3.0.2.tar.bz2) = 97a0c627f91b51b6851b9a1ed9ee7afe
-SHA256 (claws-mail-3.0.2.tar.bz2) = d04db59df8b013651721312ed167df95d47c88d55eac0eb5b7950d6958f3636e
-SIZE (claws-mail-3.0.2.tar.bz2) = 5664767
+MD5 (claws-mail-3.3.0.tar.bz2) = 646fea69bfa82be5f507e72e055957b6
+SHA256 (claws-mail-3.3.0.tar.bz2) = 16d4a9ef3a2c62f879c688b7949f4d0b834b26c9905d16fee7d76432df29d8fd
+SIZE (claws-mail-3.3.0.tar.bz2) = 5933626
MD5 (claws-mail-themes-20070116.tar.gz) = 4dba190413eabbf053b9ddc97110f8e5
SHA256 (claws-mail-themes-20070116.tar.gz) = 73b600f9ed774f46a11e20b67e6fb8bb8553a20d436ae9a7c2eb3fe717977167
SIZE (claws-mail-themes-20070116.tar.gz) = 1827645
diff --git a/mail/claws-mail/files/patch-tools-README.sylprint b/mail/claws-mail/files/patch-tools-README.sylprint
deleted file mode 100644
index 0a1b8abb68ab..000000000000
--- a/mail/claws-mail/files/patch-tools-README.sylprint
+++ /dev/null
@@ -1,18 +0,0 @@
---- tools/README.sylprint.orig Tue May 8 07:59:23 2007
-+++ tools/README.sylprint Tue May 29 00:43:03 2007
-@@ -144,11 +144,12 @@
- sylprint.pl
- The script itself.
-
-- sylprint.rc
-+ %%PREFIX%%/etc/sylprint.rc
-+ ~/.sylpheed/sylprint.rc
- Stores user default preferred configuration for the
- script. Settings in this file may be overriden by
-- command line options. Must be stored in the same
-- directory of the script and/or in the ~/.claws-mail
-+ command line options. Must be stored in the local
-+ configuration directory and/or in the ~/.claws-mail
- one (Claws Mail user's configuration directory).
-
- /tmp/sylprint.username.number
diff --git a/mail/claws-mail/files/patch-tools-sylprint.pl b/mail/claws-mail/files/patch-tools-sylprint.pl
deleted file mode 100644
index fce5e4ec5bbe..000000000000
--- a/mail/claws-mail/files/patch-tools-sylprint.pl
+++ /dev/null
@@ -1,14 +0,0 @@
---- tools/sylprint.pl.orig Tue Jan 8 20:34:37 2002
-+++ tools/sylprint.pl Tue Jan 15 00:13:15 2002
-@@ -36,10 +36,7 @@
- # get user config
- if (defined($ARGV[1]) && $ARGV[1] eq '-r') { $a++; }
- else {
-- @spp = split('/',$0);
-- $spp[$#spp] = '';
-- $spp = join('/',@spp);
-- $rcf="$spp$rc";
-+ $rcf="%%PREFIX%%/etc/$rc";
- if (-x $rcf) { do $rcf; }
- $rcf="$ENV{'HOME'}/.sylpheed/$rc";
- if (-x $rcf) { do $rcf; }
diff --git a/mail/claws-mail/pkg-plist b/mail/claws-mail/pkg-plist
index 0d31ed1345d7..cdecb21c72a3 100644
--- a/mail/claws-mail/pkg-plist
+++ b/mail/claws-mail/pkg-plist
@@ -1,15 +1,15 @@
bin/claws-mail
bin/sylpheed-claws
-bin/sylprint.pl
-etc/sylprint.rc.example
include/claws-mail/account.h
include/claws-mail/action.h
include/claws-mail/adbookbase.h
include/claws-mail/addr_compl.h
include/claws-mail/addrbook.h
include/claws-mail/addrcache.h
+include/claws-mail/addrcustomattr.h
include/claws-mail/addrclip.h
include/claws-mail/addrdefs.h
+include/claws-mail/addrduplicates.h
include/claws-mail/addressadd.h
include/claws-mail/addressbook.h
include/claws-mail/addressbook_foldersel.h
@@ -23,13 +23,13 @@ include/claws-mail/addrselect.h
include/claws-mail/alertpanel.h
include/claws-mail/browseldap.h
include/claws-mail/codeconv.h
+include/claws-mail/printing.h
include/claws-mail/common/base64.h
include/claws-mail/common/defs.h
include/claws-mail/common/hooks.h
include/claws-mail/common/log.h
include/claws-mail/common/md5.h
include/claws-mail/common/mgutils.h
-include/claws-mail/common/nntp.h
include/claws-mail/common/passcrypt.h
include/claws-mail/common/plugin.h
include/claws-mail/common/prefs.h
@@ -71,6 +71,7 @@ include/claws-mail/etpan/etpan-errors.h
include/claws-mail/etpan/etpan-thread-manager-types.h
include/claws-mail/etpan/etpan-thread-manager.h
include/claws-mail/etpan/imap-thread.h
+include/claws-mail/etpan/nntp-thread.h
include/claws-mail/exphtmldlg.h
include/claws-mail/expldifdlg.h
include/claws-mail/export.h
@@ -211,12 +212,9 @@ include/claws-mail/unmime.h
include/claws-mail/uri_opener.h
include/claws-mail/vcard.h
include/claws-mail/wizard.h
-lib/claws-mail/plugins/bogofilter.a
-lib/claws-mail/plugins/bogofilter.la
-lib/claws-mail/plugins/bogofilter.so
-%%CLAM_PLUG%%lib/claws-mail/plugins/clamav_plugin.a
-%%CLAM_PLUG%%lib/claws-mail/plugins/clamav_plugin.la
-%%CLAM_PLUG%%lib/claws-mail/plugins/clamav_plugin.so
+%%BOGO_PLUG%%lib/claws-mail/plugins/bogofilter.a
+%%BOGO_PLUG%%lib/claws-mail/plugins/bogofilter.la
+%%BOGO_PLUG%%lib/claws-mail/plugins/bogofilter.so
%%DILLO%%lib/claws-mail/plugins/dillo_viewer.a
%%DILLO%%lib/claws-mail/plugins/dillo_viewer.la
%%DILLO%%lib/claws-mail/plugins/dillo_viewer.so
@@ -241,7 +239,6 @@ libdata/pkgconfig/claws-mail.pc
share/applications/claws-mail.desktop
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.sylprint
%%PORTDOCS%%%%DOCSDIR%%/README.tools
%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
%%PORTDOCS%%%%DOCSDIR%%/TODO
@@ -271,6 +268,7 @@ share/locale/en_GB/LC_MESSAGES/claws-mail.mo
share/locale/es/LC_MESSAGES/claws-mail.mo
share/locale/fi/LC_MESSAGES/claws-mail.mo
share/locale/fr/LC_MESSAGES/claws-mail.mo
+share/locale/he/LC_MESSAGES/claws-mail.mo
share/locale/hr/LC_MESSAGES/claws-mail.mo
share/locale/hu/LC_MESSAGES/claws-mail.mo
share/locale/it/LC_MESSAGES/claws-mail.mo