aboutsummaryrefslogtreecommitdiff
path: root/mail/cone/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-08-15 02:49:45 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-08-15 02:49:45 +0000
commit69ce2b3499823eee6c2bbb2c0f8411e85a6dab93 (patch)
tree1f278028ded51bdb3a0392bd47604814547eed55 /mail/cone/Makefile
parent982aa704c10b267d6ec53fb545edd2dde57b8324 (diff)
Notes
Diffstat (limited to 'mail/cone/Makefile')
-rw-r--r--mail/cone/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/mail/cone/Makefile b/mail/cone/Makefile
new file mode 100644
index 000000000000..ddf01a1252ed
--- /dev/null
+++ b/mail/cone/Makefile
@@ -0,0 +1,52 @@
+# ports collection Makefile for: cone
+# Whom: Matthias Andree <matthias.andree@gmx.de>
+# Date created: 2003-06-19
+#
+# $FreeBSD$
+#
+
+PORTNAME= cone
+PORTVERSION= 0.52
+CATEGORIES= mail
+# This is for beta versions, leave it in please:
+#MASTER_SITES= http://www.courier-mta.org/beta/${PORTNAME}/
+# This is for release versions, leave it in please:
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= courier
+
+MAINTAINER= matthias.andree@gmx.de
+COMMENT= "Console based mail client with POP3/IMAP/SMAP support"
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ aspell.15:${PORTSDIR}/textproc/aspell
+BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
+ ${LOCALBASE}/lib/libncurses.so.5.3:${PORTSDIR}/devel/ncurses
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
+ ${LOCALBASE}/lib/libncurses.so.5.3:${PORTSDIR}/devel/ncurses
+
+USE_BZIP2= yes
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= -C --without-db --prefix=${PREFIX} --exec-prefix=${PREFIX}
+
+CONFIGURE_ENV= REHASH=${SCRIPTDIR}/c_rehash LDFLAGS=-L${LOCALBASE}/lib \
+ CPPFLAGS=-I${LOCALBASE}/include
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+MAN1= cone.1 leaf.1 mailtool.1
+
+do-install:
+ cd ${WRKSRC} && make install-strip
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sysconftool ${PREFIX}/sbin/cone-sysconftool
+ PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PORTNAME} POST-INSTALL
+ ${RM} -f ${PREFIX}/share/cone/rootcerts/.0
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "does not build on FreeBSD versions before FreeBSD 5"
+.endif
+
+.include <bsd.port.post.mk>