aboutsummaryrefslogtreecommitdiff
path: root/mail/courier-imap/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-23 02:19:02 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-23 02:19:02 +0000
commit2a8fb99db4e98016e475aaf65ef0e6c43d7407a3 (patch)
tree7387196f77943048eba0c2b0e857984f08f2b4fc /mail/courier-imap/Makefile
parent7ccf343d26abd96367d7bf24f1bdf73032e33344 (diff)
downloadports-2a8fb99db4e98016e475aaf65ef0e6c43d7407a3.tar.gz
ports-2a8fb99db4e98016e475aaf65ef0e6c43d7407a3.zip
Notes
Diffstat (limited to 'mail/courier-imap/Makefile')
-rw-r--r--mail/courier-imap/Makefile29
1 files changed, 12 insertions, 17 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index 47b631697d6c..8980628be26b 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: courierimap
-# Date created: 19 Feb 2000
-# Whom: Neil Blakey-Milner
-#
+# Created by: Neil Blakey-Milner
# $FreeBSD$
-#
PORTNAME= courier-imap
PORTVERSION= 4.13
@@ -36,10 +32,9 @@ MAKE_ENV:= ${CONFIGURE_ENV}
# WITH_SYSLOG_FACILITY: The syslogfacility to use
#
-OPTIONS= FAM "Build in fam support for IDLE command" off \
- TRASHQUOTA "Include deleted mails in the quota" off \
- GDBM "Use gdbm db instead of system bdb" off \
- IPV6 "Build with IPv6 support" on \
+OPTIONS_DEFINE= FAM TRASHQUOTA GDBM IPV6
+FAM_DESC= Fam support for IDLE command
+TRASHQUOTA_DESC= Include deleted mails in the quota
.if exists(${.CURDIR}/../../security/courier-authlib/Makefile.opt)
.include "${.CURDIR}/../../security/courier-authlib/Makefile.opt"
@@ -67,12 +62,12 @@ CONFIGURE_ARGS= --sysconfdir=${CONFDIR} \
.include "${.CURDIR}/../../security/courier-authlib/Makefile.dep"
.endif
-.if defined(WITH_SYSLOG_FACILITY)
+.if ${PORT_OPTIONS:MSYSLOG_FACILITY}
CONFIGURE_ARGS+=--with-syslog=${WITH_SYSLOG_FACILITY}
.endif
-.if defined(WITH_AUTH_USERDB)
-.if defined(WITH_GDBM)
+.if ${PORT_OPTIONS:MAUTH_USERDB}
+.if ${PORT_OPTIONS:MGDBM}
CONFIGURE_ARGS+=--with-db=gdbm --with-userdb=${USERDB}
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
.else
@@ -80,15 +75,15 @@ CONFIGURE_ARGS+=--with-db=db --with-userdb=${USERDB}
.endif
.endif
-.if defined(WITHOUT_IPV6)
+.if ! ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+=--without-ipv6
.endif
-.if defined(WITH_TRASHQUOTA)
+.if ${PORT_OPTIONS:MTRASHQUOTA}
CONFIGURE_ARGS+=--with-trashquota
.endif
-.if defined(WITH_FAM)
+.if ${PORT_OPTIONS:MFAM}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_FAM= yes
@@ -106,7 +101,7 @@ EXTRA_DOCS= AUTHORS INSTALL NEWS imap/ChangeLog imap/README \
maildir/README.sharedfolders.txt tcpd/README.couriertls \
post-patch:
-.if !defined(WITH_FAM)
+.if ! ${PORT_OPTIONS:MFAM}
@${REINPLACE_CMD} -e 's|$$LIBFAM||g; s|HAVE_FAM|DO_NOT_HAVE_FAM|g' \
${WRKSRC}/maildir/configure
.endif
@@ -124,7 +119,7 @@ post-install:
.for i in imapd pop3d
${INSTALL_DATA} ${WRKSRC}/imap/${i}.cnf ${CONFDIR}/${i}.cnf.dist
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for a in ${EXTRA_DOCS}
${INSTALL_DATA} ${WRKSRC}/${a} ${DOCSDIR}