aboutsummaryrefslogtreecommitdiff
path: root/mail/courier-imap
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-06-19 13:31:46 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-06-19 13:31:46 +0000
commitbe3f1c05932a44f04a6f5f3753e8267a7631fa89 (patch)
tree71f5792231bef3d37fa49c1b9fd103fae70fb0c8 /mail/courier-imap
parent19328be00ee9b82eb65232fb2e9feb4bb7c78f3f (diff)
downloadports-be3f1c05932a44f04a6f5f3753e8267a7631fa89.tar.gz
ports-be3f1c05932a44f04a6f5f3753e8267a7631fa89.zip
Notes
Diffstat (limited to 'mail/courier-imap')
-rw-r--r--mail/courier-imap/Makefile2
-rw-r--r--mail/courier-imap/files/patch-maildir::maildirquota.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index 1b15db9de891..2d3cf51b01f6 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= courier-imap
PORTVERSION= 3.0.5
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/mail/courier-imap/files/patch-maildir::maildirquota.c b/mail/courier-imap/files/patch-maildir::maildirquota.c
new file mode 100644
index 000000000000..a643011a8809
--- /dev/null
+++ b/mail/courier-imap/files/patch-maildir::maildirquota.c
@@ -0,0 +1,11 @@
+--- maildir/maildirquota.c.orig Fri Jun 18 23:27:53 2004
++++ maildir/maildirquota.c Fri Jun 18 23:45:01 2004
+@@ -748,7 +748,7 @@
+ char *p;
+ DIR *dirp;
+ struct dirent *de;
+-off_t s;
++unsigned long s;
+
+ if (stat(dir, &stat_buf)) return (0); /* Ignore */
+ if (stat_buf.st_mtime > *dirstamp) *dirstamp=stat_buf.st_mtime;