aboutsummaryrefslogtreecommitdiff
path: root/mail/courier
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-03-13 00:51:31 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-03-13 00:51:31 +0000
commit8923d883a0eea5d132ce87a8b9abdf9a12593f05 (patch)
tree5a62929edc5f1ed73f49bae06870b9e525573a36 /mail/courier
parentdbd9718352c33fcc12e83837a5a7dece29c318bf (diff)
downloadports-8923d883a0eea5d132ce87a8b9abdf9a12593f05.tar.gz
ports-8923d883a0eea5d132ce87a8b9abdf9a12593f05.zip
Notes
Diffstat (limited to 'mail/courier')
-rw-r--r--mail/courier/Makefile10
-rw-r--r--mail/courier/distinfo6
-rw-r--r--mail/courier/files/courier.sh.in13
-rw-r--r--mail/courier/files/extra-patch-webmail__images__sqwebmail.css2
-rw-r--r--mail/courier/files/patch-courier__Makefile.in10
-rw-r--r--mail/courier/files/patch-courier__configure65
-rw-r--r--mail/courier/files/patch-courier__configure.in13
-rw-r--r--mail/courier/files/patch-courier__module.esmtp__mkesmtpdcert.in11
-rw-r--r--mail/courier/files/patch-courier__submit2.C11
-rw-r--r--mail/courier/files/patch-courier__webmlmd.rc.in61
-rw-r--r--mail/courier/files/patch-courier__webmlmrc.dist.in11
-rw-r--r--mail/courier/files/patch-imap__mkimapdcert.in11
-rw-r--r--mail/courier/files/patch-imap__mkpop3dcert.in11
-rw-r--r--mail/courier/files/patch-imap__outbox.c15
-rw-r--r--mail/courier/files/patch-imap__outbox.h11
-rw-r--r--mail/courier/files/pkg-install.in24
-rw-r--r--mail/courier/files/pkg-message.in10
17 files changed, 237 insertions, 58 deletions
diff --git a/mail/courier/Makefile b/mail/courier/Makefile
index 16909c9d4685..e8de94b21a1a 100644
--- a/mail/courier/Makefile
+++ b/mail/courier/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= courier
-PORTVERSION= 0.62.0
+PORTVERSION= 0.63.0
CATEGORIES= mail ipv6
MASTER_SITES= SF
@@ -315,16 +315,16 @@ CONFIGURE_ARGS+=--without-ipv6
.endif
.if defined(WITH_MAILDROPFLAGS) || !defined(WITHOUT_MAILDROPFLAGS)
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-maildrop__maildir.C
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-maildrop__maildir.C
.endif
.if defined(WITH_WEBMAILXFACE) || !defined(WITHOUT_WEBMAILXFACE)
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-webmail__msg2html.c
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-webmail__msg2html.c
.endif
.if defined(WITH_WEBMAILFLAGS) || !defined(WITHOUT_WEBMAILFLAGS)
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-webmail__folder.c ${FILESDIR}/extra-patch-webmail__maildir.c
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-webmail__maildir.h ${FILESDIR}/extra-patch-webmail__images__sqwebmail.css
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-webmail__folder.c ${FILESDIR}/extra-patch-webmail__maildir.c
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-webmail__maildir.h ${FILESDIR}/extra-patch-webmail__images__sqwebmail.css
.endif
.if defined(WITH_WEBMAILRSENT) || !defined(WITHOUT_WEBMAILRSENT)
diff --git a/mail/courier/distinfo b/mail/courier/distinfo
index 775b48a8a834..4c6aed3b3b32 100644
--- a/mail/courier/distinfo
+++ b/mail/courier/distinfo
@@ -1,3 +1,3 @@
-MD5 (courier-0.62.0.tar.bz2) = 2b7acca41c778c241ed08f3ea633d8ea
-SHA256 (courier-0.62.0.tar.bz2) = af826d6759be544127bcee95e4812649defdb4d4ff55193955b2c5d911d8e755
-SIZE (courier-0.62.0.tar.bz2) = 7314085
+MD5 (courier-0.63.0.tar.bz2) = a4d12aa593a52aee90373fad9eb9ff17
+SHA256 (courier-0.63.0.tar.bz2) = 3a52363605f75f4156105aefa6bd375626f742033fbf09b5592179f274322044
+SIZE (courier-0.63.0.tar.bz2) = 7133009
diff --git a/mail/courier/files/courier.sh.in b/mail/courier/files/courier.sh.in
index a2ec2e2f7fa4..9fe3af90cef4 100644
--- a/mail/courier/files/courier.sh.in
+++ b/mail/courier/files/courier.sh.in
@@ -246,19 +246,18 @@ courier_start()
;;
esac
fi
- echo "."
LISTS=""
if [ -f ${sysconfdir}/webmlmrc ]; then
. ${sysconfdir}/webmlmrc
- if [ -n "$LISTS" ];then
- if [ -x ${bindir}/webmlmd \
- -a -x ${bindir}/webmlmd.rc ]; then
- echo -n " webmlmd"
- ${bindir}/webmlmd.rc start ${sysconfdir}/webmlmrc
- fi
+ if [ -n "$LISTS" \
+ -a -x ${bindir}/webmlmd \
+ -a -x ${bindir}/webmlmd.rc ]; then
+ echo -n " webmlmd"
+ ${bindir}/webmlmd.rc start ${sysconfdir}/webmlmrc
fi
fi
+ echo "."
}
courier_stop()
diff --git a/mail/courier/files/extra-patch-webmail__images__sqwebmail.css b/mail/courier/files/extra-patch-webmail__images__sqwebmail.css
index 62bb52989227..adedc27b6ec5 100644
--- a/mail/courier/files/extra-patch-webmail__images__sqwebmail.css
+++ b/mail/courier/files/extra-patch-webmail__images__sqwebmail.css
@@ -15,7 +15,7 @@
.message-number { }
-.message-status { }
-+.message-flag { padding: 0}
++.message-flag { padding: 0 }
+.message-select { padding: 0 }
+.message-status { padding: 0 }
.message-date { }
diff --git a/mail/courier/files/patch-courier__Makefile.in b/mail/courier/files/patch-courier__Makefile.in
new file mode 100644
index 000000000000..392829115f58
--- /dev/null
+++ b/mail/courier/files/patch-courier__Makefile.in
@@ -0,0 +1,10 @@
+--- courier/Makefile.in.orig 2010-02-15 18:58:00.000000000 +0100
++++ courier/Makefile.in 2010-02-15 19:11:12.000000000 +0100
+@@ -441,6 +441,7 @@
+ mkdir_p = @mkdir_p@
+ oldincludedir = @oldincludedir@
+ pdfdir = @pdfdir@
++piddir = @piddir@
+ prefix = @prefix@
+ program_transform_name = @program_transform_name@
+ psdir = @psdir@
diff --git a/mail/courier/files/patch-courier__configure b/mail/courier/files/patch-courier__configure
index d56e7d14f2f7..13214a7575eb 100644
--- a/mail/courier/files/patch-courier__configure
+++ b/mail/courier/files/patch-courier__configure
@@ -1,6 +1,63 @@
---- courier/configure.orig Sun Jul 3 00:06:22 2005
-+++ courier/configure Sun Jul 3 00:06:22 2005
-@@ -22109,9 +22109,9 @@
+--- courier/configure.orig 2009-09-05 13:59:59.000000000 +0200
++++ courier/configure 2010-02-15 20:05:20.000000000 +0100
+@@ -819,6 +819,7 @@
+ dirlist
+ transport
+ MODE
++piddir
+ COPYRIGHT
+ testmode
+ COURIERAUTHCONFIG
+@@ -954,6 +955,7 @@
+ enable_libtool_lock
+ with_softlinkdir
+ with_testmode
++with_piddir
+ with_transport
+ with_db
+ with_courierlogger
+@@ -1629,6 +1631,7 @@
+ --with-softlinks=dir:link,dir:link... specify soft links for
+ installation subdirectories.
+ -- This space intentionally left blank --
++ --with-piddir Directory where webmlm.pid is created
+ --with-transport='local esmtp ...'
+ Specify list of modules to install
+
+@@ -2553,7 +2556,7 @@
+ fi
+
+ fi
+-INSTALL_STRIP_PROGRAM="\$(install_sh) -c -s"
++INSTALL_STRIP_PROGRAM="install -s -o root -g wheel -m 555 -s"
+
+ { $as_echo "$as_me:$LINENO: checking for a thread-safe mkdir -p" >&5
+ $as_echo_n "checking for a thread-safe mkdir -p... " >&6; }
+@@ -15882,6 +15885,14 @@
+ esac
+
+
++# Check whether --with-piddir was given.
++if test "${with_piddir+set}" = set; then
++ withval=$with_piddir; piddir="$withval"
++ else
++ piddir=$localstatedir/run
++fi
++
++
+ version=`cat ../version`
+
+ COPYRIGHT="Courier $version Copyright 1999-2008 Double Precision, Inc."
+@@ -17008,7 +17019,7 @@
+
+ # Check whether --with-ldapaliasd was given.
+ if test "${with_ldapaliasd+set}" = set; then
+- withval=$with_ldapaliasd; ldapaliasd="$withval"; ldapaliasd="yes"
++ withval=$with_ldapaliasd; ldapaliasd="$withval"
+ fi
+
+
+@@ -18397,9 +18408,9 @@
if test "$testmode" = "0"
then
@@ -12,4 +69,4 @@
+ INSTALL_DATA='${BSD_INSTALL_DATA}'
fi
- ac_ext=cc
+ ac_ext=cpp
diff --git a/mail/courier/files/patch-courier__configure.in b/mail/courier/files/patch-courier__configure.in
new file mode 100644
index 000000000000..972abe3b7a7b
--- /dev/null
+++ b/mail/courier/files/patch-courier__configure.in
@@ -0,0 +1,13 @@
+--- courier/configure.in.orig 2009-09-05 13:59:26.000000000 +0200
++++ courier/configure.in 2010-02-15 19:44:35.000000000 +0100
+@@ -77,6 +77,10 @@
+ esac
+ AC_SUBST(testmode)
+
++AC_ARG_WITH(piddir, [ --with-piddir Directory where imapd.pid is created ], piddir="$withval", piddir=$localstatedir/run)
++
++AC_SUBST(piddir)
++
+ version=`cat ../version`
+
+ COPYRIGHT="Courier $version Copyright 1999-2008 Double Precision, Inc."
diff --git a/mail/courier/files/patch-courier__module.esmtp__mkesmtpdcert.in b/mail/courier/files/patch-courier__module.esmtp__mkesmtpdcert.in
new file mode 100644
index 000000000000..aa6d563837a5
--- /dev/null
+++ b/mail/courier/files/patch-courier__module.esmtp__mkesmtpdcert.in
@@ -0,0 +1,11 @@
+--- courier/module.esmtp/mkesmtpdcert.in.orig 2010-02-15 21:37:57.000000000 +0100
++++ courier/module.esmtp/mkesmtpdcert.in 2010-02-15 21:37:16.000000000 +0100
+@@ -36,7 +36,7 @@
+ then
+ cp /dev/null @mydatadir@/esmtpd.pem
+ chmod 600 @mydatadir@/esmtpd.pem
+- chown @mailuser@ @mydatadir@/esmtpd.pem
++ /usr/sbin/chown @mailuser@ @mydatadir@/esmtpd.pem
+ dd if=@RANDOMV@ of=@mydatadir@/esmtpd.rand count=1 2>/dev/null
+ @OPENSSL@ req -new -x509 -days 365 -nodes \
+ -config @sysconfdir@/esmtpd.cnf -out @mydatadir@/esmtpd.pem -keyout @mydatadir@/esmtpd.pem || cleanup
diff --git a/mail/courier/files/patch-courier__submit2.C b/mail/courier/files/patch-courier__submit2.C
new file mode 100644
index 000000000000..a85379056c20
--- /dev/null
+++ b/mail/courier/files/patch-courier__submit2.C
@@ -0,0 +1,11 @@
+--- courier/submit2.C.orig 2008-01-29 13:06:47.000000000 +0100
++++ courier/submit2.C 2009-10-03 22:34:47.000000000 +0200
+@@ -860,7 +860,7 @@
+ if (sizelimit && bytecount > sizelimit)
+ {
+ std::cout << "523 Message length (" <<
+- sizelimit << " bytes) exceeds administrative limit."
++ bytecount << " bytes) exceeds administrative limit(" << sizelimit << ")."
+ << std::endl << std::flush;
+ return (1);
+ }
diff --git a/mail/courier/files/patch-courier__webmlmd.rc.in b/mail/courier/files/patch-courier__webmlmd.rc.in
new file mode 100644
index 000000000000..e947e3631820
--- /dev/null
+++ b/mail/courier/files/patch-courier__webmlmd.rc.in
@@ -0,0 +1,61 @@
+--- courier/webmlmd.rc.in.orig 2007-03-05 05:43:24.000000000 +0100
++++ courier/webmlmd.rc.in 2009-10-03 22:18:39.000000000 +0200
+@@ -1,48 +1,48 @@
+ #! @SHELL@
+
+-case "$1" in
++case "$0" in
+
+ /*)
+- prog="$1"
++ prog="$0"
+ ;;
+ *)
+- prog="`which $1`"
++ prog="`which $0`"
+ ;;
+ esac
+
+ set -e
+
+-case "$2" in
++case "$1" in
+ start)
+- if test "$3" = ""
++ if test "$2" = ""
+ then
+ echo "Usage: $prog start [configfile]" >&2
+ exit 1
+ fi
+
+- @SETENV@ -i @SHELL@ -c "set -a; . $3; $prog check || exit 1; \
++ @SETENV@ -i @SHELL@ -c "set -a; . $2; $prog check || exit 1; \
+ @courierlogger@ -pid="'"${PIDFILE}"'" $LOGGEROPTS -start $prog"
+ exit $?
+ ;;
+ stop)
+- if test "$3" = ""
++ if test "$2" = ""
+ then
+ echo "Usage: $prog stop [configfile]" >&2
+ exit 1
+ fi
+
+- @SETENV@ -i @SHELL@ -c "set -a; . $3;\
++ @SETENV@ -i @SHELL@ -c "set -a; . $2;\
+ @courierlogger@ -pid="'"${PIDFILE}"'" $LOGGEROPTS -stop $prog"
+ exit $?
+ ;;
+ restart)
+- if test "$3" = ""
++ if test "$2" = ""
+ then
+ echo "Usage: $prog restart [configfile]" >&2
+ exit 1
+ fi
+
+- @SETENV@ -i @SHELL@ -c "set -a; . $3; $prog check || exit 1; \
++ @SETENV@ -i @SHELL@ -c "set -a; . $2; $prog check || exit 1; \
+ @courierlogger@ -pid="'"${PIDFILE}"'" $LOGGEROPTS -restart $prog"
+ exit $?
+ ;;
diff --git a/mail/courier/files/patch-courier__webmlmrc.dist.in b/mail/courier/files/patch-courier__webmlmrc.dist.in
new file mode 100644
index 000000000000..d347eca8c071
--- /dev/null
+++ b/mail/courier/files/patch-courier__webmlmrc.dist.in
@@ -0,0 +1,11 @@
+--- courier/webmlmrc.dist.in.orig Sun Apr 8 21:03:03 2007
++++ courier/webmlmrc.dist.in Sun Jun 10 11:54:35 2007
+@@ -19,7 +19,7 @@
+ #
+ # The PID file. Don't change unless you know what you're doing.
+
+-PIDFILE="${PORT}.pid"
++PIDFILE=@piddir@/webmlm.pid
+
+
+ ##NAME: PREFORK:0
diff --git a/mail/courier/files/patch-imap__mkimapdcert.in b/mail/courier/files/patch-imap__mkimapdcert.in
new file mode 100644
index 000000000000..ec39e2fe1d66
--- /dev/null
+++ b/mail/courier/files/patch-imap__mkimapdcert.in
@@ -0,0 +1,11 @@
+--- imap/mkimapdcert.in.orig 2010-02-15 21:42:15.000000000 +0100
++++ imap/mkimapdcert.in 2010-02-15 21:36:46.000000000 +0100
+@@ -40,7 +40,7 @@
+ then
+ cp /dev/null @mydatadir@/imapd.pem
+ chmod 600 @mydatadir@/imapd.pem
+- chown @mailuser@ @mydatadir@/imapd.pem
++ /usr/sbin/chown @mailuser@ @mydatadir@/imapd.pem
+
+ dd if=@RANDOMV@ of=@mydatadir@/imapd.rand count=1 2>/dev/null
+ @OPENSSL@ req -new -x509 -days 365 -nodes \
diff --git a/mail/courier/files/patch-imap__mkpop3dcert.in b/mail/courier/files/patch-imap__mkpop3dcert.in
new file mode 100644
index 000000000000..fb2834b6d917
--- /dev/null
+++ b/mail/courier/files/patch-imap__mkpop3dcert.in
@@ -0,0 +1,11 @@
+--- imap/mkpop3dcert.in.orig 2010-02-15 21:45:23.000000000 +0100
++++ imap/mkpop3dcert.in 2010-02-15 21:37:01.000000000 +0100
+@@ -40,7 +40,7 @@
+ then
+ cp /dev/null @mydatadir@/pop3d.pem
+ chmod 600 @mydatadir@/pop3d.pem
+- chown @mailuser@ @mydatadir@/pop3d.pem
++ /usr/sbin/chown @mailuser@ @mydatadir@/pop3d.pem
+
+ dd if=@RANDOMV@ of=@mydatadir@/pop3d.rand count=1 2>/dev/null
+ @OPENSSL@ req -new -x509 -days 365 -nodes \
diff --git a/mail/courier/files/patch-imap__outbox.c b/mail/courier/files/patch-imap__outbox.c
deleted file mode 100644
index 61f2df1de141..000000000000
--- a/mail/courier/files/patch-imap__outbox.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- imap/outbox.c.orig Tue Jul 13 00:35:27 2004
-+++ imap/outbox.c Sun Dec 31 13:24:50 2006
-@@ -92,10 +92,10 @@
- argv[5]=NULL;
- }
-
-- return (sendmsg(message, argv, errlogger));
-+ return (ci_sendmsg(message, argv, errlogger));
- }
-
--int sendmsg(const char *message, char **argv, void (*err_func)(char *))
-+int ci_sendmsg(const char *message, char **argv, void (*err_func)(char *))
- {
- char buffer[512];
- int i;
diff --git a/mail/courier/files/patch-imap__outbox.h b/mail/courier/files/patch-imap__outbox.h
deleted file mode 100644
index 321f2da3051d..000000000000
--- a/mail/courier/files/patch-imap__outbox.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- imap/outbox.h.orig Tue May 27 17:55:10 2003
-+++ imap/outbox.h Sun Dec 31 13:24:27 2006
-@@ -10,7 +10,7 @@
-
- int check_outbox(const char *message, const char *mailbox);
- int is_outbox(const char *mailbox);
--int sendmsg(const char *message, char **argv, void (*err_func)(char *));
-+int ci_sendmsg(const char *message, char **argv, void (*err_func)(char *));
- const char *defaultSendFrom();
-
- #endif
diff --git a/mail/courier/files/pkg-install.in b/mail/courier/files/pkg-install.in
index c6e6ebd6002d..3c3cf76b9886 100644
--- a/mail/courier/files/pkg-install.in
+++ b/mail/courier/files/pkg-install.in
@@ -52,16 +52,16 @@ replace() {
}
if [ ":$2" = ":POST-INSTALL" ]; then
- if yesno "Would you like to activate Courier in /etc/mail/mailer.conf" n; then
- mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Courier sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/bin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/bin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/bin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/bin/mailq" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/makealiases" >> /etc/mail/mailer.conf
- echo "Done."
- fi
+ if yesno "Would you like to activate Courier in /etc/mail/mailer.conf" n; then
+ mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Courier sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/bin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/bin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/bin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/bin/mailq" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/makealiases" >> /etc/mail/mailer.conf
+ echo "Done."
+ fi
fi
diff --git a/mail/courier/files/pkg-message.in b/mail/courier/files/pkg-message.in
index 79319066d9e7..ec6cc1fdf387 100644
--- a/mail/courier/files/pkg-message.in
+++ b/mail/courier/files/pkg-message.in
@@ -26,6 +26,16 @@
courier_enable="YES"
sendmail_enable="NONE"
+ Note: in newer OS versions you should change variables
+ used in /etc/rc.conf file, as NONE for sendmail_enable
+ is deprecated and will be not supported in future:
+
+ courier_enable="YES"
+ sendmail_enable="NO"
+ sendmail_submit_enable="NO"
+ sendmail_outbound_enable="NO"
+ sendmail_msp_queue_enable="NO"
+
Also, you will want to disable some Sendmail
specific daily maintenance routines in your
/etc/periodic.conf file: